Navigation display IN IPC

Hi, new to this forum. Wondering if anyone can help/advise. About a year ago I bought a sync 3.4 second hand unit to replace my sync2.0. It was on 19200. I’ve always had the issue where the ipc doesn’t clear the road name for navigation so when the next road is shorter it still shows part of the previous road. I thought be updating to the latest version 20196 it might fix it, but it did not. Could it be down to ipc firmware as it was never an issue with sync2. Has anyone else seen this when replacing sync2 with a sync 3.4 unit. This is for a UK mondeo 2015.

By the way, I’m so grateful I found this group, the software update process is superb, again some reason my unit always stated it was up to date, but clearly not as I’m 4 versions behind. Great work and thanks.

It does sound likely to be an ipc firmware issue in honesty, first time I’ve heard of it. There is a configurable option in the apim for the format of the navigation repeater (Motorola and Intel format) so you could try changing that, but it’s more likely to break the distances displayed than fix this issue. Nothing to lose my trying it though.

I personally don’t like updating ipc firmware as they are one of the more sensitive modules (permanent mileage displays) , if I were you I’d pay for a dealer to do the update for you, but then I am cautious!

Yeah that’s what I’m thinking. I will try ipc repeater setting though, as you say no harm.

Yeah I don’t have the right tools to do ipc firmware upgrade. Would be nice but I’m not going anywhere near Ford for them to charge an arm and leg :stuck_out_tongue_winking_eye:

Worth asking if you still get it main dealer serviced, I don’t think it’s too expensive

Take a look at this and see if it helps…

Instrument Cluster Navigation (IPC) — (SOLVED)

Hello all, I have upgraded my sync 3 to 3.4 the other day and I don’t have the option to turn on navigation prompts for the instrument cluster in the display settings. I opened up forscan and checked and my navigation repeater is enabled, but it’s…



IPC firmware update sorted this. This can be closed now. Thanks for the help here.


Glad that worked for you. Take care.

Thanks for the update, I’ve purchased a 2015 mondeo since your post and it has the exact same issue you describe. I’ll be doing the IPC upgrade now. Thanks!

1 Like