Navigation repeater data from Android Auto question

What is your SYNC Region? US

What is your current SYNC Version? 3.4.21098

Do you have Navigation? Yes

Do you have a error message, if so what is it? No


Please paste your log output or provide the URL to your log file below


Please describe in detail your issue below

More of a curiosity than anything as I don’t think this has been well documented and unsure if it is related to the Intel/Motorola formatting bit. But when utilizing Navigation via AA like Google Maps or Waze, the Navigation info displays on the IPC, but not all info is there. In most cases it just shows the current street name, speed limit, next street name and distance to turn (with this number being accurate). Total ETA and trip distance for example do not show and the total distance usually shows as like 0.00km despite all my units being set for miles and the factory nav shows miles on the IPC when in use.

Again, this is a curiosity and not a make or break bug. Haven’t seen this in particular documented anywhere. Not sure if it is a known/expected bug or maybe I should try changing the Motorola/Intel bit?

Pretty sure this is related to the IPC AsBuilt but @Louage or @F150chief can probably help better as they are the “AsBuilt Gods” :smiley:

1 Like

This has been discussed over at F150Forum with the trucks, but same principle, info in the IPC via Nav Repeater function. What you see is normal, at least for US vehicles using Telenav navigation systems. It is the same for iPhone. It would be nice to have the extra data, but I think this is actually an Android and Apple issue, not a Ford issue, as the repeater function does work.

It’s definitely a Ford issue, Android Auto works fine on other cars and i assume Apple Carplay also does, to be honest it works fine in my fiesta also though :man_shrugging: definitely seems to be car specific

Then it’s normal for it to exhibit this behavior on a NA Ford? Maybe EU Fords are different? I only have a Ford and a Lincoln, so I wouldn’t know if I was missing anything…

I don’t know, might be worth seeing if others chime in, it can be temperamental but I’ve seen it work in the EU atleast.

Not specifically related to what you talking about, but I also think this is related to Ford. I’m not sure if because Google does not fully understand Ford’s system, or if Ford does not make things easy.

Simple example: my car “does not need” GPS lock to have incar gps, since it knows where it’s based on speed and steering wheel movement…
When I use Gmaps, the phone does not use location services, it uses the car’s GPS. But if I enter an underground garage, then the phone tries to get a GPS lock instead of using the car’s extrapolated position.

This does not happen on other brands, so they can “navigate” even underground, because Android Auto uses the car’s GPS information…

So yeah, not sure who’s fault is it really… But I’m blaming Ford, just out of habit…

It will be ford, Android Auto provides car manufacturers API information etc, Ford doesn’t provide Android Auto things.

So this covers the call on the AA side that sends this data to the vehicle and implies pretty definitively that all relevant data including trip estimates (which is what goes missing on my vehicle) is supplied to the vehicle from AA. But it also comes right out and says this is vehicle dependent and not all features/data will be displayed. lol.

NavigationManager | Android Developers

So yeah. Seems like Ford’s end of things. Not too surprising. Also given this is a MyFordTouch > Sync 3 upgrade, not sure how that impacts things despite the built in nav showing on the IPC perfect. Either way, no huge worry from me. Just a fun little curiosity.

And just as a reference, this is what I get using Google Maps in my C-Max. This was with a long 4-5-ish hour long route set as a test. The top line is what is consistently missing with the inaccurate km unit. The turn-by-turn info in the main section is usually always accurate including the distance-to-turn number:

1 Like

This is exactly what I experience in my F-150 and Nautilus in NA. The Sync unit (screen) shows all of the info, the IPC does not.

A calibration update of the apim, ipc or both may help here.

I’m sure we have had this conversation on the forum before, changing some IPC settings fixed it for them did it not?

I remember a conversation about the NAV Repeater working or not, having to do with Motorola or Intel, which solved that issue. But that was whether the nav info showed in the IPC or not. Could be something there though…