Navigation screen is mostly black and completely blank after 3.4 build and map update

Updated from 3.4 build 21020 maps NA 2 20 to 3.4 build 22200 maps 2 21. Now the navigation screen is mostly black and nonfunctional. In addition the display brightness icon is grayed out. Can anyone help me with this as the original build worked great including navigation.

SYNC Region: North America & Canada

Navigation Variant: Yes

Install Type: Retrofitted

Old SYNC Version: 3.4.21020

New SYNC Version: 3.4.22200

Do you have a error message, if so what is it?
No error messages.

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: Yes

Syn3 Updater Log File!AjvT4lEPxDvgiz-hF8hyNVB6S1BY?e=YvTizI

Please post your installation log file from the USB…

This is normal for versions past 3.4.21020.!AjvT4lEPxDvgiz-hF8hyNVB6S1BY?e=YvTizI

Am not sure this is it. If not feel free to comment or inform me better. Thanks

Have you performed a Master Reset?

The log file looks ok. Did the reformat finish all the way and end at the GREEN screen? The system would have rebooted on it’s own and come up. If the system came up in this state then you must perform a master reset to reset it.

Is the map display the only issue other than the grayed out illumination setting?

Yes did the master reset twice. the only issue is the maps not displaying, plus the grayed out illumination setting. Everything else works fine.

yes the reformat finished all the way to the end at the green screen.
I’m using a Sandisk Ultra 3.0 thumbdrive. Maybe that has something to do with the issue.

The illumination setting is normal, this is a change in the way the APIM integrates into the vehicle illumination system.

It sounds like there is an issue with the maps installation. Can you see any of the map, is it there and just dark or a completely black screen when switching to NAV? Does the “About Sync” screen indicate the maps are presently installed?

The Sandisk is a 64 GB
The illumination setting did work on Sync version 3.4.21020 on occassion. Approximately once every 3 or 4 times turning the radio on.
It did work on the first boot up on the new sync version including maps. Immediately after doing a master reset with the new sync version the maps disappeared and illumination setting grayed up permanently.

No maps are visible, only black. the home icon is visible at the top left.
Yes it does indicate maps are installed with the latest version

How soon did you do a master reset after the APIM rebooted from the reformat mode? If you have an older Sync APIM, it takes about 5 minutes for the APIM to finish installing all of the files, especially the NAV files. Wait at least 5 minutes to perform the master reset.

I would prepare another installation of the system, same as you did last time. However, I would recommend you stay at Sync 3.4.21265 since the later versions have documented issues. 3.4.21265 is the most stable recent version. You could also go back to 3.4.21020 if you desire, the maps are compatible.

That maybe the issue. I’ve been doing the master reset within 30 seconds, certainly within 45 seconds of install. I did not know to wait at least 5 minutes.
I just installed the old original version. Am waiting at least 5 from now.
I may try version 3.4.21265 as you suggest if all goes well with the original version sometime later today.
Thank you very much for your help. You’ve been great especially with the lateness of the hour.
I’ll replay in apx 5 minutes if the old version has been successful or not.

No luck. The nav screen is black. You can see the home icon time etc at the top of the screen and the radio, navigation and other basic icons at the bottom as before but navigation is black and does not respond to punching the nav icon button other than popping up a black screen.
I’ll try again later today sometime with the version you suggested. For some reason navigation is just not loading.
Thank you again for help with trying to resolve the nav issue.

Could you run the APIM Interrogator tool in the Syn3 Updater and post the results? You can remove your VIN from the file…

You did a complete reformat of the APIM re-installing the maps and apps?

I think this is the apim interrogator tool info you are asking for. I’m not sure what exactly a complete reformat of the apim means at the moment as I am not well versed on computer terms. All this is new to me. Thank you for your help and patience with me as I try to access the reformat procedure.
The radio screen now says navigation failure-please see dealer for service after removing the interrogator tool usb thumb drive in a box on the upper right of the main screen but is still mostly black as before after pushing the navigation button. It did not do this before.

autoinstall.lst (246 Bytes)
Sync_WV1T009F_1F.xml (11.0 KB)

Complete reformat is using the Syn3 Updater to perform a reformat of the Sync 3 APIM to install apps and software. This is reformatting the eMMC storage and wiping all user settings, logs, etc. This places the unit basically back to factory, but with new apps , maps, etc. This is what you did the first ime, but something happened causing the nav to malfunction.

So, what I wanted to know is if you performed another reformat or just an app downgrade when you said you installed the original version (3.4.21020) above…

Looking at the interogator log, the maps and other files are indeed installed, however. there may be corruption in the installation, so that’s why I wanted you to do the installation over. This would normally clear the corruption.

Something I noticed in the interrogator log is the age of the APIM and the firmware files loaded. This is one of the first NAV Sync 3 APIM’s, (GB5T-14G371-CFC) known to be problematic and have a higher failure rate than the newer generations. This is a retrofit into a Sync 1 vehicle based on your factory asbuilt information. This is the info on the retrofitted Sync 3 APIM:

“On-line Diagnostic Database Reference Number” didValue=“F110”
“ECU Core Assembly Number” didValue=“F111”
“ECU Delivery Assembly Number” didValue=“F113”
“ECU Calibration Data #1 Number” didValue=“F124”
“Private Sub Node #1 Serial Number” didValue=“F141” responseLength=“16”>
“Vehicle Manufacturer ECU Software Number” didValue=“F188”

One of the documented issues with this APIM, particularly this model number, is the firmware files. This is a Ford production issue, nothing you did…The GB5T-14G374-AF file is known to have errors in the storage addressing, which leads to issues as this. This can be fixed, but will require the upgrade of the firmware on the APIM. This will require a paid licensed version of FORScan and a USB OBD adapter for the firmware programming.

So, try the reformat again like you did originally. If that fails, it is likely the firmware is corrupted and will need to be reloaded.

I did the 3.4.21265 version with maps twice with the same results, no navigation
I did the 3.4.21020 version with maps again with the same results, no navigation

I just did only the maps download now and waited apx 10 minutes before master reset. Maps is missing under the “about sync” screen. The main screen icon is there but still black screen when pushed.

I’ll try to do the apim firmware upgrade as soon as I can figure out how to do that.
If that fails I’ll do one more update with all the original programming and see what happens. If no no maps then I’ll just have to get another apim from a reputable seller.
Thanks for your help.

Hold off on the firmware thing…
Where did you get your APIM asbuilt? I just had the chance to go thru some of it and it is not correct for your vehicle.
It looks like you have Navigation Enabled (NNG External HMI) set. This is for ROW/NNG countries, not NA or EU. If this is true, the NAV will not work.
You need to check this and set the Nav to Navigation Enabled (Telenav Common HMI).

The asbuilt codes came from motorcraft service free info. After install the retrofit 4.2 to 8 inch unit it added serveral lines of code. My preliminary research leads to believe that these aren’t causing issues at present.
My apim is set to: External NAV N GO interface
There’s 3 other options. Disabled, Enable common interface, External Telenav interface

That is incorrect. That is for NNG maps. You have Telenav maps.

Try this. You will likely need to perform a master reset.

Bingo!! Navigation is back! Yeah!!
Build 3.4.21265
Maps version NA 2 20
You are a genius!
I may get brave enough to update to the latest maps eventually, but I’ll leave well enough alone for now.
Enable common interface on the apim navigation choice in Forscan fixed it. Yeeaahh!!