Newbie questions - Error MEM-ERR01

Trying to do a map update downloaded from the Ford site, my maps are currently at F11. I get a MEM_ERR01 error. I ran the PU5T-14G386-BB_1690840002000.tar.gz tool to clear the slogs, which completed without error but I still get a MEM_ERR01 error. How can I tell what the update did, I can see that it outputs messages to a log, how can I see the log?

I ran the Imterrogator Log which to my uneducated eye seems to suggest I’ve loads of free space?
Version NU5T-14G381-AA
APIM Model: 4U5T-14G371-GJA
APIM Type: Navigation
APIM Size: 64GB
APIM Free Space: 11G
15/10/2023 15:57:34 +00:00

Partition Type = Free / Total
/fs/sd/MAP/ = 1.0M / 1.1G
/fs/sd/MAP/ = 14M / 2.8G
/fs/sd/MAP/ = 14M / 2.3G
/fs/sd/MAP/ = 7.8M / 1.5G
/fs/sd/MAP/ = 17M / 2.2G
/fs/sd/MAP/ = 21M / 3.8G
/fs/sd/MAP/ = 336K / 38M
/fs/sd/MAP/ = 5.6M / 3.2G
/fs/sd/MAP/ = 25M / 3.2G
/fs/Nuance/ = 27M / 4.6G
/fs/Nuance/ = 29M / 4.8G
/fs/Nuance/ = 25M / 4.3G
/fs/Nuance/ = 35M / 3.6G
/fs/Nuance/ = 8.4M / 1.9G
/fs/Nuance/grace = 21M / 1003M
/fs/rwdata/ = 591M / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 89M / 90M
/fs/mp/ = 84M / 1.4G
/fs/mp/resources = 332K / 72M
/fs/images/ = 11G / 54G

Installed Packages


APIM AsBuilt
DE00: 0A6A09DE10023C440882
DE01: 554B0105C002088028000405
DE02: 0400010000
DE03: 000020F1130101
DE04: 17FC181A2F1C
DE05: 80
DE06: 0A003B000000003A980000043068008E

Is there something I can do to resolve this issue and run the Ford update?

Second question, I’m tempted to run the CyanLabs updates but unsure if I’m MY20 or not. I dont want to brick my APIM!
My van was registered in June 2020. The For site lists it as a 2018 V408 Transit connect. The Bezel Diagnostic says the assembly part numbher is 4U5T-14G371-GJA and a H/W Part number of 1U5T-14G371-FE. Can anyone tell if this is MY20?

I’m still unsure about the term MY20 , is this a hardware issue or a software issue? Can someone explain please.


SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Unknown

Install Type: OEM

Old SYNC Version: 3.4.22200

New SYNC Version: 3.4.22200

Do you have a error message, if so what is it?
Updatinf Maps from F11 I keep getting MEM_ERR01 error.

Update Method: Official Ford

Well, without having the actual autoinstall.lst file we can’t know… Bottom line: if the referenced files on that .lst file are installed (which you can check with the interrogator log output), it worked… Since it’s giving you a mem error, I doubt it, but won’t be sure until we see the .lst file.

One workaround would be to split the install into multiple ones.

As per our hardware database, that’s not a MY20 APIM and can be reformatted. If the APIM is not MY20, chances are the screen isn’t as well. The interrogator log can’t sense/see the screen, only the APIM.

It depends on the point of view. Staring with MY20 models Ford changed at a hardware level on the APIMs and screens, and the leaked Ford tool for reformatting cannot handle that, thus bricking the units if they are reformatted.
So you can see it as a software, hardware or software& hardware “issue”.

Thanks for the quick response, sorry more questions… just trying to understand things.

The RW Data Cleaner tool looks like it just runs a bash script. The script does a series of echo commands. Is it possible to see these anywhere?

for example the first few lines of the script are


# slay_vca shell script

# Signal handler.
	echo "Received signal.  Update aborting."
	exit 1

Think it about it this way: if you could somehow see those logs, you would not need the tool to erase the contents of a folder/partition… Makes sense?..

Besides, you do not have issues with the rwdata partition…

Thanks for the help!

yes, I was think more about other scripts just using that one as an example.

With regards my failed ford F11 maps update this is the autoinstall.lst script. Can I just mod this so that it does each update individually and run it again multiple times for each tar.gz file?

What does the “Options = Delay,Include,Transaction” do? Would I need to change this line to something else

; SYNC3 Consumer Application Upgrade - Release 3.4.22200 - Only for Nav/EU assemblies.

Item1 = 4U5T-14G422-BAH
Open1 = SyncMyRide\4U5T-14G422-BAH.tar.gz
Item2 = 4U5T-14G422-BBH
Open2 = SyncMyRide\4U5T-14G422-BBH.tar.gz
Item3 = 4U5T-14G422-BCH
Open3 = SyncMyRide\4U5T-14G422-BCH.tar.gz
Item4 = 4U5T-14G422-BDH
Open4 = SyncMyRide\4U5T-14G422-BDH.tar.gz
Options = Delay,Include,Transaction
Item1 = GB5T-14G386-AD
Open1 = SyncMyRide\GB5T-14G386-AD.tar.gz
Item2 = LU5T-14G386-CA
Open2 = SyncMyRide\LU5T-14G386-CA.tar.gz
Options = Delay,Include,Transaction

Can I just mod this so that it does each update individually and run it again multiple times for each tar.gz file? See below.

What does the “Options = Delay,Include,Transaction” do? Would I need to change this line to something else

Item1 = 4U5T-14G422-BAH
Open1 = SyncMyRide\4U5T-14G422-BAH.tar.gz
Options = Delay,Include,Transaction

The provided file is for upgrading nav voice packages, not maps.
You already have those packages installed, so there’s no point in reinstalling them.
Since you already have an interrogator log with those files installed, you should be able to upload that log to ford to let them know the install was ok.

That was one of my suggestions, but it’s not needed since you have the files installed.

Check Detailed explanation of autoinstall.lst available? - #2 by F150Chief

Thanks that explains why my navigation version is still showing F11.

Its always worthwhile to ask someone who knows!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.