No Car Play after upgrading to 3.4 and replacing USB Hub - 2016 C-Max

I have a 2016 Ford C-Max. I used the automatic update to update to Sync 3.4. I also replaced the USB Hub with a USB 3.1 version.
Everything appears to work now that I upgraded to Version: 3.4.23188, but I cannot get Carplay to work or show up.
I have an iPhone 15 with USB-C and I am using a USB-C cable.
The phone charges. Bluetooth works, but nothing else.
Could it be my cable?
Could it be the new hub (its a 3rd party hub from Amazon users claim works with carplay)
Does this version of Sync work with a 2016 C-Max?

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0

New SYNC Version: 3.4.23188

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File




CP works from at least Sync3 2.7 and onwards.
I run 3.0 and it works.

If using a certified cable with the proper hub you can’t get CP to work then it’s because you skipped the activation version. If that’s the case there’s not much you can do since you can’t go back to that intermediate build now.

You can try with AA since it’s more forgiving (about HUBs) than CP… if that does not work either, well, there you go…

Well don’t I feel silly.
After trying for 1/2 an hour and posting this, I got it to work.
I tried a usb-c to usb-c cable (different cable), and suddenly it worked.

So sorry about that. And I can confirm it does work with a 2016 Ford C-Max and a 3rd party USB-A and C replacement outlet.

Also, the Cyanlabs software worked perfectly. I updated my maps too with no issues so far.

Well, that’s good to hear, don’t feel silly.
Reports are mixed on these cases, after upgrading to 3.4 from no-CP scenarios, some people got this working but others don’t.
So be happy that it worked in your case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.