Out of space for the file? Bricked Apim

Hi.
I have an Apim HP5T-14g371-BAF.
I tried to update it to MY18.5.
Unfortunately, the module has been blocked.
I can’t upload one file to it and I don’t know why.

You can see it in the photo.
It looks like there is no space for him.
Any help?

You have selected the file for EU without NAV, are you sure it is correct? See here below the list of possible 14G375 files:

1U5T-14G375-A*.vbf 8GB / 16GB EU without NAV
1U5T-14G375-B*.vbf 8GB / 16GB NA without NAV
1U5T-14G375-C*.vbf 8GB / 16GB ROW without NAV
1U5T-14G375-D*.vbf 32GB NA with NAV
1U5T-14G375-E*.vbf 32GB CHINA with NAV
1U5T-14G375-F*.vbf 32GB XX (it means ANY region) with NAV (Telenav)
1U5T-14G375-G*.vbf 32GB ROW With NAV (NNG)
1U5T-14G375-H*.vbf 64GB EU with NAV
1U5T-14G375-J*.vbf 32GB TURKEY with NAV
1U5T-14G375-K*.vbf 32GB UAE with NAV (NNG)

HP5T-14G371-BAF
8GB No Nav

For a US NON-NAV vehicle, you should be using 1U5T-14G375-BA.

Yes. I know that.
I have tried several files. This one is an example.

APIM Firmware Flash Rescue - Ford / Information - CyanLabs Official Community

Start over and return the unit to stock to recover it.