Screen went black after updating from 3.4.22110 to 3.4.22251

While updating the Sync 3 software from 3.4.22110 to 3.4.2225. The screen rebooted and went black. It never turned back on.


SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Unknown

Old SYNC Version: 3.4.22110

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?
NO

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.11.8.0

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

I did not get a log output 

Did you try a reset?

Yes I have reset the unit multiple times. I have also tried to reset the firmware with ForScan and it failed.

What is the part number of the APIM? Is it MY20?

Is not a My20. Part number below

APIM - Accessory Protocol Interface Module
Part number: GB5T-14G371-CDA
Calibration level: GB5T-14G371-CDA (latest known: GB5T-14G371-CJU)
Strategy : GB5T-14G374-AE
Calibration: GB5T-14G375-CA

I’m getting the following DTC:
Code: U3000 - Control Module
Code: U2101 - Control Module Configuration Incompatible

The APIM configuration is corrupted or incomplete. Reload the entire asbuilt at once thru FORScan…Once you reload the asbuilt, the APIM will reboot. Once this is done, reset the APIM using FORScan and it will reboot again. At this point the unit should come back and the DTC’s should clear. You will need to clear the DTC’s manually and see if they come back.

If this does not work, you will need to reload the Strategy file, along with the Calibration file. This is because the early files like -AE, -AF are known to have address space issues. Upgrading the unit to 3.4 likely caused an issue here with these firmware files. This can be fixed, just reload the asbuilt and do the reset procedure above first.

Since this is a 2015 Mustang, you will not use the factory asbuilt as that was Sync 2. Not compatible. You will need to use a copy of the existing asbuilt, hopefully you made backups.

I have tried to reload the asbuilt APIM. Is there a file that I need to get to do that? I have also tried multiple strategy files to load the only file that seems to sort of get the unit to respond is the -AF. I cannot find a backup for the -AE. Everything else that I load fails.

I did not make backups of the existing asbuilt. Because I was updating from a USB stick created with Cyanlabs. Does that mean I’m out of luck?

Can you obtain the VIN of the donor car

I reached out to the vendor I bought it from. Waiting for a reply.
Is there anything else I can do? in the case they do not get back to me?

If you loaded the -AF file from Ford then the memory addressing is corrupted. You will need to use the correct file that is fixed for your region. Luckily, NA.

See your PM…

Thank you for the help.

Since this thread has been silent for 10 days, I’m assuming everything got sorted out privately, so I’m closing the thread.

The issue was never sorted out. I ended up putting back in the Sync 2 in the vehicle. I’m guessing that my Sync 3 module is bricked. However, I do not get any errors in Forscan, so I’m able to see the module to be healthy. Still the screen is black.

At this point, I’m not sure if there’s anything else to try.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.