Hello I’m hoping someone can help me. I went to upgrade from sync 3.0 today to sync 3.3 19052 with maps 2.21 2021 NA and I keep getting sign_error2 message the red screen. My car has navigation and is the original apim with no modifications. I’m using a 32GB kingston drive and on the latest cynlab updater using AutoInstall. Any help would be appreciated as my screen is stuck on the upgrade screen can’t get out of it.



Post the log for USB creation

1 Like

Ok thank you I’m trying it one more time and I will post the log in a few minutes if this doesn’t work.


Hi Sandman just wonted to report back as i tried another USB not 3.0 and worked like a charm everything updated and new maps installed and working after a master reset. please close this thread



Thank you for the update.
Based and depending on the log that would had been my recommendation, but wanted to see the log first.
Enjoy the upgraded system.

1 Like

Thank you. Just a quick question is the 3.4 version much better and snappier is the upgrade in your opinion worth it. I’m think of trying the 3.4 version what are your thoughts.

Thanks again


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.