Stalled update from Sync 3.4 (19274)

Sync_VZ5Y068C_1FTEW1EG8FFC05233.xml (11.1 KB)

I tried to update my 2020 APIM from build 19274 and Maps from NA 118 with Syn3 updater all at once.

Updating either stalled or I didn’t wait long enough 2.5+ hours.

Now my current Sync 3.4 about page shows build 19274 but the Maps show NA 220

Then I tried to only update to build 3.4.23088. APIM shows Software Updating for over 2 hours and didn’t complete.

I tried to only update Maps from NA 220 to NA 220 (maybe didn’t complete from first attempt?) but now I get a Mem_Err01.

I removed GraceNotes and still get a Mem_Err.

I attached my current interrogator log.

My APIM is from a 2020 F150 which I installed into a 2015 F150.

Im using a Lexor 64GB Thumb Drive.

Thanks for any Advice to get my APIM upgraded to the latest version.


Something has gone wrong with your APIM.
Currently, you do not have any space left for the unit to process any update, which is really bad.
From the log you sent, this is seen:

  • "APIM Free Space: 1.5G ", bad
  • A lot of maps installed, but without details, bad.
  • Packages installed listed do not make any sense, since it says you only have 5U5T-14G391-CK installed, which is a VOICE file for ROW (not that big of a deal). That is of course, besides 5U5T-14G381-CJ which is Sync3 itself. No maps, nothing else, which is not true since the APIM is full of data.

The thing is, if the unit as many maps installed you can’t delete them because it’s a MY20 APIM.
Was the donor F150 a NA one?, according to the asbuilt it’s.

Have you performed a master reset?. If not, try perfoming one and running the interrogator log again to see if the unit tells us what’s on the unit actually.

The last two things I did was master reset then take interrogation log that is posted.

My APIM is running fine. Navigation is working too.

Does the about sync3 mention Gracenotes installed?

Go into bezel diagnostics to check if the installed packages are there.
Usually you can go into that section while keeping EJECT + FF/SKIP for a few seconds until it goes into that menu. Browse the APIM section to see if you can find any information about what’s installed.

The bottom line is: you have a MY20 APIM that’s full of stuff (possibly maps) and won’t process any more updates (Maps, Sync3, whatever it may be) because it only has 1.5 GB of free space.
You need to clear some space up, but since you can’t reformat it, it’s trickier than that.

Usually, you could remove gracenotes (hence my opening question) and install a small voice package… BUT I do not think those are the issue, but a failed maps installation.

You didn’t answer this question: “Was the donor F150 a NA one?”

Yes. Donor vehicle was NA.

I removed gracenotes because I was getting Mem-err0 when I tried to reinstall the latest Sync 3.4 build again.

Removing gracenotes did allow me to get around the mem-err0 to try to upgrade to latest Sync 3.4 build only. But it went 2+ hours so I turned my truck off.

You will need to jailbreak the APIM and remove all of the maps, then install the correct files again. There is no other option other than buying a new APIM.

You cannot reformat this APIM, do not try.

Will try the jailbreak later today. Thanks.

I also found a script that you can run on a jailbroken APIM that will remove all files associated with navigation. Made for MY20 APIMs since you can’t reformat them.

Everything worked.

I successfully updated to the latest maps after an interrupted installation on my “MY20” APIM.

Applied jailbreak and ran navigation file removal script took less then 10 minutes.

Running the Syn3Updater to update Nav maps took a total of 1 hour and 35 minutes.

Installation ran 35 minutes until the first reboot, 30 minutes until the second reboot, then a final 30 minutes until completion. Which required a master reset to get the Nav up and running.

This time I didn’t follow the pup-up window that said to cycle engine off then on.

Just leave the Syn3Updater thumb drive in and don’t touch anything through out the ENTIRE process (1.35 hours for me). Let it cycle the APIM on its own. Which it will do 2 times.

Thanks for the quick replies and help!

Awesome, thank you for updating the thread with the results. That’s why I said that removing old maps was tricker than just reformatting since JB was required.

Anyways, we are glad it worked out ok.
Take care.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.