SYNC 3.4.21098 won't update

Hello. I have Sync 3 APIM with 3.4.21098 version non-nav - Canada region. I tried to update it to latest 3.4.22251 but I did it a few times, but every time I got the same. I put the USB stick - there is only information “Installing firmware updates” for over 1 hour and then nothing happen. Version is still 3.4.21098, logs file are empty. What should I do? Focus 2017 with Sync 3 - autoinstall mode.

SYNC Region: NA

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.4.21098

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: (stable)

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Branch: Stable
Operating System: Microsoft Windows 11 Home (2009)

Version: 3.4.21098
Region: NA
Navigation: False
Install Mode: Auto-Wykrywanie (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Auto-Wykrywanie

Mode: Drive
Model: SanDisk Ultra USB Device
Size: 14,5GB
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater Stable - Autoinstall Mode - Sync 3.4.22251 NA

Item1 = VOICE - 5U5T-14G391-CS_1660783942000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G391-CS_1660783942000.TAR.GZ
Item2 = GRACENOTES - 4U5T-14G423-CC_1615429225000.TAR.GZ
Open2 = SyncMyRide\4U5T-14G423-CC_1615429225000.TAR.GZ
Item3 = APPS - NU5T-14G381-AB_1665525837000.TAR.GZ
Open3 = SyncMyRide\NU5T-14G381-AB_1665525837000.TAR.GZ
Options = AutoInstall

5U5T-14G391-CS_1660783942000.TAR.GZ (385,5MB)
4U5T-14G423-CC_1615429225000.TAR.GZ (564,2MB)
NU5T-14G381-AB_1665525837000.TAR.GZ (869,8MB)

[20.02.2023 19:16:33] Selected Region: NA - Release: Sync 3.4.22251 - Map Version: APIM BEZ NAWIGACJI 
[20.02.2023 19:16:33] Install Mode: Auto-Wykrywanie (autoinstall) Forced: False 
[20.02.2023 19:16:33] MY20 Protection: Auto-Wykrywanie 
[20.02.2023 19:16:33] Formatting USB drive
[20.02.2023 19:16:33] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[20.02.2023 19:17:25] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[20.02.2023 19:17:27] Validated: 5U5T-14G391-CS_1660783942000.TAR.GZ (Skipping Download) 
[20.02.2023 19:17:27] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[20.02.2023 19:17:28] Validated: 4U5T-14G423-CC_1615429225000.TAR.GZ (Skipping Download) 
[20.02.2023 19:17:28] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[20.02.2023 19:17:31] Validated: NU5T-14G381-AB_1665525837000.TAR.GZ (Skipping Download) 
[20.02.2023 19:17:31] Preparing USB drive
[20.02.2023 19:17:31] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[20.02.2023 19:17:31] Copying: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[20.02.2023 19:18:05] Validating: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[20.02.2023 19:18:06] Copied: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[20.02.2023 19:18:06] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[20.02.2023 19:18:06] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[20.02.2023 19:18:57] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[20.02.2023 19:18:58] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[20.02.2023 19:18:58] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[20.02.2023 19:18:58] Copying: NU5T-14G381-AB_1665525837000.TAR.GZ 
[20.02.2023 19:20:16] Validating: NU5T-14G381-AB_1665525837000.TAR.GZ 
[20.02.2023 19:20:17] Copied: NU5T-14G381-AB_1665525837000.TAR.GZ 
[20.02.2023 19:20:18] Generating Autoinstall.lst


Follow this tutorial → Tutorial: Sync 3.4 NON-NAV APIM: Failure to Update to Newer Version Sync 3.4

1 Like

Okay, i did everything step by step: downgrade to older version (success) and then while trying to auto-install latest update: there is no “system software update” info at the top of screen, so I do not know if I have to wait for update or the update is simply not being installed. In my opinion USB drive was prepared properly, but I am not sure if I have to turn of MY20 protection? My car is from 2017. I tried also master reset but it did not help :frowning:

Since you said you performed the actions steps by steps, I have 3 questions:

  1. what was the amount of free storage on the APIM before removing packages?
  2. what was the amount of free storage on the APIM after installing the small voice package? (this was the very last step before downgrading)
  3. What’s the amount of free storage on the APIM on 3.3.xxxx ?

With your reply to these questions, please also provide:
A) interrogator log of the current status for the APIM
B) information on which kind of USB are you tring to use, reformat?, autoinstall?. Provide a screenshot of the USB’s root contents, all .LST files’ contents and SyncMyRide folder’s contents.

  1. As I remember before removing anything there was 1.7GB free of 3.GB.
  2. I checked storage again only after uninstalling Gracenotes and then there was 2.4GB
  3. Also 2.4GB

Interrogator log:
Wersja 4U5T-14G381-AN
Model APIM: HP5T-14G371-BCA
Typ APIM: Non-Navigation
Rozmiar APIM: 8GB
Wolne miejsce APIM: 2.4G
21.02.2023 13:44:34 +00:00

Partition Type = Free / Total
/fs/Nuance/ = 3.0M / 465M
/fs/rwdata/ = 959M / 1.2G
/fs/mp/ = 505M / 1.4G
/fs/images/ = 2.4G / 3.0G

Installed Packages

APIM AsBuilt
DE00: AB28640300008A170000
DE01: 434101064082000000000005
DE02: 0002010000
DE03: 01001301020001
DE04: 17E8179828BE
DE05: 80
DE06: 10043300000000135600000430670072

I think that the screenshot of USB is not required now, there were autoinstall.lst, DONTINDX.MSA and SyncMyRide folder with packages files on the root.

I tried Master Reset, then uninstalling again Gracenote packages and I did auto-install without gracenote package and update was successful. I added manually Gracenotes later and it also worked. I do not know what happened but I think that everything is fine, but the after update there is still flickering dimmer what is most annoying :smiley: Thx for help :slight_smile:

Thank you for the information.

Awesome, glad it worked.
Based on the logs, 2.4 is plenty of space for the tool to process.

Just remember that in the future, should you decide changing build, you will need to make room again.

About dimming, you could downgrade to an earlier version where the toggle was still available.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.