SYNC 3.4.22251 not working anymore

Good evening everyone,

I hope this post finds you well.

Basically I updated my AYNC APIM (ver 3.0xxx) a few months ago to SYNC 3.4.22251 by using the Sync3 Updater and the installation was succesfull, no problems at all.

I startted having some issues couples of week ago when the unit began to lose setting (at every car start it asks if I want to keep automatic updates, the languages is set on english etc…) and it didn’t show Apple Carpay anymore.

When I connect the phone the carplay logo shows on the phone and the sync kets me select whether I want to allow carplay setting or not but at the end it doesn’t connect.

I have tried all the solutions reported in the thread where it is explained how to reset the unit but all of them are insuccessful.

I am still getting the error “INSTL_ERR12” everytime I pop the USB device in.

Even if I try to perform a rwdata cleaning I still get the same message as soon as I insert the pendrive.

Is it there any possibility t solve it according to your experience or do I have to change the APIM?

Thank you all,

Kind regards

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.12345

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

1 Like

Hello there.

Sadly, all known methods for solving the full rwdata partition issue are located on that thread. If none of those work, JB included, there are no other actions we could recommend.

Have you been able to run an interrogator log against the unit?.

I have tried to run the interrogator but still get the same error message.

It looks like the unit doesn’t even read the pendrive.

I haven’t tried JB though.

You dont seem to have mentioned doing a Master Reset?

I have tried that as well but the unit gets stuck as soon as I try to do that

Update to new v3.4 23188 it fixed mine i had same exact issue

Did you have the INSTL_ERR message as well?

That would solve the issue, yeah, because that build has fixed the issue/bug.
The problem the OP has is that the unit is not able to install/run anything, so he is not able to upgrade.

If none of the other solutions work, that’s your last option.

Question: have you tried multiple Soft Reset → Soft Reset → Hard Reset sequences?

Just a suggestion have you tried downloading the actual 3.4 23188 from ford and tried installing you get same error?also try master reset then disconnect battery for about 30 mins to allow all capacitors to drain and try install again.i would double check all necessary files loaded onto syn3 loader.lastly try another new usb flash drive i have had issues with them multiple times they juat wear out at contact point and create all sorts of loading issues…i would use a 64gb or larger as well

Thank you all for your suggestions.

I will try to follow your last advices (downloading the new update from ford, try to do a master reset and eventually disconnect the battery).

If none of these works I have no other option but trying to JB the unit.

I’ll keep you updated.

Thank you all

About the download from Ford, where do I get the updates? I mean it asks e the VIN number, which clearly is not compliant with version 3.4.xxxxx and above

You won’t be able to get a 3.4 download from the Ford site as their updates for your 2018 model ceased at version 3.0.20204.
You will need to try the things previously suggested and then download 3.4.23188 and maps 2.22 if required with Syn3 Updater from Cyanlabs and follow up with a master reset.

Im facing the same problem as you, except my sync3 freezes after i press continue on the master reset. ( probably completely out of memory that it cant even save the last command of the master reset) My last option is to do a hard reset by disconnecting the battery for 30mins+ and hopefully that freed up some space on the ROM to allow scripts to proceed. Afterwards im just going to run RWcleaner from cyanlabs and downgrade it completely to 3.3 then upgrade it back to the latest more stable sync. This is getting frustrating not going to lie.
Keep us updated @marcomoretti Suggest you use cyanlabs syn3 updater and do a downgrade/format to 3.3

Have you tried a different flash drive?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.