Sync 3.4.22251 suddenly not functioning properly

I updated to Sync 3.4.22251 last December. Had no issues until the past few weeks. Upon starting the vehicle I keep getting the pop up screen asking to turn on the following functions. Automatic System Updates, and Sync diagnostics. I’ll then get 2 other follow up screens after. I also the last heard radio station doesn’t come on either. It’s more annoying than an issue but looking to get this fixed. Will updating to the latest sync solve the problem?

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 0

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 0

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File


Updating to the most recent version will fix a lot of issues.

You need to get out of that build since it has a bug: your rwdata partition is surely full.
Check out this guide → Tutorial: Sync 3.4 NON-NAV APIM: Failure to Update to Newer Version Sync 3.4 APIM Sync Settings Not Saving, VER_ERR08 Errors, Cannot Perform Master Reset or Upgrades/Updates (Solved)

Ok. So essentially I have to somehow make additional space, prior to upgrading to the latest version, correct? I can’t just update first?

No, you need to read the guide to see which option works for you.

I have NAV. These instructions are the same for units with NAV?


Got it. Thank you! Much appreciated.

APIM Free space: 4.2G

RWData: 0/1.2g

Please, do not post multiple consecutive messages… if you want, you can always add information by using the edit button.

About the information the interrogator log gave it’s what I pointed in my opening message about the rwdata partition being full, you need to go through the guide to resolve it.

I ran the RW Data cleaner and now have 859M free. Should I continue to remove Gracenotes and Small Voice Package before updating to 3.4.23188. Or do I have enough free space now?

Oh dear god…

I’ve just realized I’ve sent you to the wrong tutorial!!!, no wonder you are kinda lost!!! :man_facepalming:
Apologies, I made a huge mistake by pasting the wrong link…

This is the guide you must follow → APIM Sync Settings Not Saving, VER_ERR08 Errors, Cannot Perform Master Reset or Upgrades/Updates (Solved), hopefully it will make a lot more of sense…

Again, I’m sorry for the confusion.

I’ve edited the original message as well to point to the correct one…

And yes, you should try the rwdata cleaner utility first. If that works, you will be able to upgrade right away.

No worries!! So I have 859M free now. Is that enough to upgrade to 3.4.23188?

Thanks so much!

Yes, you can now go to the latest build which has that bug fixed.
Also, you are a Car Play user, right?.

Awesome. I’ll do that in the morning. And yes I’m a car play user.

One thing I notice is that it’s defaulting to a bunch of packages. Should I keep them all selected?

That’s up to you… If you only want to upgrade Sync3 without the maps, configure it so and it will select only what’s required for that…

If you want to upgrade maps as well, you can do it as well…
If your unit does not have MY20 components you can reformat it, which is faster and clenaer…

Ok. It was defaulting to select everything which looks like other prior updates. So wasn’t sure if I should keep everything defaulted on, which I was leaning to do.

I’m all set! Updated successfully! Thanks again for your help!

Great, thank you for your feedback on the issue.
I’ve marked it as solved now.
Take care.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.