Sync 3.4 Black Screen

I would not do anything else until you can connect to the APIM with FORScan and find out if you can determine the issue and also what the model and particulars of the APIM. If someone replaced the unit with a MY20+ APIM in your 2015 F-150, they should not have done that. (2015 F-150’s came with Sync 2.)

There is a link for FORScan above, but go here and read this tutorial. This thread will be very useful…
FORScan - software to enable/disable features in your truck - Ford F150 Forum - Community of Ford Truck Fans

When you get the adapter and load FORScan, the first thing you want to do is save a profile of the vehicle, then look for the model of the APIM presently installed. You can find this in the ‘Modules’ tab. You are looking for the APIM info, it will look like this, but with your current part numbers.

APIM - Accessory Protocol Interface Module
Part number: GB5T-14G371-CFC
Strategy : GB5T-14G374-AF
Calibration: GB5T-14G375-CA

If this is a MY20+ model, then the first letter of the part number will be ‘L’ or ‘M’. (2020 or 2021). If it is a ‘K’ or before, it would be a 2019 or earlier APIM.

Also, connect to the APIM to retrieve the asbuilt information. This is covered in the tutorial above. Save the file and post it here.

Oh okay! Would the screen have the year on it like the APIM?

Not a Ford assembly number, just a manufacturer part number.

BTW, Parallels will work fine, just make sure the adapter is mounted to the Windows side only. Windows must be able to control USB. I run Parallels with Win10 with no issues.

Did you happen to be running the FORD GT theme on the APIM before you updated it?
Did it look like this?

Will I search the part number then to find out the year it is or is there a certain number that says what year it is?

Okay! That’s what I’ve been doing, anytime I plug something into it, it asks me if I want to use it in the WIndows/Parallels or the MacOs.

Also no, I didn’t have any themes setup prior to updating it. The only thing I did was set it to the night mode all the time.

1 Like

The first letter of the part number is the year.

If this is a MY20+ model, then the first letter of the part number will be ‘L’ or ‘M’. (2020 or 2021). If it is a ‘K’ or before, it would be a 2019 or earlier APIM.

Thank you!

Okay, thanks for that information! So I want it to have the “K” before the part number? If not, should I then try to find the screen with that?

Right now we just want to see what model the APIM is as installed.

But yes, you will want a J or K series APIM ideally. These are referred to as MY18.5+ and are arguably better units than the G or H series before them. The screen will be marked in this fashion also.



1 Like

When you start the truck, what does the screen do now? Does it show a Ford logo and then go black, or just stay black all the time?

Do you have information on the parts that you bought? Pics?

The screen still just stays black all the time, the usb ports light up for around 20 seconds or so and then they go out.

I’m waiting on the OBD adapter for the FORScan to come in the mail tomorrow, but not off the top of my head. I know I had to get a special wiring harness to install the screen because I originally had the 4" myford screen. It had the screen with the ADIM, the GPS antenna, and new USB ports. When I’m able to do the FORScan, I can see if that has any additional information about it


So if I happen to have the MY20+ screen and not an older one, then getting a new APIM, I may end up with the same issue? Also, to check the screen, would I be looking for the manufacturer part number with “G”, “H”, “J”, “K”, or would it be something else?

Yes, you will encounter the same issue. The problem is that the reformat tool that leaked does not have the necessary drivers for the new screen assemblies. Ford changed their screens in 2020+ models and so the reformat tool (while it technically should work just fine to reformat and install) can’t initialise the display, and without initialising the display it doesn’t proceed to reformat and the unit becomes bricked.

I’m not too familiar with screen assembly part numbers so perhaps someone else here could answer that question.


Preferably J or K. You would want to match the APIM.


Did you make any progress on the asbuilt and APIM info?

I’ve gotten the adapter, but the light on it is just red. I’m not sure how to get it to change. I’ve tried downloading the drivers it says to, but it hasn’t helped

If you are trying to use Parallels, I would suggest a native boot of Windows. Although Parallels should work, when doing any sort of module programming/configuration you want a reliable and stable connection.

When I first hooked up my OBDLink EX to my Windows 10 native boot it automatically configured drivers and was ready to go with a green light. That should be the case for you too I’d think.

You might need FTDI drivers updated.

obdlink ex - FORScan forum

I ended up doing windows 10 through boot camp, however it is saying that the connection isn’t recognized when I plug it into the computer. I’m having to use a USB A to USB C adapter because the Mac I have is only USB C ports

Hmm, I also have a MacBook with USB-C ports and bootcamp. I could try it out myself and see how it goes. Not entirely sure what else to suggest at this point. Did you install the FTDI drivers? Are the Apple drivers installed as well?

1 Like

Yea, I installed it all, a few times I think. Also, it could be the USB A to USB C adapter because I remember in the past, there’s been a few times where it didn’t work. Gonna try to get a different one, and I think it’ll work then

1 Like