Sync 3.4 - Create downgrade package without NAV VOICE


I have been fiddling with the upgrade from a 3.0 SW version to 3.4. My experience so far was mixed, since the first USB stick I made with the full 3.4 packages (with EU maps) failed 80% through and the unit didn’t recognize any USB after that. I had to leave the car overnight and it successfully reflashed a 3.4 package without any maps in it (in the interest of time and being worried that the long process is affecting my UBS stability).

I now have a 3.4 installed but without any maps and I get a “nav malfunction” error.

My plan is to create via the tool a “Downgrade” package to install the maps back on the unit.

Not the tricky part comes, is it possible, if anyone experienced with this, for example, to only install the maps without any voice nav files (as far as I can see those have ~8GB). I wouldn’t really need the voice cues and would appreciate if the system had fewer files to copy so I don’t risk the full 80 minutes of install that could fail again.


It will probably work but seems a pointless test when all it requires is for you to wait for an install.

1 Like

Thanks for the response, I will create such a package and see how it goes!

The problem I got, was not the wait, but rather that the USB stopped working (it required a few hours to actually work again - left it overnight), the install failed when installing the voice package for the maps (about 40 mins in), and then when it restarted the USB wasn’t detected at all.

I am just trying to reduce the risk of whatever bug is with the USB on my car (or electrical problem or whatever) - I also got random Android Auto disconnects in the past hence my worry.

I would recommend using another USB if it stopped working, a decent quality USB 3.0 drive such as Sandisk or Samsung are best from my testing.

I have used 3 drives (SanDisk 3.0 - the original one, SanDisk 2.0 a backup one one and a no name one this was last resort); the first time the car stopped mid upgrade none worked anymore. I took the night for the system to “sit” and it worked in the morning with the same drives and I did two updates. I suspect electrical / connection issues on the car itself.

The procedure without voice files went just fine. I master reset after the install, the system seems to be working, I have Radio pictures, NAV and it seems to see GPS and all the functions work. I will drive around later more and check if all is working as expected!

Thanks for the support!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.