Sync 3.4 freezing and no satellite pickup

I’ve got sync 3.4 on ranger. The screen is freezing and not picking up navigation. What can do to fix this

SYNC Region: ANZ

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3

New SYNC Version: 3.4.20188

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 3.4

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Don't have it as can't access screen

Have you tried a master reset on it?

So frozen that it’s not even booting any more?

If so, most likely eMMC is corrupt. I’ve also seen the modules act up when the vehicle resides in an area with dramatic swings of temperature (talking like Montana/North Dakota weather where it can be 90 in the summer and negatives in winter).

Not much you can do besides replacing the module or if you think it’s weather related, wait for warmer conditions.

If you can get it to boot up, IMMEDIATELY update it.

I wonder if a soft reset has been tried as that often fixes a frozen or black screen as you know.

Tried the factory reset. Is that same as soft reset

Tried that. Still freezes after that

What’s “tried”?, “tried and succeded” or “tried and failed”?.
And no, Master Reset is not the same as Soft Reset, but Master Reset is “more” than a Soft Reset.

Have you tried running an interrogator log against the unit ?

How can we do that. Just upgrade with same update i added

Havent tried that. How do i do this

Click on interrogator log and read

A soft reset is holding the sync power button and forward seek >>> buttons together until the system hopefully reboots. Different to a master reset as mentioned.

Upgrade to the latest sync version 3.4.23188.