Sync 3.4 Issues

I was having the same issue as many others with the auto update screen popping up with each start up. I tried to download the 23188 build update from Ford and the file kept saying invalid. I found my way to CyanLabs through searches and downloaded the update for my sync 3.4. I kept getting the INSTL_ERR12 when I would insert the usb so it wasnt pulling a file to update. I tried to soft reset with no help. When I tried the master reset, my screen would freeze until I power cycled the truck or did another soft reset. After a ton of back and forth with Ford customer service, they told me to “key cycle” my truck. Once I did that, I was able to master reset the system and when I inserted the Cyan Labs update usb, it said update complete and restarts the module. After all this, it still shows the 22251 build and not the 23188.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: MY20

Install Type: OEM

Old SYNC Version: 3.4.22251

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: Newest

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

No log

What’s that? What did you do?

If the following is true

It did exactly that…

Post the log, it’s on the USB you used or in Syn3Updater 's logs tab.

1 Like

The key cycle is what the service rep called it. She had me start the truck, Turn it off, open the door, lock the door, close the door, and wait 2 minutes for screen to power down. She was adamant I do this in this sequence. Once I did it, it was the first time I was able to proceed with the master reset (prior to this, screen would freeze when I pressed continue). I put the old and new version as the same in this thread because I still have not been able to update to the new build. The folder where the log file is blank so it keeps aborting the process after I get the “update complete, remove usb” on the screen

That cannot be. The log is created once the USB is created, regardless of what you do with it. And there’s also a copy in Syn3Updater 's logs tab. Without seeing the log we can’t assist, or at least I can’t, since I do not know what you are trying to do.

I plugged the usb in and it didn’t show anything. I repeated the steps, and it came back with an error that my Apim is not a MY20. Is that because it’s been replaced with another APIM. It was an OEM style one through intelligent1tech when mine went bad a couple months ago. I am trying to switch to my computer to upload the log

The specific APIM may not be in the database. Because your truck is a 2020 I would assume that your APIM is a 2020+. Unless you take the APIM out and look at the date code on the back of it it’s a 2020+. Ford would not replace it with an older model. If you are a second owner or know it has been replaced than you never know what has happened. Are you saying you did replace the APIM?

That makes a bit more sense…
I strongly suggest you read the instructions → Basic Usage - CyanLabs , since based on your input “you can’t” upgrade because you are not following the procedure correctly.
Review the instructions and ask if you have doubts, as the previous message said, you must ensure no MY20 hardware is present. You can’t reformat MY20 hardware, but you can install just the app package via autoinstall (no maps upgrade).

Branch: Stable
Operating System: Microsoft Windows 11 Home (2009)

Version: 3.4.22251
Region: NA
Navigation: True
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Auto-Detect

Mode: Drive
Model: SanDisk Ultra USB Device
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater Stable - Autoinstall Mode - RWData Cleaner

Item1 = RWDataCleaner TOOL - PU5T-14G386-BB_1690840002000.TAR.GZ
Open1= SyncMyRide\PU5T-14G386-BB_1690840002000.TAR.GZ
Options = AutoInstall

GB5T-14G386-AD_1606255780000.TAR.GZ (46.1KB)
PU5T-14G386-BB_1690840002000.TAR.GZ (3.2KB)

[1/9/2024 4:46:33 PM] Selected Region: - Release: RWData Cleaner - Map Version:
[1/9/2024 4:46:33 PM] Install Mode: Auto-Detect (autoinstall) Forced: False
[1/9/2024 4:46:33 PM] MY20 Protection: Auto-Detect
[1/9/2024 4:46:33 PM] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ
[1/9/2024 4:46:33 PM] Validated: PU5T-14G386-BB_1690840002000.TAR.GZ (Skipping Download)
[1/9/2024 4:46:33 PM] Preparing USB drive
[1/9/2024 4:46:33 PM] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ
[1/9/2024 4:46:33 PM] Copying: PU5T-14G386-BB_1690840002000.TAR.GZ
[1/9/2024 4:46:34 PM] Validating: PU5T-14G386-BB_1690840002000.TAR.GZ
[1/9/2024 4:46:34 PM] Copied: PU5T-14G386-BB_1690840002000.TAR.GZ
[1/9/2024 4:46:34 PM] Generating Autoinstall.lst

I deleted everything off the usb, started again at the beginning and didnt update maps. For the first time when I put the usb in the truck for update, it shows my build updated to the 23188 that I have been trying to do.

I replaced it. I didnt buy the replacement from Ford. I bought one off a 3rd party site that was preprogrammed with my vin to be essentially a plug and play replacement at 1/3 the cost which fixed my issues for about 3-4 months before I started having more issues.

1 Like

Thank you for the log, that confirms what the issue was.
That USB will not ever update anything, it’s a check for MY20 hardware that must be later “read” by syn3updater. All of this is in the guide I sent before.

Glad it all worked for you in the end. So do you now have to buy updated maps from Ford?

Question, did you just buy the APIM?, like no screen?.
Also, what issues did you have with your original APIM?, the default settings thing?.

Correct. I bought the Apim by itself. Installed on the back of the old screen. The issues I had (wouldn’t connect upon startup, black screen, frozen screen, wouldn’t save settings, etc) the dealership told me that the Apim was bad and it wasn’t saving any settings and would be compeletly shot before too long.

Well, if the original APIM was running 3.4.22251 or 3.4.23088 it was not bad, it was running a bad Sync3 build which has a bug… Hence, it could be fixed like you did with this one…

I’m saying this because APIMs are not exactly cheap, and so far you have 2…

I believe it was running the 22251 version, and I assume that’s why the Ford site still shows that version on the sync update website under my vin. Unfortunately since I thought the original one was trashed, that’s where it ended up.

Oh, bummer…

One final note: since your vehicle came with a MY20 “combo” (APIM+Screen), I would not try reformatting the unit with Syn3updater… Keep that in mind should you decide to do something else in the future…

The leaked reformat tool that Syn3updater uses came from Ford, and it can’t handle MY20 hardware…
You APIM may not be MY20 (I’m not confirming it since I’ve not seen an interrogator log), but your Screen most likely is.

There are alternatives for reformatting MY20 hardware, not with syn3daupter though, but I’m getting ahead of myself…

Thank you for all your help with this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.