sync 3 doesn't boot correctly

The screen on my 2017 Ford Ranger doesn’t boot correctly. This has been happening since August of last year. The ford logo appears, starts loading and then the screen goes black. This happens when I first turn the car on and after that it happens randomly. Sometimes when the logo appears, the radio turns off for a bit and then back on. Most of the buttons that aren’t on the screen work. The USB slots work and I managed to get an interrogator log. I tried to update sync to 3.0.20204 but it didn’t work.

Version HN1T-14G381-LG
APIM Model: HP5T-14G371-ACA
APIM Type: Non-Navigation
APIM Size: 0GB
APIM Free Space: Unknown
05/05/2023 12:55:26 +00:00

Partition Type = Free / Total
/dev/hd0t180 = 24416224 / 8903760896
/dev/hd0t181 = 2097120 / 656783360
/dev/hd0t177 = 2097152 / 136776704

Installed Packages
HN1T-14G423-AA
HN1T-14G391-AF

APIM AsBuilt
DE00: 086A04821300884A40D0
DE01: 454E0103C002000000800005
DE02: 0200000303
DE03: 010025000D0001
DE04: 17FE17FE3185
DE05: 80
DE06: 16013B00000000167600005656880081
DE07: BLANK
DE08: BLANK


SYNC Region: EU

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 2.2.16280

New SYNC Version: 2.2.16280

Do you have a error message, if so what is it?
I tried to install version 3.0.20204 (from the Ford website, through USB stick) but I got the error message “VER_ERR01”.

Update Method: Official Ford