**SYNC 3 (Gen 3 & 4) with SYNC 4 screen issues***

I have the Sync 2 in my '16 F250 and it functions like it should without issues (I know some people have had issues with them). I wanted to upgrade to SYNC 3 so started researching…got the new USB hub, GPS antenna, SIRIUS antenna, etc… Found a deal on a SYNC 4 w/8.46" screen so bought it. Then found a deal on a SYNC 3 Gen 4 64GB EURO APIM (2019 Manf. date) so bought it. Plugged the SYNC 4 up just to see what it would do. Radio worked, NAV showed up but unsure if it’d work…headlights came on and wouldn’t go back off even after unplugging SYNC 4…had to turn key off. So took SYNC 4 screen off and put on EURO SYNC 3 Gen 4. Language was German, radio worked, NAV pulled up but still unsure if it’d work… couldn’t get “Settings” to icon to work. Changed language in ForScan and some other things. It was on Version 3.4 but needed to load US maps. So did the Cyanlabs route…I’m pretty sure I bricked it though. 2019 manufactured date so its a MY20…I was in a hurry to get it all going I didn’t even think '19 would be a 2020 vehicle.
So I bought another SYNC 3 Gen 3 APIM (2017 date). Plugged it all up radio works but nothing on screen. Thought I may of got dud so ordered another APIM. One I got ended up being Gen 3 to 4 (2019 date) has a GEN 3 case but missing one of the plugs like GEN 4. Seller says it came out of a 2019 F150. Plugged it up and same thing radio works but blank screen.
My questions are:

  1. Can I “unbrick”/“reformat” or something…the Euro Sync 3 Gen 4 and get US maps on it?
  2. If the other two APIM’s aren’t version 3.4 will the SYNC 4 8.46" screen not work? If so so those two could actually be good.
    I appreciate any and all help figuring this debacle out.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Retrofit

Old SYNC Version: 2

New SYNC Version: 3.4

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.0

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

APIM AsBuilt

DE02: 0000010000


DE00: 08640096100230060082

DE03: 000000F3070002

DEO4: 1900190036AC

DEOS: 80

DE06: 0E04330000000080800005656690068

Based on what another user and I ran into trying to get a EU NAV APIM working here in the US I don’t think you’re going to be able to get this to work.
You can reformat it after you jailbreak it and use the FMods tools along with the updater to put US maps on it, the best point I was able to get to was making the unit a non-NAV which at least allowed the compass to work.

Sync 4 does not support CGEA 1.2, so this will not work in your vehicle since it is CGEA 1.2. Sync 4 supports CGEA 1.3 at his time.

Likely the unit is unable to boot due to no memory available. It is possible to rescue this one using the FMods tools and jailbreak.

You need a Sync 3 screen, the video drivers are completely different from Sync 3 to 4.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.