Sync 3 Update - blank screen

First mistake is not finding this site first. I bought my parents 2016 Ford Expedition. They were the only owners and I’m 99% positive it was never updated to a MY20. Build was still at 1.015139.

I couldn’t get the sync to update via wifi or USB with the Ford Updater, but came across another forum that said to update to 2.2 then go to 3.0 I updated with their build to 2.2 (don’t know the complete build version) but it definitely updated. I decided to then use the ford website 3.0.23219 update, as that’s what Ford site said I can update to. The screen constantly said “updating system.” I drove around for hours with multiple restarts, but it never completed. Took the USB out and used 2.2 for about a week totally fine, but then decided to give the update another try on a long drive. Reached my destination and gave up, unplugged the USB. Went to restart, completely blank screen that is backlit. Radio, volume, Bluetooth and steering wheel controls still work. Tune button on the control head does not. Backup cam does not work. USB seems to be powered as my phone recognizes it’s plugged in for Android auto. I’m tried the interrogator tool to attempt to see what version the 2.2 might have been but nothing happens. I’ve tried to reinstall the version 2.2 and also tried a cyanlab built USB with 3.3 on it. Nothing works. Is my only option a firmware reset via Forscan?

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 2.2

New SYNC Version: 3.0.23129

Do you have a error message, if so what is it?

Update Method: Official Ford

So you never used syn3updater and yet the screen went black, right?.

This is not a thing.

Try performing a soft reset. If that fails, remove the fuse for 15-30 minutes to see how it goes.

Performed both. Did the soft reset multiple times by holding the power and forward skip, along with removing the fuse for 30min. No joy.

Do you have Forscan and an adapter ?

Ordering one now. Once it shows up I’ll post what it shows

Also, dumb question, but if it is a bad APIM. Can I simply buy any APIM online for Ford sync 3.4 w/nav or are they specific to models and years of vehicles? Just wondering bc I’ve seen some reasonably priced ones on eBay and for $250 and 30min, might be less painful. I do still enjoy the troubleshooting and problem solving work, along with saving some money trying to fix it.

APIMs are basically interchangable, you “only” need to ensure it’s the correct capacity. For NA, 32 GB, for EU 64 GB. Other than that, it’s just programming, which may need to be done depending on the vehicle. You can download your original asbuilt from a ford site that I can’t find right now…

You know what they say about cheap things right…
I’m sure you can find a lot of options, but my recommendation is to avoid stuff from China and buy from a respectable seller… there are a lot of counterfeit units out there…

If you ask me, it does not make a lot of sense for you to get a black screen using just Ford’s update USBs… That makes me think that maybe there’s a dumb parameter that’s wrong and the unit is trying to display a wrong theme… That’s why I asked if you had an adapter and forscan, because the unit should be accesible still.

Got the reader. Below is the basic from initial scan:

APIM - Accessory Protocol Interface Module
Part number: GB5T-14G371-CFC
Calibration level: GB5T-14G371-CJU
Strategy : GB5T-14G374-AF
Calibration: GB5T-14G375-CA

Ok, so it’s a GB5T-14G371-CFC which is quite old… your original assumption it was never serviced seems to be correct… It’s a 32GB one…

Share the asbuilt values for the APIM, you want to double check these values:

Now that you have access, save a backup of those values (besides the screenshot, which also serves as a backup if you need it). You can also download the factory asbuilt from .

Now, those values seem correct for the theme.
Before moving forward, try forcing a reset from Forscan… It should not matter really, but since you have the adapter and forscan it’s worth trying.

If that fails, I would change these values, write them and force a reboot again through Forscan.
DE02/7D0-03-01 xxxx-01xx-xxxx

If that does not work, change:
DE01/7D0-02-01 xxxx-00xx-xxxx

If none work, revert them back to the current value they have.

While doing so, just check if the splash screen is seen or not at some point.

backup values saved and factory asbuilt downloaded. No joy with loading the factory built file or with changing 7D0-03-01 or 7D0-02-01 to themes within the Ford family. Self test shows no errors. No splash screen seen at any point. Prior to malfunction it was the standard Ford logo, now nothing. The screen is still backlit however. Hard power cycle (30+ min battery disconnect) did nothing either. I was surprised because it didnt wipe any presets in my radio and my phone was still connected via bluetooth. Still no joy with the interrorator tool. The USBs are getting power and my phone recognizes it when I plug in, but the system doesn’t seem to initiate the commands on the usb device. I’ve tried multiple USB thumb drive brands. Last addition, not all the steering wheel buttons work. The 4 arrow and OK buttons work but the volume, phone/seek buttons, and voice recognition button do not.

I’m running out of ideas…
Which interrogator package are you trying to run?.

GB5T-14G386-AA_56065.tar.gz, which lines up with my Sync 3.0 and previous known successful/working install of 2.2 from F150forums. I’ll give -AB a try and see if that does anything.

I think the only thing left to do is put eyeballs on the Screen and APIM part numbers.

Besides replacing, what does getting the part numbers do? I’m about to pull it and see if I can reflash just for the hell of it. Seen a couple of threads requiring shorting a couple of contacts and connecting directly to the APIM on a testbench. Also seen some stuff about jailbreaking. Any reason I can’t drive around with the thing pulled while I wait for a new one to come in the mail? First time messing with an APIM but not my first time taking apart and programming electronics.

Pulling it because I have seen where Forscan shows a different part number than it shows on the back. Your APIM shows signs of being a 2020+ APIM. It very well may not be but if it was replaced, or the screen unknown to you it very well could be. The part number does match a very early one that would be in a 2016 but either way your APIM is bad it seems. Those early ones are the most temperamental and it’s not uncommon to brick them after a calibration update.

Of course saying this I am wondering what brand and size USB you are using?

Gotcha, yeah I’ll get to pulling them for a closer look. USB drives on 64GB for both the update and then for the interrogator. Then a 4GB and a 8GB (brand unknown) for the interrogator.

so random update…I ended up getting ambitious and trying to do a firmware recovery via forscan. Initially said I bricked the APIM, and it was acting like it. Everything was now off (radio, screen backlight) and getting errors in forscan. I managed to get it back to its previous state (still have the blank screen) but radio, bluetooth, backlight are all back. I’m still playing around with it, more to follow.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.