I am new here and wanted to see if I can get some help. I upgraded to 3.4 20021 and I am getting the USB error. I know that I must upgrade the USB port but I don’t know which one. Can anyone help?

Hi, Welcome,

What car do you have?

What Year?


I have a 19’ Escape.

i believe but am not 100% as do not have a Ford Escape you need


However a '19 plate shouldn’t need a new USB Hub

did you master reset after upgrading? i got the error too, but a master reset after my upgrade and usb works fine. music started right up. i have a 2016 ford escape i’m on 19274 because i saw the 20021 had issues.

I am on 19274 and have the same problem in 2019 F250. I get a USB error and it takes minutes to finally start working. I haven’t tried changing out the USB hub as of yet because I figure its an error in the programming. I also get prompt volume if any apps are open on phone CarPlay . I have done multiple resets and nothing has solved the issue. Friend of mine has a 2020 F250 and on 20021 from Ford and not and issue. I wish there was a way to go back to factory because of all the issues. If someone finds a solution please let me know.

Prompt volume is an issue with Waze not sure if they released an update to fix it yet

Don’t have Waze and the problem still exists.

for completion purposes any ideas on this oustanding question? maybe bad cable? @F150Chief

Needs to replace hub. Seen this on various US cars. Usually under warranty.

2017 Fusion Hybrid w. Hxxx APIM and 3 to 3.4 update via cyanlabs.
got the bad usb error occasionally until I switched cables, now it works perfectly with the original hub

You mean the cable for the phone…? Apple requires a genuine iPhone cable. (Although I think there are some cables that will work…) Android has no requirements other than the cable works.

Yes, Android. USB A to C cable. I leave the cable plugged in the car and hook the phone (pixel 3a) up whenever I want Android Auto.
With one cable I would get occasional UBS errors (with or without phone).
The cable would still work and AA would eventually connect and function properly.
A new cable and all this behaviour has gone away.

All I can think is there is some sort of resistance check (like the signal to enable fast charge) and the first cable has a funny resistance.

The cable giving me grief with the APIM still works just fine on the computer to transfer data. Go figure.

The Apple cable has a microchip in the lightning connector. This is how the phone and/or hub knows it’s the right cable for CarPlay. AA does not care. But the hub does have a load sensing circuit for power. That could have been out of spec for the hub in this case.