Sync3 with black screen

Good morning friends, I need help from the team, if by chance the translation is bad, I’m sorry because I’m from Brazil and I used google translator to translate into English.
My problem is with the Sync3 that has a black screen, no update was made, I was traveling and the radio simply started to slow down, locking the GPS, and not responding to the commands on the screen, very slow indeed, the next day already it didn’t turn on anymore.
It was then that I started researching the internet and saw that this is a common problem with Sync3, several reports from users with the same problem, there is even a bulletin published by FORD to technicians that I had access to on the website https://www. fordserviceinfo.com/, informing you of the problem.
I took the car to the dealership and they told me that it was necessary to change the APIM, due to the very high value I did not authorize it. But I think if the reverse camera works, why change the APIM, I don’t think it’s totally dead. So I started researching how to recover the APIM, so I bought an ELM327 vLinker FS recommended by ForScan and ventured out to try to recover. So far without success.
My ForScan does not give an option to update firmware, I don’t know why. Then I found your website https://cyanlabs.net/, as I didn’t know the version of the software installed I was afraid of making things worse and tried to find out the version of my software beforehand. On the ford website it says my version is 3.0.17276, not sure thats what ford says.
I downloaded the programs to the pendrive, I put it in the car and nothing happens, I created a log pendrive, but it does not generate the XML.
Then I saw that it is possible to record directly on the eMMc, through USB, I found a tutorial on github, I even made a USB adapter, I connected it to the APIM board and put it in the notebook, it recognized the chip and even asked to do the formatting, that is he is still alive, i hope i can recover. What I couldn’t do was compile the programs to boot MLO and QNX-IFS-REFORMAT.
Can anyone help me with a solution?


SYNC Region: ANZ

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.17276

New SYNC Version: 3.4.21265

Do you have a error message, if so what is it?
No

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.11.8.0

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

CYANLABS - SYN3 UPDATER - V2.11.8.0
Branch: Stable
Operating System: Microsoft Windows 11 Home Single Language (2009)

PREVIOUS CONFIGURATION
Version: 3.0.17276
Region: ANZ
Navigation: True
Install Mode: reformat (reformat)
Install Mode Overridden: True
My20 Protection Enabled: Desabilitado / Não Modelo 2020+

DESTINATION DETAILS
Mode: Drive
Model: SanDisk Cruzer Blade USB Device
Size: 29,8GB
FileSystem: exFAT
Partition Type: MBR

REFORMAT.LST
GRACENOTES=4U5T-14G423-DC_1615429585000.TAR.GZ
VOICE=5U5T-14G391-DP_1626960105000.TAR.GZ
APPS=5U5T-14G381-EU_1634769242000.TAR.GZ
MAP=4U5T-14G421-DAG_1644011139000.TAR.GZ
VOICE_NAV=4U5T-14G422-DH_1644008342000.TAR.GZ


AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.11.8.0 Stable - reformat FORCED  Mode - Sync 3.4.21265 ANZ

[SYNCGen3.0_ALL_PRODUCT]
Item1 = REFORMAT TOOL  - 1u5t-14g386-cb.tar.gz
Open1 = SyncMyRide\1u5t-14g386-cb.tar.gz
Options = AutoInstall

FILES (6)
1u5t-14g386-cb.tar.gz (8,5MB)
4U5T-14G423-DC_1615429585000.TAR.GZ (896MB)
5U5T-14G391-DP_1626960105000.TAR.GZ (1GB)
5U5T-14G381-EU_1634769242000.TAR.GZ (847,2MB)
4U5T-14G421-DAG_1644011139000.TAR.GZ (4,7GB)
4U5T-14G422-DH_1644008342000.TAR.GZ (1,5GB)

LOG
[18/01/2023 19:30:21] Selected Region: ANZ - Release: Sync 3.4.21265 - Map Version: 2.21 (2021) - ANZ, SA and TW 
[18/01/2023 19:30:21] Install Mode: reformat (reformat) Forced: True 
[18/01/2023 19:30:21] MY20 Protection: Desabilitado / Não Modelo 2020+ 
[18/01/2023 19:30:21] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[18/01/2023 19:30:21] Validated: 1u5t-14g386-cb.tar.gz (Skipping Download) 
[18/01/2023 19:30:21] Checking Existing File: 4U5T-14G423-DC_1615429585000.TAR.GZ 
[18/01/2023 19:30:24] Validated: 4U5T-14G423-DC_1615429585000.TAR.GZ (Skipping Download) 
[18/01/2023 19:30:24] Checking Existing File: 5U5T-14G391-DP_1626960105000.TAR.GZ 
[18/01/2023 19:30:27] Validated: 5U5T-14G391-DP_1626960105000.TAR.GZ (Skipping Download) 
[18/01/2023 19:30:27] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[18/01/2023 19:30:30] Validated: 5U5T-14G381-EU_1634769242000.TAR.GZ (Skipping Download) 
[18/01/2023 19:30:30] Checking Existing File: 4U5T-14G421-DAG_1644011139000.TAR.GZ 
[18/01/2023 19:30:44] Validated: 4U5T-14G421-DAG_1644011139000.TAR.GZ (Skipping Download) 
[18/01/2023 19:30:44] Checking Existing File: 4U5T-14G422-DH_1644008342000.TAR.GZ 
[18/01/2023 19:30:49] Validated: 4U5T-14G422-DH_1644008342000.TAR.GZ (Skipping Download) 
[18/01/2023 19:30:49] Preparing USB drive
[18/01/2023 19:30:49] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[18/01/2023 19:30:49] 1u5t-14g386-cb.tar.gz exists and validated successfully, skipping copy 
[18/01/2023 19:30:49] Checking Existing File: 4U5T-14G423-DC_1615429585000.TAR.GZ 
[18/01/2023 19:31:15] 4U5T-14G423-DC_1615429585000.TAR.GZ exists and validated successfully, skipping copy 
[18/01/2023 19:31:15] Checking Existing File: 5U5T-14G391-DP_1626960105000.TAR.GZ 
[18/01/2023 19:31:47] 5U5T-14G391-DP_1626960105000.TAR.GZ exists and validated successfully, skipping copy 
[18/01/2023 19:31:47] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[18/01/2023 19:32:12] 5U5T-14G381-EU_1634769242000.TAR.GZ exists and validated successfully, skipping copy 
[18/01/2023 19:32:12] Checking Existing File: 4U5T-14G421-DAG_1644011139000.TAR.GZ 
[18/01/2023 19:34:32] 4U5T-14G421-DAG_1644011139000.TAR.GZ exists and validated successfully, skipping copy 
[18/01/2023 19:34:32] Checking Existing File: 4U5T-14G422-DH_1644008342000.TAR.GZ 
[18/01/2023 19:35:25] 4U5T-14G422-DH_1644008342000.TAR.GZ exists and validated successfully, skipping copy 
[18/01/2023 19:35:25] Generating reformat.lst
[18/01/2023 19:35:25] Generating autoinstall.lst
[18/01/2023 19:35:25] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY! 

2023-01-19_08-57-38

2023-01-19_08-58-35

Not something i have experience with really, maybe someone else can chime in.

Sorry it wasn’t very clear to me, you have no experience with direct reflash in eMMC? Is that what I wanted to say?

But is there anything I can do with ForScan?

Not sure were you read that, but it’s not common.
If the unit started having issues just before showing a black screen, that seems a hardware error.

At this point, I’m not sure if the unit is operational or not (besides the screen).
For instance, does the media player work?. Radio?.
Does your phone pair?. What about Android Auto?.
Do the USB ports have power?.

You mentioned you tried running an interrogator log with no results, right?.
Have you tried removing the battery for a while to force the modules to restart?.

Do you have physical access to the unit?, have you checked all the connections?.

Yes the unit is operational. However, only the reverse camera works. It does not enter the initial screen where it switches to radio, usb, bluetooth, it is as if it had lost the eMMC operating system.

I connected the board via usb, linux recognizes the OMAP5430 chip.

The car’s USBs have power, as it charges the cell phone.

I’ll attach a photo below so you can understand how I connected it to see if it’s functional. I used the car’s power plug and a mini USB cable directly on the notebook.

I do not need any photo, I won’t go into HW stuff.
What I want to understand if it the unit is operational and radio works, for instance.
Or USB playback…
You can access all those settings via voice without the screen.

I have an official document from ford, reporting on the problem of this APIM model, and it says that the solution is to reprogram it.

But as the car is out of warranty they charged me absurdly expensive to perform this service.

1 Like

I don’t know if the information is relevant to you, but through ForScan I can execute commands in APIM normally too. I even deleted the dtcs, and reset the module, but the same black screen remains.

Do you think spamming will make people more willing to help?.
That CLEARLY does not work for me, quite the opposite in fact.

So, stop spamming messages.
I was not going to say anything before, but your opening thread consisted of 16 consecutive messages… 16… Didn’t say anything because they were merged together and wanted to give you the benefit of the doubt.

But now you added 3 more consecutive messages… and you are now @ing me…
So please, stop spamming, specially when @ing people… there’s an edit button for a reason…

My sincere apologies, it was not my intention to spam, I just tried to provide as much information as possible so that someone can help me. When the account is new, it is not possible to send multiple attachments together, which is why they were separated. As for the text messages, I can correct them if necessary and edit the posts. I really apologize, it was not my intention to cause SPAM, I’m just looking for help.

1 Like

That’s ok… take into account that if you @ someone, you create a notification to that person… One is enough, people will look at it when they have time. This is a free support community, and there are different time zones in place…

Again, no problem, but from now on please do not post multiple messages consecutively, I’m sure the forum even warned you while doing so…

I can understand what you said about detail, which in fact you have provided a lot of them in a clear way which is awesome (I liked how you “sequenced” the photos, thus telling a story about the rear camera working)… but all can be done in a single message…

Going back to your issue, this is quite a strange one.

Your APIM is a J series from what you mentioned before, which is not an old one. I would expect this kind of issues on older models. About the service bulletin you mentioned, it’s a bit vague and I’m not sure if it’s applicable to your case.
The fact you mentioned the unit started like “dying” just before the screen went black, that screams “hardware failure” to me… Plus, all the DTCs…

Having said so, if the unit is not operational and USB ports do not seem to work, trying to recover the unit with normal procedures does not seem possible. Your phone charging is tricky though, since the USB has power then.

About directly modifying the board it’s really out of my league, but let me tell you it could be a bit of a gray area for legal reasons… I’m not shutting the discussion down, but it’s just a heads up…

There are a few members that know low level stuff, specifically firmware upgrading (I think that’s what you were looking for, right?). Lets wait until they jump in.

But as said before, I believe not many users will have experience with directly handling the board.

Have you considered visiting a junkyard or buying an used APIM to replace yours?.
I’m sure Ford will charge you a lot, but maybe there are cheaper options for you to consider.

@F150Chief is out of town for another week but he could have some answers.

There is a way to reprogram the entire emmc via usb using omap processor “backdoors” but this is not something I have any experience with yet and likely won’t bother learning. Fmods would be the place to assist with this.

The APIM is dead or dying, it is not worth recovering. What you read and the Ford bulletin is correct, the earlier series of APIM’s do experience this issue, although it is not a common occurrence it does happen, especially with APIM’s with earlier Sync 3.0 versions. Unfortunately this is a hardware issue, not software or firmware. You can source a newer Sync unit with much more stable hardware on the internet for much less than the dealership will charge. FYI - The video from the cameras is not processed thru the same path as the Sync application in the APIM.

I am curious why a 2019 EcoSport would have Sync 3.0 from the factory. It looks like the APIM is a 2018 production year model, with 2016 model year firmware.
APIM - Accessory Protocol Interface Module
Part number: JNIT-14G371-DBC
Calibration level: JNIT-14G371-DBC
Strategy : GB5T-14G374-DG
Calibration: GBST-14G375-DB

From @SaNdMaN:
The fact you mentioned the unit started like “dying” just before the screen went black, that screams “hardware failure” to me… Plus, all the DTCs…

This is a correct analysis…

@SaNdMaN, Yes, at the moment it really has a hardware failure, but I believe that something similar must have happened as it can happen on any computer, suddenly it damages the partitions or operating system and unfortunately you have to redo everything.

The DTC’s could be because the APIM is not communicating.

The FORD bulletin applies exactly to my model, this is stated in the document 14G371.

USB connected on LINUX I get responses from the OMAP processor, and fastboot answers me 1st level, 2nd level fails, says iboot is missing. It could have been my fault compiling the program, I’ve never done it before, so the USB isn’t dead.

When the 2nd level fails and I try again afterwards, it asks me for iboot.ift, this may be what is not being found on the APIM SSD, then it says that it is necessary to reprogram.

@CyanLabs, that’s exactly what I’m working on, reprogramming the whole emmc, but as I’ve never done it before I’m having my difficulties, I don’t have experience with APIM either, but I’ve been working with IT for 25 years, so I have some ideas. I will not give up, because I believe I have a solution since it responds to the commands presented above.

To know if the SSD was alive, I did the tutorial below, I managed to access the SSD directly in windows, it didn’t recognize it of course because the format of the partitions are different, but it asked me to format it, as if it were a new pendrive. This already gives me good hope.

sa3poGGT5cn3KC0kTIqFkpzve74-960

@F150Chief, I understood your explanation, I agree in quotes, I will not give up on recovering while there is still hope and answers.

As for his version, it was actually manufactured in 2018, 05/16/2018 but the car is 2018/2019, so I believe I have no problems with that, but FORD should have already really corrected the problem, it was published in a bulletin that the update solves the problem , but when I discovered this information it was too late, the problem had already happened.

==================

Well, my dears, I appreciate everyone’s response and the time dedicated to answering me, I really believe that it is a hardware problem, but I also believe that there is still a solution.

As I said, I have no experience in reprogramming APIM, I have never done it before, and maybe this is not the ideal forum for this (Know that before checking these hardware issues, I was trying with ForScan, and in that I saw that you understand and are very good ), Congratulations to you for your dedication, I even saw an ASBuild code completely rewritten, and left available only for the user to download. I’m looking and trying, I’ve managed to evolve, if I’m successful I won’t hesitate to let you know, and if anyone wants to solve this problem together with me, I’ll be here trying. I don’t have a lot of time to work on it, maybe you don’t either, but here we are.

A big hug and see you later.

It’s my friends, after many attempts and failures, a lot of persistence because I knew there was still a way, I finally managed to recover SYNC, I was on the right path, I just didn’t know how to do it, but I’m very happy with my achievement. Many thanks to the CyanLabs forum and your team, you do an amazing job in making the application available for updates, and the support to users, thanks to the forum right after I managed to recover my APIM I mounted the pendrive and updated it to 3.4.21265.

Thank you very much hugs!!!

Glad to hear that!, it’s not common to hear good news after such a scenario. Congratulations on your persistence.
Now you know more about Sync3.

Thank you for the feedback.
Enjoy it, take care.