"the media device is not available" on startup when auto resuming USB music playback

I just picked up a new 2021 Escape PHEV Titanium Premium and am using a USB stick for music. After the vehicle has been off for a while, it can never resume USB music playback by itself. It times out with message “the media device is not available”. It can always play fine when I manually re-select the USB source, but cannot resume on startup, unless the vehicle has been off for only a very short while (just a couple seconds), then it does resume properly.

It seems to just be too slow to mount the USB device and times out. But it then detects the USB media just fine a couple seconds after startup (as can be seen in the video I made).

  1. I tried with 3 different brands, sizes and USB versions (1.1, 2 and 3.1) of memory sticks with the same results with each device.
  2. I tried different file systems on the USB sticks (FAT32, exFat) and different sector sizes.
  3. I tried re-indexing the USB media multiple times. It does indeed complete successfully the indexing each time.
  4. I tried multiple master reset of Sync.
  5. I tried a cold reboot, by disconnecting the 12v battery for 45 minutes.

Any ideas of what would be causing this ?

Here is what it looks like.

Thanks in advance for your time !


SYNC Region: North America & Canada

Navigation Variant: Yes

Old SYNC Version: 3.4.21194

New SYNC Version: 3.4.21194

Do you have a error message, if so what is it?
the media device is not available

Update Method: Official Ford Update

Syn3 Updater Version:

Syn3 Updater Documentation Read:

Syn3 Updater Log File

I’m going to take a wild guess and say that this is probably just expected and the system is taking too long to enumerate the USB stick on a cold boot (which is what’s happening if the vehicle is left off for a while) and timing out and returning to another audio source. I see this on mine in certain scenarios too across different audio sources. Bluetooth Audio is also a common one if it can’t connect to the phone fast enough.

You said you used different brands of USB sticks. Are any of these good name brands and not counterfeits?

Apart from a cheap 8Gb USB 2.0, I have tried with a 64GB PNY Elite-X Fit USB 3.0 a 32GB SanDisk Extreme USB 3.0 and a 128Gb SanDisk Extreme PRO USB 3.1. Oh and I even tried with an old 64Mb USB 1.

They all work fine once detected, but none are able to resume music on vehicle startup.

Since this a new unit under warranty, i would just go to the dealership and make them solve it.

It’s not normal behavior to me.

2 Likes

I have seen this happen before and it is usually caused by some fault in the APIM or associated hardware. It will exhibit this behavior on cold boot. Other than the APIM, this could be the USB hub, also.

There is nothing you will be able to do to fix the issue, due to the fact that you cannot perform invasive testing or other methods without voiding the Ford warranty. Just take it to the service department and show them exactly what you have done to test it. Be helpful to them and they will probably just replace the unit.

3 Likes

This has happened to me with every version of 3.4. the only version were it was anyway stable was 21020. As soon as i updated from that version it happened all the time.
When i got my new car in January this year i brought it back to the dealers and they told me it was normal behavior. That’s just one of multiple reasons why i won’t buy another ford. The cars are mechanically sound but their tech is a joke! has no one in ford heard of test before release??
End of rant…

People had been updating their Sync3 units for s while now, this is not wide spread.

I wonder if these issues are for newer cars with newer hardware and 3.4s, and that’s why we didn’t receive this feedback before…

1 Like

I’ve had this intermittently (as mentioned in my post above) on my G model APIM. It hasn’t happened often enough or been irritating enough for me to bother and just chalked it up to the older, slower APIM. Everything else has functioned perfectly otherwise. But everything does take JUST a bit of time on a cold boot to get ready. Bluetooth, maps, voice commands, all of it.

That said I also use Android Auto a lot these days so I don’t often run into this in those scenarios either.

How can I find out which APIM I have? thanks.

Run the APIM Interrogator Utility in Syn3 Updater.

Yeah I have an AAWireless Gen2 adapter on order that should ship in january. Until then I have the 3 month trial of SiriusXm. So I should survive even if my Ford dealer does not take this issue seriously. :wink:

Believe it or not, I sold my Tesla Model 3 SR+ last week and then bought this Ford Escape PHEV. USB music would not resume properly on startup with the Model 3 either back in 2019. Tesla only fixed that issue around mid 2020.

So I think the tech is fine in all of these cars, but it’s a software issue. As a computer programmer myself, I can understand how things that seems trivial to users are not always so trivial to fix. But as a user myself, I just want this “basic” stuff to work of course ! :wink:

I’ll get back into the BEV world when the range of “affordable” EVs are close to 500 Km during the Canadian winter.

So, what are you going to do?
Is there any reason for leaving this thread open?

I have an appointment with the dealer for December 10th.

It might be useful if I can report back after that.

I totally agree, yes.
We’ll let this open then.

I’ve found this happens a lot less with the 21265 update. Specially if the car is off for a good length of time. 21194 was very bad for this happening.