Update to 3.4 - Bluetooth lag and skipping

After updating to Sync 3.4.22110 I am getting a significant bluetooth lag on both my iPhone and Android on bluetooth. 3-5 second delay. On occasion you can here the smallest glitch in a song.

Did a master reset after upgrade and unpaired both phones and repaired after restarting phones. I don’t think it was a pairing issue as the iPhone had never been paired to the truck before and immediately had issues after pairing.

Does anyone have any additional troubleshooting tips to recommend? Should I consider ‘downgrading’ to previous versions of 3.4 or redownloading and reinstalling?


SYNC Region: North America & Canada

Navigation Variant: No

Install Type: Stock (Original Unit)

Old SYNC Version: 2.0.16074

New SYNC Version: 3.4.22110

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.10.11.0 Stable

Syn3 Updater Documentation Read: Yes

Syn3 Updater Log File

    CYANLABS - SYN3 UPDATER - V2.10.11.0
    Branch: Stable
    Operating System: Microsoft Windows 11 Home (2009)
    
    PREVIOUS CONFIGURATION
    Version: 2.0.16074
    Region: NA
    Navigation: False
    Install Mode: Auto-Detect (reformat)
    Install Mode Overridden: False
    My20 Protection Enabled: Auto-Detect
    
    DESTINATION DETAILS
    Mode: Drive
    Model:  USB  SanDisk 3.2Gen1 USB Device
    Size: 114.6GB
    FileSystem: NTFS
    Partition Type: GPT
    
    REFORMAT.LST
    GRACENOTES=4U5T-14G423-CC_1615429225000.TAR.GZ
    APPS=5U5T-14G381-EZ_1652218180000.TAR.GZ
    VOICE=5U5T-14G391-CR_1644007976000.TAR.GZ
    
    
    AUTOINSTALL.LST
    ; CyanLabs Syn3Updater 2.10.11.0 Stable - reformat  Mode - Sync 3.4.22110 NA
    
    [SYNCGen3.0_ALL_PRODUCT]
    Item1 = REFORMAT TOOL  - 1u5t-14g386-cb.tar.gz
    Open1 = SyncMyRide\1u5t-14g386-cb.tar.gz
    Options = AutoInstall
    
    FILES (4)
    1u5t-14g386-cb.tar.gz (8.5MB)
    4U5T-14G423-CC_1615429225000.TAR.GZ (564.2MB)
    5U5T-14G381-EZ_1652218180000.TAR.GZ (869.8MB)
    5U5T-14G391-CR_1644007976000.TAR.GZ (385.5MB)
    
    LOG
    [5/26/2022 11:59:42 PM] Selected Region: NA - Release: Sync 3.4.22110 - Map Version: Non Nav APIM 
    [5/26/2022 11:59:42 PM] Install Mode: Auto-Detect (reformat) Forced: False 
    [5/26/2022 11:59:42 PM] MY20 Protection: Auto-Detect 
    [5/26/2022 11:59:42 PM] Formatting USB drive
    [5/26/2022 11:59:42 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
    [5/26/2022 11:59:51 PM] Checking Existing File: 1u5t-14g386-cb.tar.gz 
    [5/26/2022 11:59:51 PM] Downloading: 1u5t-14g386-cb.tar.gz
    [5/26/2022 11:59:52 PM] Validating: 1u5t-14g386-cb.tar.gz 
    [5/26/2022 11:59:52 PM] Downloaded: 1u5t-14g386-cb.tar.gz 
    [5/26/2022 11:59:52 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/26/2022 11:59:52 PM] Downloading: 4U5T-14G423-CC_1615429225000.TAR.GZ
    [5/27/2022 12:00:15 AM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:00:18 AM] Downloaded: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:00:18 AM] Checking Existing File: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:00:18 AM] Downloading: 5U5T-14G381-EZ_1652218180000.TAR.GZ
    [5/27/2022 12:00:39 AM] Validating: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:00:44 AM] Downloaded: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:00:44 AM] Checking Existing File: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:00:44 AM] Downloading: 5U5T-14G391-CR_1644007976000.TAR.GZ
    [5/27/2022 12:00:53 AM] Validating: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:00:56 AM] Downloaded: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:00:56 AM] Preparing USB drive
    [5/27/2022 12:00:56 AM] Checking Existing File: 1u5t-14g386-cb.tar.gz 
    [5/27/2022 12:00:56 AM] Copying: 1u5t-14g386-cb.tar.gz 
    [5/27/2022 12:00:56 AM] Validating: 1u5t-14g386-cb.tar.gz 
    [5/27/2022 12:00:56 AM] Copied: 1u5t-14g386-cb.tar.gz 
    [5/27/2022 12:00:56 AM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:00:56 AM] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:01:13 AM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:01:19 AM] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ 
    [5/27/2022 12:01:19 AM] Checking Existing File: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:01:19 AM] Copying: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:01:43 AM] Validating: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:01:54 AM] Copied: 5U5T-14G381-EZ_1652218180000.TAR.GZ 
    [5/27/2022 12:01:54 AM] Checking Existing File: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:01:54 AM] Copying: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:02:10 AM] Validating: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:02:14 AM] Copied: 5U5T-14G391-CR_1644007976000.TAR.GZ 
    [5/27/2022 12:02:15 AM] Generating reformat.lst
    [5/27/2022 12:02:15 AM] Generating autoinstall.lst
    [5/27/2022 12:02:15 AM] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!

I’d start by deleting the pairing on both devices, doing a full power reset on both, power both back up and leave them to stabilise, then re-pair.

For me I’ve always had a few second delay in Bluetooth connectivity on SYNC 3. When playing a song the audio would usually lag behind the indicator by 2-4 seconds.

The audio “glitching”, “popping” or “skipping” is also a known issue that’s been plaguing SYNC 3 for years, doubt it’ll ever be fixed.

You could downgrade to see if it helps, but personally my Bluetooth has always behaved how you described it for years on many different versions. For reference I had a 2018 Fusion.

Can confirm what avdonr wrote.

The Audio always was behind 2-4 seconds regardless of the BT source device.
This is just the sync 3 buffering the audio I think.
This was the case on 3.0 and is on 3.4.
The glitching / Skipping is normal for USB/BT sources after upgrading from <=3.0. It happens occasionally and probably won’t be fixed.

If you don’t want Audio Buffering at all you need to use Android Auto, CarPlay or iPod / USB.

If by lag you are referring to the delay between pushing “next” and the next song actually being played, it’s been like they since 3.0.

I’m currently running 3.0 and it has the same delay you are describing, sometimes less, sometimes more…

Yes, I first noticed it with pushing next on a song, but it became glaring when my husband tried watching tik tok in the truck. On my previous 2013 nissan he would pop it on the speakers and enjoy them on a road trip while I drove. It was an unusable experience on Sync.

I am going to try the full power reset advised, though these are brand new never had been paired devices so I am not sure if there is much to clear out.

I thought maybe it just may be a bug with this version. I was particularly hopeful because I haven’t been able to get android auto to work yet. I think my USB hub needs replacing and so I have had to rely on bluetooth to get directions and the delay has caused me to miss a few turns because I get it just a smidge too late.

You should get away with android auto without changing your hubs, it’s apple car play that won’t work… Just to be safe, make sure the cable is good…

Thank you. I ordered 6 different cables advised in the forums and oem samsung cables and none work. Tried short cables, anker cables, everything. It would flicker on for a second and then give errors that android auto was unable to initialize.

After testing the cable and multiple phones someone advised that the port voltage could be out of wack and replacing with a new one could do the trick so im taking that for a spin. If that fixes the android auto connection issue ill update here so soneone else will know the solution.

I hope it helps as so far i have tried multiple cables, updating the sync, resets, multiple phones, and so far no dice! Its kikd of my last hope!

That’s true, we had a case like that some time ago that was due to bad voltage.
If you are already planning on changing the HUB, I would first try removing and reconnecting your current one, just to make sure all connections are solid.

Never thought of that! Gonna give it a shot right now! Thanks for that suggestion!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.