Updated to 3.4.21194

Hi, I just updated to Sync 3.4.21194. It successfully installed. The problem I was facing after the update is no settings will save. So I went to try a master reset but now I get the splash ford RS theme then it goes black. Radio and volume work but all I have is a black screen after the master reset.

Is this a replacement APIM or original to the vehicle?
If original, what version was the unit on before the upgrade?
Have you tried disconnecting the battery for a few minutes then re-connecting?

This is the original APIM on the vehicle. It was upgraded from 3.3.19052. I have disconnected the battery for a few minutes. Still the same issue. Ford RS splash screen shows and loads. Then the radio turns on, I can control the volume. Yet the black screen persist. I did manage to hold the power/next track to soft reboot, it fully loaded and had the popup that says to enable the diagnostics/autoupdate, but the screen was unresponsive.

So this APIM has already been reformatted from Sync 3.0 version to Sync 3.3.19052 before this and all was well, but updating to Sync 3.4.21194 has now caused issues with the display.
Is this a NAV unit?
Did you have the theme set to the old Ford GT Blue theme previously?
If you updated thru the Syn3 Updater, can you post the log file from the usb?

The fact that the display will work, indicated by the autoupdate message, means that something is wrong with the display settings. This could be a splash screen or theme settings or combination that is no longer supported.

Do you have FORScan?

It is a non nav unit. I didn’t change any splash screens. Kept it at the Ford RS splash screen that is default. I do not have forscan. I’ll probably order the adapter if it will fix the issue.

`PREVIOUS CONFIGURATION
Version: 3.3.19052
Region: NA
Navigation: False
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Disabled / Not MY20

DESTINATION DETAILS
Mode: Drive
Model: SanDisk Ultra USB Device
FileSystem: exFAT
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.10.6.0 Stable - Autoinstall Mode - Sync 3.4.21194 NA

[SYNCGen3.0_ALL_PRODUCT]
Item1 = APPS - 5U5T-14G381-ET_1627475308000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G381-ET_1627475308000.TAR.GZ
Item2 = VOICE - 5U5T-14G391-CP_1626959995000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G391-CP_1626959995000.TAR.GZ
Options = AutoInstall

FILES (2)
5U5T-14G381-ET_1627475308000.TAR.GZ (847.2MB)
5U5T-14G391-CP_1626959995000.TAR.GZ (385.4MB)

LOG
[10/11/2021 9:16:08 PM] Selected Region: NA - Release: Sync 3.4.21194 - Map Version: Non Nav APIM
[10/11/2021 9:16:08 PM] Install Mode: Auto-Detect (autoinstall) Forced: False
[10/11/2021 9:16:08 PM] MY20 Protection: Disabled / Not MY20
[10/11/2021 9:16:08 PM] Formatting USB drive
[10/11/2021 9:16:08 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[10/11/2021 9:16:16 PM] Checking Existing File: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:16:16 PM] Downloading: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:16:45 PM] Validating: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:16:47 PM] Downloaded: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:16:47 PM] Checking Existing File: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:16:47 PM] Downloading: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:16:53 PM] Validating: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:16:54 PM] Downloaded: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:16:54 PM] Preparing USB drive
[10/11/2021 9:16:54 PM] Checking Existing File: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:16:54 PM] Copying: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:17:18 PM] Validating: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:17:21 PM] Copied: 5U5T-14G381-ET_1627475308000.TAR.GZ
[10/11/2021 9:17:21 PM] Checking Existing File: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:17:21 PM] Copying: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:17:40 PM] Validating: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:17:41 PM] Copied: 5U5T-14G391-CP_1626959995000.TAR.GZ
[10/11/2021 9:17:41 PM] Generating Autoinstall.lst
[10/11/2021 9:17:41 PM] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!
`

The log file does not indicate any issues with the installation. I can’t think of anything else that would be wrong. If it is the settings, this is not unheard of, as there have been a few cases here with this issue.

Can you post a pic of the display autoinstall message after the forced reboot?

@SaNdMaN , @avdonr , or anyone else have any ideas?

The OBDLink EX usb adapter is about $50 US. Cheaper than the Bluetooth and safer.
https://www.obdlink.com/aff/forscan-ex

Just bought the OBDLink EX, says it will arrive sometime Oct 12 (today). Hopefully I can figure out the problem.

You will want to look at the Splash (Boot) Screen settings and Theme settings, make sure you are not set for a 10" screen. Should be set for FordMY20 for Sync 3.4. Attached is an APIM spreadsheet with all the settings.
APIM As Built Database.xlsx (62.7 KB)

First thing is to save a vehicle profile, second thing is to save the APIM asbuilt data.

Here is a good tutorial for getting started:
FORScan Tutorial - Google Docs

Beyond trying to change the theme via FORScan I would suggest trying a downgrade and clean reformat back to 3.4.21194 if possible (I realize the screen is black so this may be difficult). That way we can ensure that there is no settings/config issues within the SYNC filesystem itself.

1 Like

Little update. I looked around in forscan for the items F150chief suggested. Still acts as if it loads the splash screen and then doesn’t continue loading. I am not sure if downgrading is possible? its like the system freezes. Unless i can just downgrade it and it’ll be working am not quite sure.

What would the autoinstall be for the downgrade to 3.3? would it be the same as

[SyncGen3.0_ALL_PRODUCT]
Item1 = 4U5T-14G381-AN_1552583626000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G381-AN_1552583626000.TAR.GZ
Options = AutoInstall

Yes, that would be correct. It should take about 10-15 minutes to perform the downgrade if it works.

Looks like it’s at Ford MY20 theme and RS boot screen. Did you change these or were they set to that already? If you changed it, you might need to perform a module reset. In FORScan, in the Tools menu, APIM Reset.

Can you get to the APIM Asbuilt Configuration page? Looks like this…
IMG_4700

If you can, at the bottom there is a save all button. Save the config. It will name the file automatically.

If you do not have the asbuilt configuration for your vehicle, go to Index - FordServiceInfo.Com (motorcraftservice.com) and input your VIN. This will take you to the asbuilt data for your vehicle. Download the .ab file and place it in the Asbuilt folder for FORScan. This will be under MyDocuments on the computer. When you select the Restore All button at the bottom, this will allow you to load the factory asbuilt for the APIM and see if it will recover that way. Just say yes to program it even if it says there is no changes. Once the APIM reboots, it might come back.

I did change it to the MY20, that was the only change from ford timeless which it was on prior. I did the APIM reset. plugged in the usb to downgrade. Waited around 45 min nothing happened. Is there a way I can use forscan to downgrade the APIM?

Did you reload the factory asbuilt for the APIM?

Yes I did, reload it back to the factory asbuilt

I’ll have to look at a few things…

The symptom of not being able to save any settings is a classic sign of failing emmc on the apim, your symptoms are unusual indicating hardware failure. You may need to obtain a replacement apim.

1 Like

That is what I found searching around also, unfortunately. I think that the EMMC has bad blocks(?) and unfortunately when it was updated wrote into those. When it was on Sync 3.0, it probably did not use that area in the storage so there was no issue. Just a guess…

The unit was previously upgraded to 3.3.19052. A 2017 APIM would not have been on this revision from the factory.

1 Like

If a downgrade to 3.3 works, I would suggest again the clean reformat to 3.4.21194 directly to see if that fixes the issues. I’m thinking something got messed up along the line with all these delta updates to a bunch of different applications/files.

1 Like

This is a chance, but if you want to try it…

Since you have FORScan, you could try to reload the firmware, specifically the ECU Config/Illumination Strategy. You will need a paid license for FORScan to program firmware. Read the attached file for instructions. If this does not revive it, it’s not likely to be fixed.

APIM Firmware Flash Rescue Gen 2 (H-2017).txt (1.2 KB)