USB stutter / glitch SYNC 3.4

What is your SYNC Region? USA

What was your Old SYNC Version? 3.4.21020

What is your current SYNC Version? 3.4.21020

What version of Syn3 Updater are you using? NA

Do you have Navigation? YES

Have you read the documentation at Syn3 Updater | Cyanlabs Docs ? YES

Do you have a error message, if so what is it? NA


Please paste your log output or provide the URL to your log file below
(Log files can be found on the root of your USB drive or in %localappdata%\CyanLabs\Syn3Updater\Logs)

REPLACE THIS TEXT WITH YOUR LOG

Please describe in detail your issue below

Curious about USB music stutter/glitches. Every since I bought my Escape almost a year ago now it seems to have USB music glitches. The first week of ownership I updated the SYNC software by wifi. It seemed to have issues doing this. I didn’t really listen to USB music much before the upgrade so not entirely sure it did it before the upgrade files or not.

Since then it has been month after month of frustration. Now I have had it in the dealership. They replaced the APIM, the media hub, and done other software updates. Nothing really seems to fix the issue permanently. The last round with replacing the media hub seemed to fix the glitches for about a week (had one glitch in a week of 20 minute commutes back and forth to work each way). Next week and it stutters and pops and clicks more than ever.

I went so far to create hash files to verify the data on the drives I am using (I tried seven different USB drives and ended up sticking with a ssd drive hooked up to a USB adapter). The verifications all came up OK so no file corruption is to blame.

Restarting a song that stuttered or has multiple stutters plays clean without issue.

Since this is a 2020 Escape I understand that only the dealership can reformat anything and clean out the bugs that may be there.

Anyone else have this issue? Did you ever fix it?

Sadly, it’s a known 3.4 issue.
Latest builds seem to mitigate the issue, but users reports say it’s still there, less obvious than in older builds, but present non the least.
There’s no known solution, it’s up to Ford.

2 Likes

I drove a few different loaners and never had that experience. Similar or same sync units (well on the outside).

I wonder if there is corruption in the file system that these updates don’t address.

Do have links to others with this issue? I want to collect more data. I want to fix it for myself and in turn everyone else. These types of files have existed for decades no excuse for Ford software devs to be so incompetent. I have cheaper digital media plays that never fail.

pretty confident it’s to do with CPU usage, causing latency, audio is extremely latency sensitive

1 Like

I do not have links, but if you search in these forums (the specific build threads) you will find many comments about it.

Even though the Sync3 version may be the same, not all APIMs are the same, some are slower, some are faster.

About performance, you can always try reformatting a unit to start from scratch, but 3.4 is more demanding than 3.0…

Again, sadly it’s a known 3.4 feature at the moment…

1 Like

Dealers also can’t do this.

That is unfortunate…

Trying to navigate to a fix is not easy. It is frustrating that some of the loaners I used like a 2020 Bronco that had a very similar SYNC system worked just fine–yet mine is what it is.

I have noticed that compared to windows pc the system only grabs data in segments instead of continuously reading the file as a stream. Also when I streamed from a USB cord (not using AA) there would be a digital drop noise and the audio would keep playing correctly on the phone device. As opposed to the USB drive that squashes the audio stream together.

Don’t these APIMs use a codec chip to decode the audio info in to a wav and then the DSP that the CPU software is doing that is messing up the playback? I tried turning everything off that I could and it didn’t seem to have a great impact on the frequency of these glitches.

What options other than using an FM transmitter with an external player do I have to USB music?

I’m not really sure what options you have.
Other than trying to use it via Bluetooth or Android Auto / Apple Car play…

If your unit is 2020 or later you can’t reformat of course, but I’m a buzzed to see such a later model with this issue. I mean, latest APIMs should be faster.

Try the lastest builds, try performing a master reset… But again, this is at this point a feature, it’s been there from day one.

And it’s one of the main reasons as to why I’m still at 3.0.

1 Like

I rarely have an issue with skipping but occasionally it does. I have researched this extensively and have not been able to pinpoint the issue, other than processing demands by the APIM. It usually happens when I’m using Nav. But maybe that’s just when I noticed it.

Like you say, feature.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.