USB Updates Never Finish (Official Ford OR Syn3 Updater)

The long and short of it…I BELIEVE I’ve done everything I’m supposed to do to try and update my wife’s Sync system. I’ve started from a master reset (which gets stuck in a boot loop when it tries to restart and has to be forced). I’ve unplugged the battery, restarted the system, etc. 32GB USB 3.0 drive, followed ford instructions (formatted exFat) and also used the Syn3 updated and followed every instruction for an update. Tried with and without maps. Looks like APIM has enough space but maybe it doesn’t (?)…log pasted below. Basically the “Updating System Software” pops up on top of the screen and it never does anything after that. No errors…just sits there…I’ve waited 1.5 - 2.0 hours a couple of different times and I’m tired of wasting the gas lol. Any help would be appreciated…I think the hardware may be shot (hence why a master reset won’t actually reboot itself and just eventually shuts the screen completely off and cuts power to the USB ports until several forced soft resets get it back up and running).

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: MY20

Install Type: OEM

Old SYNC Version: 3.4.21020

New SYNC Version: 3.4.21020

Do you have a error message, if so what is it?
None - nothing happens

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Version 5U5T-14G381-ER
APIM Model: 5U5T-14G371-CHD
APIM Type: Navigation 
APIM Size: 32GB 
APIM Free Space: 4.1G 
1/15/2023 10:50:36 AM +00:00

Partition Type = Free / Total
/fs/sd/MAP/ = 12M / 1.4G
/fs/sd/MAP/ = 36K / 1.4G
/fs/sd/MAP/ = 148K / 1.4G
/fs/sd/MAP/ = 12M / 1.3G
/fs/sd/MAP/ = 3.0M / 922M
/fs/sd/MAP/ = 9.3M / 1.3G
/fs/sd/MAP/ = 16M / 1.7G
/fs/sd/MAP/ = 13M / 1.4G
/fs/sd/MAP/ = 13M / 2.0G
/fs/Nuance/ = 9.9M / 1.6G
/fs/Nuance/ = 6.4M / 1.1G
/fs/Nuance/ = 25M / 2.6G
/fs/Nuance/ = 3.0M / 465M
/fs/Nuance/grace = 5.8M / 775M
/fs/rwdata/ = 641M / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 90M / 90M
/fs/mp/ = 133M / 1.4G
/fs/images/ = 4.1G / 25G

Installed Packages

APIM AsBuilt
DE00: AA0A010308026B0C048A
DE01: 55530B04B40B5498A8B6C405
DE02: 0006080200
DE03: 000001900B000B
DE04: 1ABD1AA42E85
DE05: 10
DE06: 1B003300000000753000005656940076
1 Like

Post the log for the USB you created with syn3updater

Branch: Stable
Operating System: Microsoft Windows 10 Pro (2009)

Version: 3.4.21020
Region: NA
Navigation: True
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Enabled

Mode: Drive
Model: USB SanDisk 3.2Gen1 USB Device
Size: 28.7GB
FileSystem: FAT32
Partition Type: MBR

; CyanLabs Syn3Updater Stable - Autoinstall Mode - Sync 3.4.22251 NA

Item1 = VOICE - 5U5T-14G391-CS_1660783942000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G391-CS_1660783942000.TAR.GZ
Item2 = GRACENOTES - 4U5T-14G423-CC_1615429225000.TAR.GZ
Open2 = SyncMyRide\4U5T-14G423-CC_1615429225000.TAR.GZ
Item3 = APPS - NU5T-14G381-AB_1665525837000.TAR.GZ
Open3 = SyncMyRide\NU5T-14G381-AB_1665525837000.TAR.GZ
Options = AutoInstall

5U5T-14G391-CS_1660783942000.TAR.GZ (385.5MB)
4U5T-14G423-CC_1615429225000.TAR.GZ (564.2MB)
NU5T-14G381-AB_1665525837000.TAR.GZ (869.8MB)

[1/15/2023 11:02:49 AM] Selected Region: NA - Release: Sync 3.4.22251 - Map Version: Keep Existing Maps
[1/15/2023 11:02:49 AM] Install Mode: Auto-Detect (autoinstall) Forced: False
[1/15/2023 11:02:49 AM] MY20 Protection: Enabled
[1/15/2023 11:02:49 AM] Formatting USB drive
[1/15/2023 11:02:49 AM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[1/15/2023 11:03:01 AM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ
[1/15/2023 11:03:06 AM] Validated: 5U5T-14G391-CS_1660783942000.TAR.GZ (Skipping Download)
[1/15/2023 11:03:06 AM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ
[1/15/2023 11:03:12 AM] Validated: 4U5T-14G423-CC_1615429225000.TAR.GZ (Skipping Download)
[1/15/2023 11:03:12 AM] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ
[1/15/2023 11:03:24 AM] Validated: NU5T-14G381-AB_1665525837000.TAR.GZ (Skipping Download)
[1/15/2023 11:03:24 AM] Preparing USB drive
[1/15/2023 11:03:24 AM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ
[1/15/2023 11:03:24 AM] Copying: 5U5T-14G391-CS_1660783942000.TAR.GZ
[1/15/2023 11:04:04 AM] Validating: 5U5T-14G391-CS_1660783942000.TAR.GZ
[1/15/2023 11:04:07 AM] Copied: 5U5T-14G391-CS_1660783942000.TAR.GZ
[1/15/2023 11:04:07 AM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ
[1/15/2023 11:04:07 AM] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ
[1/15/2023 11:05:15 AM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ
[1/15/2023 11:05:19 AM] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ
[1/15/2023 11:05:19 AM] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ
[1/15/2023 11:05:19 AM] Copying: NU5T-14G381-AB_1665525837000.TAR.GZ
[1/15/2023 11:07:07 AM] Validating: NU5T-14G381-AB_1665525837000.TAR.GZ
[1/15/2023 11:07:35 AM] Copied: NU5T-14G381-AB_1665525837000.TAR.GZ
[1/15/2023 11:07:35 AM] Generating Autoinstall.lst

Everything looks good, even the amount of free space the APIM has (over 4GB).
Before trying to make even more room (which should not be needed), do you have another USB Pendrive to try with?.

Your kind of upgrade should take about 10-15 minutes since you are only upgrading a small portion of the system.

Even you not being able to complete a Master Reset (which is not a good sign), the unit seems responsive since it’s processing the interrogator log…

I’ve tried like 5 different drives and the one from the log is brand new. I have one more 64GB I just bought that I can try and will report back.

Up until yesterday I couldn’t even get the interrogator to work but now it does. When I tried the update with Maps I actually got an install pop-up related to the maps update so I thought I was in good shape. 2.5 hours later…no dice.

The master reset works…I just have to force it to boot back up after it shuts off. I agree though that was my first inclination that the unit is shot.

Appreciate the feedback I’ll give it another try with a different drive when she gets back later since I just reset it again before she left. Do you think trying a different earlier version (later than what is on there) might help? Maybe there’s something in an earlier update that is needed before the newest one will take?

If you already tried so many different drives, I would not bother with another one.
I mean, a single USB drive could be bad… but 5?.. neh… not worth it…
And honestly, your latest log shows that the USB you used is fast…

About the Master Reset, it should not be necessary to do anything for it to work… Even if it works “forcing” it, the forcing should not be necessary.

Is the unit under warranty?.

It is. I’m waiting for the damn dealership to get back to me for an appointment to bring it in.

I was also hoping to just get it fixed since they’ll probably sit on the damn thing all day, attempt to run the update 30 mins before they close, then ask me if they can keep the vehicle overnight and tell me they need more time to troubleshoot it…rinse and repeat haha

Sorry, I forgot to answer these:

Not really, since they all have similar space requirements.
If the issue is the free space, it should not matter which version you choose.

Master reset should take care of that, plus the unit should somehow states there’s something pending.

Going back on track, here’s the deal.
There are a few things you could try, but if the unit is under warranty (specially a MY20 model) and you have a valid Ford ugprade that’s also failing, I would certainly go that road first. The reason is that with MY20 hardware your options are limited since you can’t reformat it, and if in fact there’s something wrong with the unit, it’s better for them to take a look at it. You can just tell them the master reset issue and that the official Ford upgrade does not work either, that will give them enough information.

If you still want to pursue upgrading on your own, there are a few things I can think of, like making a bit more of room…

But if you ask me, I would have the unit checked first under warranty.

Also, your car has multiple USB ports, right?.
Have you tried different ones?.

Will do. Thanks. I’ll check back in once I get it in for service.

Please post the actual xml file generated by the Interrogator Utility.

You could try deleting Gracenote and trying the Sync version update only to see if that works. If it does, then there is a processing issue due to free space. If it does not them there is something else at play. If I can look at the actual xml I can check a few things.

Have you checked the Ford Navigation site to see if the vehicle is eligible for free maps update?

Log file posted…I THINK this is the same one from my earlier post.

I’ve tried removing the gracenotes and that also just did nothing like the updates. I may try again while Ford still hasn’t gotten back to me about service.

There is the free maps update on the Ford site. The maps update from Syn3 did START but I was running it combined with the software update and 2 hours later nothing was happening.

Side note - UConnect on my 2021 TRX updated flawlessly in 10 mins with a USB. Also, the update UI has a countdown, progress bar, text showing which module is being installed…one would think there would be SOME sort of UI for Sync updates so we’d be able to tell if anything is happening or not!

Sync_WY6CFS91_1FM5K8GCXLGA46683.xml (11.2 KB)

There’s a mixture of versions on that APIM, I mean maps and voice_nav packages.
It’s evident there was an upgrade that was not completed fully.

Lets see what Ford says.

That wouldn’t surprise me one bit. At one point the WiFi updates were working, then they stopped. I ran a USB update that completed but uploading the XML file wouldn’t work on the Ford site so it kept trying to download and install an older update which wouldn’t work but eventually went away. Now we are where we are.

Are you able to tell which pieces of the updates are the most recent and what version they’re from? I’m wondering if it’s the 2021 update that got screwed up or if it was from these recent attempts where after 2 hours of running the engine I had no choice but to bail.

I did follow the official procedure for an incomplete update with Ford where you upload the XML file and recheck for updates, and it’s SUPPOSED to create an update package that starts from where you left off. Obviously that didn’t work haha.

I’ll continue to keep everyone posted if I ever get through to anyone to make a service appointment.

Update: Almost like their ears were ringing…first available appt Feb 15. Guess we’ll have to wait this one out for a bit unless anyone wants me to keep tinkering haha

Yes sir, we can, but since many things were performed against the unit, it’s hard to say where it started to go wrong.

Most maps (4U5T-14G421-C*C) are 1.19 (2019), but there’s one that’s older than that: 4U5T-14G421-CBB (it should be CBC).

Voices for NAV are also mixed:
They should be either ending in H or C, but not mixed. H is more recent (2020), of course. C is from 2018.

So yeah, something went wrong with the autoinstall.

1 Like

Would it make sense to create an update package with the existing version that’s showing on the vehicle to see if the random packages update and straighten this out? Or maybe just a drive with the specific items that are mismatched?

Yes, but first wait what Ford says…
If Ford’s a dead end, there are few things we can try.
But again, since it’s a MY20 APIM and under warranty it’s best to be fixed by Ford.

Of course, then it will be up to you if you abandon Ford’s upgrade path or not…

For instance, you won’t be able to install the latest maps with Syn3Updater since they are ESN locked if I’m remembering correctly , but you could get them from Ford if you are elegible…

Hello, is there any update from your side?, it’s been about 2 weeks now.

They had no appointments until Feb 15 so still waiting to bring it in.

Update: HA! Exactly what I said would happen, happened. I am having it out with the service center for lying right to my face. Tried to save them the diagnostic time and just said, “Try to do a factory reset and try to run a sync USB or OTA update, you’ll see the hardware is borked.” They let me know there was a recall on the 360 camera…ok cool take care of that too.

I go to pick it up…“You mentioned to my wife the recall was done but what about the head unit issues.” Guy claims part of the camera recall was a whole system update blah blah blah everything is all set. I’m in a rush so I start the thing up, the software version takes a bit to load, and I’m already on the road. It finally populates…21020 - you MFer! In addition now for weeks, including before the service and after, I get “Updating System Software” on top of the screen every time its on.

So I call back and say, hey chief you didn’t AT ALL update anything…I can see the version number is still from 2021. He claims he’s looking through Ford Connect and all systems are connected but on 2/13 they weren’t communicating properly with the APIM, so that means it was probably fixed, and its running an OTA right now. Except its not connected to Wifi (and I can’t get it to) so how is it running an OTA?

Basically I have to call back tomorrow and say “Yup still the same problem” and probably wait another month for an appointment unless I raise absolute hell.

Keep you all posted…I guess I won’t get the blue screen of death backup camera anymore at least? One would think I wouldn’t get BS’d considering the troubleshooting I laid out to them in advance that I had already done AND told them exactly what to do to reproduce the issues. Unreal…

Some service departments are good, some suck. Good luck with the progress, hope they can resolve it without driving you crazy. At this point the camera is fixed, so you could try just updating the Sync software to at least 3.4.21265 (which is a stable version).

1 Like