Waze Speedometer in carplay is broken / jumps around

Hello there,

in October last Year I decided to reformat my EU NAV Sync 3 APIM in my 2017 MK8 Fiesta to Version 3.4 21194. I since then updated to 3.4 21265. I also tested 3.4.22020.
I’ve made changes to the APIM ASBuilt recently to enable the heated Seat Icons.
But I tried with my factory ASBuilt and it’s still broken.

Ever since the reformat the Speedometer and Map zoom in Waze work really unreliable in CarPlay. Rather than maintaining a set speed it just jumps around sometimes having a 15-60km/h offset to the actual driving speed. That also means that the Map zoom just rapidly zooms in and out.

This only happens on my Sync 3 I’ve tested that in some other cars including a Renault Zoe, and a Fiesta MK 8 with Sync 2,5 and a C-Max with Sync 3.0. It works completely fine there.

Since I heard that some Data like speed are combined out of GPS and some info provided by the car I figured this might be related to the reformat.

Here is a video of the issue look at the speedometer in the top right. I’m maintaining a constant speed there. Waze Sync 3 issue - YouTube

The Built in Nav works fine without issues
AppleMaps works fine without issues (Although I think it’s kinda zoomed in too much on highways but in general it works completely fine)

I tested this with the current stable AppStore release and the TestFlight release of Waze. They both behave the same.
Also tried a different cable, USB port and iPhone just to be sure.
It works on AndroidAuto for the majority of the Time. It does have some hiccups too but not as bad as on CarPlay (-7km/h at worst and it doesn’t jump around so much)

Hopefully someone here has an idea of whats wrong.
Maybe this is a Waze issue after all but I hope it’s just something like a ASBuilt change that has to be made to fix it.
(I’m changing to summer tyres next weekend but that shouldn’t affect that… I think.)


SYNC Region: Europe

Navigation Variant: Yes

Old SYNC Version: 3.0.20204

New SYNC Version: 3.4.21265

Do you have a error message, if so what is it?
No Error Message

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.10.8.0

Syn3 Updater Documentation Read: Yes

Syn3 Updater Log File

CYANLABS - SYN3 UPDATER - V2.10.8.0
Branch: Stable
Operating System: Microsoft Windows 11 Pro (2009)

PREVIOUS CONFIGURATION
Version: 3.4.22020
Region: EU
Navigation: True
Install Mode: Automatische Erkennung (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Automatische Erkennung

DESTINATION DETAILS
Mode: Drive
Model: Lexar USB Flash Drive USB Device
FileSystem: exFAT
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.10.8.0 Stable - Autoinstall Mode - Sync 3.4.21265 EU

[SYNCGen3.0_ALL_PRODUCT]
Item1 = GRACENOTES - 4U5T-14G423-AC_1615425645000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G423-AC_1615425645000.TAR.GZ
Item2 = ENH_DAB - 1U5T-14G658-AG_1626915602000.TAR.GZ
Open2 = SyncMyRide\1U5T-14G658-AG_1626915602000.TAR.GZ
Item3 = VOICE - 5U5T-14G391-AR_1633363332000.TAR.GZ
Open3 = SyncMyRide\5U5T-14G391-AR_1633363332000.TAR.GZ
Item4 = APPS - 5U5T-14G381-EU_1634769242000.TAR.GZ
Open4 = SyncMyRide\5U5T-14G381-EU_1634769242000.TAR.GZ
Options = AutoInstall


FILES (4)
4U5T-14G423-AC_1615425645000.TAR.GZ (689MB)
1U5T-14G658-AG_1626915602000.TAR.GZ (56,8MB)
5U5T-14G391-AR_1633363332000.TAR.GZ (1,5GB)
5U5T-14G381-EU_1634769242000.TAR.GZ (847,2MB)

LOG
[04.04.2022 18:05:03] Selected Region: EU - Release: Sync 3.4.21265 - Map Version: Vorhandene Karten behalten 
[04.04.2022 18:05:03] Install Mode: Automatische Erkennung (autoinstall) Forced: False 
[04.04.2022 18:05:03] MY20 Protection: Automatische Erkennung 
[04.04.2022 18:05:03] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[04.04.2022 18:05:05] Validated: 4U5T-14G423-AC_1615425645000.TAR.GZ (Skipping Download) 
[04.04.2022 18:05:05] Checking Existing File: 1U5T-14G658-AG_1626915602000.TAR.GZ 
[04.04.2022 18:05:06] Validated: 1U5T-14G658-AG_1626915602000.TAR.GZ (Skipping Download) 
[04.04.2022 18:05:06] Checking Existing File: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:05:07] Validate: 5U5T-14G391-AR_1633363332000.TAR.GZ (Failed!, Downloading)
[04.04.2022 18:05:07] Downloading: 5U5T-14G391-AR_1633363332000.TAR.GZ
[04.04.2022 18:08:54] Validating: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:08:59] Downloaded: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:08:59] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:08:59] Downloading: 5U5T-14G381-EU_1634769242000.TAR.GZ
[04.04.2022 18:11:23] Validating: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:11:26] Downloaded: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:11:26] Preparing USB drive
[04.04.2022 18:11:26] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[04.04.2022 18:11:26] Copying: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[04.04.2022 18:14:34] Validating: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[04.04.2022 18:14:36] Copied: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[04.04.2022 18:14:36] Checking Existing File: 1U5T-14G658-AG_1626915602000.TAR.GZ 
[04.04.2022 18:14:36] Copying: 1U5T-14G658-AG_1626915602000.TAR.GZ 
[04.04.2022 18:15:04] Validating: 1U5T-14G658-AG_1626915602000.TAR.GZ 
[04.04.2022 18:15:04] Copied: 1U5T-14G658-AG_1626915602000.TAR.GZ 
[04.04.2022 18:15:04] Checking Existing File: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:15:04] Copying: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:23:22] Validating: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:23:26] Copied: 5U5T-14G391-AR_1633363332000.TAR.GZ 
[04.04.2022 18:23:26] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:23:26] Copying: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:27:51] Validating: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:27:54] Copied: 5U5T-14G381-EU_1634769242000.TAR.GZ 
[04.04.2022 18:27:54] Generating Autoinstall.lst
[04.04.2022 18:27:54] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!

What about Google Maps?

This is an issue with Waze implementation in CarPlay and Android Auto affecting Sync. This is documented on various forums, including their own.

Here to give a small Update
Google Maps works fine without issues and so do Here and Magic Earth.

@F150chief I was hoping, not to hear that and from what I’ve found after your post the issue hasn’t been resolved in over a year… The only good thing is, that it’s not a Sync issue but rather a Waze issue that occures on many many vehicles and Brands.

Thank you both.
I think this thread can be closed now.

1 Like