2016 Ford Flex No CarPlay

I took my car (2016 Ford Flex) to the dealer for warranty repairs and I previously had CarPlay. Turns out, the previous owner installed “Lincoln branded software” (Sync 3.0.20204) to use CarPlay. Now, I have actual “Ford software” (Sync 3.0.23219), as they called it. It looks more like a theme change.

After the repairs were complete, they told me they had to replace the APIM. I have had the vehicle for 2 years, and have used CarPlay the whole time, until now.

I used the Syn3 tool to do the interrogator. It determined I have a MY20 module. I bet I didn’t have one before this repair. I am not sure how to proceed without bricking my stereo. I have attached the XML file generated in the first step.

I just want CarPlay for my trip from KC to Nashville in August so I can use navigation, as my vehicle does not have it built in.

Sync_W34GBBNR_2FMHK6C85GBA07001.xml (10.2 KB)

SYNC Region: NA

Navigation Variant: Non Nav

Manufacturer Year: MY20

Install Type: OEM

Old SYNC Version: 3.0.20204

New SYNC Version: 3.0.23219

Do you have a error message, if so what is it? N/A-didn’t even try with the warning messages.

Update Method: Official Ford

There is no difference between a Lincoln and Ford APIM or SYNC software. It’s just a simple AB setting that changes the theme.

1 Like

Usually if things stop working, upgrading won’t fix them.
If you have been using CP for about 2 years and it just stopped working, that does not seem related to Sync3.

You can always perform a master reset, delete the car from the phone and re-pair them…
But again, there may something else at play.

Does Android Auto work?

1 Like

When I took it to ford last week, they replaced the APIM and upgraded the stereo without telling me. Then they told me that my car was not sold with CarPlay and they can’t unlock it. The SYNC3 ports are the same as before and it shows iPhone connected but CarPlay never pops up.

Nobody in my house has an android device. I’ll ask some coworkers tomorrow. But ford did tell me that they had to lock it since it was sold without that “feature”.

A 2016 Ford Flex never was sold with Carplay. If it was working before it was out of luck as you need a newer USB module that the 2016 Flex did not have.

It is easily added though with a newer Sync version and USB hub.

1 Like

I’m confused… when was the repair / APIM change done?..
If that was done 2 years ago, that’s NOT the reason as to why you do not have CP now…
If it’s was recent and you are still on 3.0, there’s something you can try…

1 Like

I do apologize. I see I didn’t make that clear. I took it to the dealer Monday 7/1. By Tue 7/2 they gave it back and then I found out they replaced the APIM. It worked up until the day I got that car back from warranty repair.

What’s your current Sync3 version?.

1 Like

The current version is 3.0.23219

Assuming yo have already performed a master reset and removed the car from the phone to later repair the both of them, if only the APIM was changed I would assume the HUB has not been replaced…

If so, try this as a reference guide → 2016 Mustang Sync3 1.0 updated to 3.0 and no Apple Carplay! - #10 by SaNdMaN

Once you are on 2.2.xxxx, try if CP works.

I’ve asked if you had an Android device to test this with since Android is more forgiving (or less picky) than iOS…

1 Like

I removed my phone from Bluetooth and master reset the stereo. I created a USB drive with the autoinstall.lst in the root and HN1T-14G381-SA_64817.tar.gz in a folder named “SyncMyRide”.

I started the car, inserted the USB, and waited about 3 minutes for it to say “updating system”. After, it said, “changes will take effect when you start your vehicle next”. The screen went black.

I turned the car off, opened the door, waited a few minutes, and started it back up…still a black screen.

Black screen?, that’s unusual.
Can you share a screenshot of the USB 's root and whatever lst file content?

Also, is the unit operational?
Audio?, radio?, powered USBs?.
Try performing a soft reset …

It was weird. Took about 9 minutes to read the flash drive, upgrade, and complete. Once I tapped “OK” on the screen, it shut off.

I have not tried a soft reset. I will look it up and give it a shot. Thank you.

; 2.2.17011 install

Item1 = APPS - HN1T-14G381-SA_64817.tar.gz
Open1 = SyncMyRide\HN1T-14G381-SA_64817.tar.gz
Options = AutoInstall

The stereo seems to be dead. I hope warranty covers it again. I’ll probably just end up getting after market sadly. Then trading it in on something newer.

The compass only points north now, the time reset when I did the power button and seek forward but nothing else changed. Still a black screen. No sound. No usb charging.

I honestly do not know what’s going on…
I’m starting to doubt about what job was done to your car…
There’s something that does not add up…

The .LST you provided should be harmless to a normal APIM running 3.0.xxxx, it would just “update” from 3.0 to 2.2… that’s it… A black screen resulting from such a simple procedure makes me wonder what’s really going on with the APIM…


  • Do you have forscan and an adapter?
  • Does your vehicle have a rearview camera?. If so, does it work?.

I was thinking of ordering one of the usb adapters on payday. This is the 3rd APIM replacement under warranty. The first and second time, I took it to where I bought the car. The third and most recent time I took it directly to my local ford dealer.

I do have a backup camera. I hear the beeps when I get close to something but no picture. The clock and compass aren’t working. The usb isn’t charging or even showing connected. It’s so strange. Every video I’ve watched it’s so simple and straight forward. This thing has always had problems.

I am willing to bet you have a 2020 APIM in there and you did a reformat.

It absolutely does have a My20 and I was really worried about that. I’m not sure what the auto install script does, so I just followed the posted instructions.

I would not mention anything about Cyanlabs to the dealership. They will void your warranty if they find out you caused it.

Let us know how it goes.
It would be awesome to see a picture of the APIM’s back… as I said before, something just do not add up… I’m not saying this last job you got done on the car the culprit, but you mentioning that CP used to work but now it does not and that a simple autoinstall apparently killed the APIM makes me thing that there’s an unknown part of the story…

If the unit is not operational at all (no sign of life, no reverse camera), that really sounds like a MY20 reformat… but the .LST file you sent before does not show that, not at all…

That should not had happened to a normal APIM…

1 Like