2016 Ford Flex - Update Message with No USB

Hi all, thanks in advance for any help, it is appreciated. I have a 2016 Ford SEL with Nav. Just bought it used. Trying to upgrade enough for Android Auto and Carplay. So far only through the Ford USB method.

It was on Sync3 1.0 15139 when I bought it. I tried the Ford direct USB update (Sync3 1.0 to Sync3 3.0) and it would not take and it stayed on 1.0. So after reading a thread online, it said to try to go to 2.2 before going to 3.0. I tried to go to 2.2 with the USB (files from a f-150 forum). I gave up on that process after it took way too long and I got low on fuel. I never got an install complete message. But now my build number says Sync3 3.0 20204 (my files were for 2.2, which is confusing, to say the least, I just cross-checked the files in the database and they are indeed for 2.2 ).

It now has the “Updating System Software…” message on the screen but no USB plugged in. Also no options in settings for Carplay or Android Auto. Hub is ordered but not in yet.

Any advice on the best method to get rid of the “Updating System Software…” message and get to the right version and have AA and CP?

For reference the USB 2.2 file list:

  • HB5T-14G386-TCB
  • HN1T-14G391-CC
  • HN1T-14G423-CA
  • HN1T-14G381-LG

Update: I did the soft reset. Power and Skip button. “Updating” message went away. Going to try to install 3.0.20204 again and see if that works.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 1.0.15139

New SYNC Version: 3.0.20204

Do you have a error message, if so what is it?
Updating System Software…

Update Method: Official Ford

Before moving forward, create and run an interrogator log to see what’s on the unit.
There’s really any logic for it to “magically” go to 3.0 when the USB had 2.2 files as you said, so something else is happening here. Are the WIFI updates enabled?, if so disable them just to be sure.

About the AA or CP options they won’t appear until an AA or CP session is established.

Ok, thank you for your help! Really appreciate it. Here are my latest steps.

  1. Soft Reboot: that got rid of the “Software update” message nag. It still would not take update to 2.2

  2. Hard Reboot: It still said it was on 3.0.20204

  3. I followed part of this thread:

  1. I installed: HN1T-14G381-SA - only this file nothing else with the instructions in that thread. I used a folder and autolist, etc.

  2. After that installed, my system currently says it is on 2.2.17011.

  • I left auto system updates off in settings.

  • Android Auto now works.

  • Carplay is not there in settings and/or not working if I plug in an iphone. (USB hub coming this weekend) Will that fix CP?

  • Ran interrogator log as you suggested. Here are the results.

VIN: 2FM****
Version HN1T-14G381-SA
APIM Model: GB5T-14G371-CFC
APIM Type: Non-Navigation           ******<-- This unit has working Navigation!?
APIM Size: 0GB 
APIM Free Space: Unknown 
7/25/2023 6:56:44 PM +00:00
Partition Type = Free / Total
/dev/hd0t180 = 54710240 / 7306221568
/dev/hd0t181 = 2097120 / 696151040
/dev/hd0t178 = 2097152 / 136764416

Installed Packages
JR3T-14G391-CE * Voice - ALL - 3.2.19056-Pre18.5
GB5T-14G422-CJ * Voice_nav - NA - 1.015049
JR3T-14G423-CB * Gracenotes - NA -
GB5T-14G421-CJ * Map - NA - 1.015048
GB5T-14G424-CH * Map License - NA - not in DB
APIM AsBuilt
DE00: 222105022B028100000A
DE01: 555301044082000000000000
DE02: 0000000000
DE03: 01000000000001
DE04: 198C198C2E0E
DE05: 80
DE06: 0A0033000000000EF900005656840069

I am not certain what all of that means but some of it makes sense. I would like to update this unit to the highest level still allowed by Ford for now. What steps should I take to do that? Carplay is the most important for my wife, since she drives it. Thanks for your advice.

This is the file list direct from Ford that originally did not work and why I was trying to go to 2.2 first, then 3.0. I cross-referenced the database.

Item1 = HB5T-14G386-THB - Tool - ALL
Item2 = HB5T-14G386-TCC - Tool - ALL
Item3 = JR3T-14G391-CE - Voice - ALL - 3.2.19056-Pre18.5 - already installed
Item4 = JR3T-14G381-AX - APP - ALL - 3.0.20204
Item5 = JR3T-14GC423-CB -  not in DB 
Item6 = GB5T-14G386-AC - Tool - ALL

I guess my main question is. If I want to get to 3.0.20204 should I simply install those Ford files now or do I only need the (3.0.20204) APP file? It appears that version of voice is already installed (can I leave that out), not sure what the other “Tools” are.

Following up in case anyone else has a related issue with a 2016 Ford Flex.

It is said in other posts but I will confirm. If you are on Sync 3 v1.0, installing 2.2 first seems to be the solution if you are hitting snags. I was using a 3.0 USB and Ford method. Then a new USB hub fixes CarPlay.

I will probably upgrade to 3.0.20204 ( JR3T-14G381-AX - SYNC 3 APIM Software (IVSU) Database - CyanLabs ) but haven’t yet. Then maybe 3.4 with Syn3. As of now everything functions properly so might just leave it since I don’t use Ford navigation.

Thanks to this site and all the admins and contributors!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.