2018 ford f-150 after update to 3.4 21194 no navigation function

Updater does not say, it’s configured.
So it seems you told syn3updater you do not have nav, that’s why you have no maps.
So configure syn3updater right, set your current 3.4.xxx build as current, SELECT NAV, and try again…

ok ,i will do reset and report back to you. OK

@F150Chief i think he just misconfigured Syn3updater.
He said he used to have nav, but the updater said no-nav…
I think that’s the issue, but without logs who can tell, really… it’s all guesses based on the information provided…

SYNC Region: North America & Canada
Navigation Variant: Yes
Old SYNC Version: 3.0 19052
New SYNC Version: 3.4 21194
Do you have a error message, if so what is it?
Navigation Fault
Navigation is not functioning properly.
Please visit dealer for service

It’s set for NAV, but maybe did not select the maps version, or kept old maps, which will not work.

when i open the updater now and select usa and 21194 it indicates non nav. should i reset ? Thank you for your patience .How can i select maps when it doesn’t show any?

From 3.0 to 3.4 is a reformat, so he kept nothing.
Since there are no logs and he said “updater said no nav apim”, well, that leads me to believe he just misconfigured the updater.

@kingfiss it’s not hard, start reading before touching random buttons.
Master reset won’t do a thing, because you didn’t select maps.

As said before, configure syn3updater right: tell it you have nav, select your current and desired versions, recreate the USB and try again.

1 Like

what would be a good version to pick to recreat usb drive?I will try .

The latest

Thank you i will try and report back.Kingfiss

Ok, good luck with that.
While you create the USB, read the tutorial you need to follow: Windows Automated Method - Update to Ford Sync 3.4 - CyanLabs , the Updating (Downgrade Mode) section.

Open the updater and go tho the setup tab. Fill out the config at the top as 3.4 21194, North America & Canada, Navigation Variant: Yes. Save the config.

Go to the update tab. (The house) Select the following…

i just got you last instructions, will try to follow and report back,thank you.

Hello guys, i have also facing the same problem , i have ford edget 2017 and went according to the instruction of selecting nav. and the other steps, now its updated on my car except the Nav is not working, do you think by master reset will solve this issue, if not , shall i download again the update on my USB or ishall use the same USB file to upgrade ? by the way, i’m living in Middle east thank you

Thank all who were involved in helping me see my mistake,followed F-150Chief and Sandmans instructions to a tee.Everything is working perfectly. Many thanks again. Expert advise. Thank you for your patience.Kingfiss

Did you make the region and navigation settings in the APIM asbuilt with FORScan?

1 Like

Don’t know what step exactly you mean, but all the steps that explained in the video, I followed, I selected Middle East and activated the Nav bar. Before i download it. Will you please screenshot this step?so I know exactly what you mean .thanks


Hope it works for you.

Read this:
Tutorial: Installation of ROW (NNG) Maps on NA 32GB Sync 3 APIM - Ford / Guides & Info - CyanLabs Official Community

You need to make the asbuilt changes…You need to change the country code in the APIM to the country you are presently in and change the map type to NNG.

APIM Asbuilt Settings:

The country information in the APIM As Built needs to be changed:
from 7D0-02-01 5553 xxxx xxxx
to 7D0-02-01 XXXX xxxx xxxx
This setting changes the country from US to your country code.

When changing from NA to ROW (NNG) maps, the Navigation Map Type will need to be changed from Telenav to NNG. (Central America, Caribbean, India and Sri Lanka, Israel, Middle East, North Africa, South Africa, South East Asia)

7D0-01-02 x*xx xxxx xxxx
USB2, Navigation Map Type (Telenav/NNG), Rear Electronic Feature Panel (REFP) (Rear EFP with Rotary Volume Knob)
0=USB2 Disabled, Navigation Disabled, Rear EFP Disabled
1=USB2 Disabled, Navigation Disabled, Rear EFP Enabled
2=USB2 Disabled, Navigation Enabled (Telenav Common HMI), Rear EFP Disabled
3=USB2 Disabled, Navigation Enabled (Telenav Common HMI), Rear EFP Enabled
4=USB2 Disabled, Navigation Enabled (NNG External HMI), Rear EFP Disabled
5=USB2 Disabled, Navigation Enabled (NNG External HMI), Rear EFP Enabled

If you have a setting of ‘2’, use a setting of ‘4’.
If you have a setting of ‘3’, use a setting of ‘5’.

This topic was automatically closed 9 days after the last reply. New replies are no longer allowed.