Android Auto from Sync3 v1.0 to v3.0 - 2016 Lincoln MKX

Bought a 2016 Lincoln MKX from a Ford/Lincoln dealer running on Sync 3 V1.0.15139, (Gracenotes and Maps NA 1.14 if it matters any) and they said I could update it at home via WiFi or USB. Tried both, using the 3.0 update from the Lincoln website, letting the USB run for about 3 hours. Update was attempted with a 64gb USB 3.0 Sandisk flash drive. Do not want to update to 3.4, as I don’t feel like I would be tech savvy enough to troubleshoot any issues that may arise from that. Only looking to go as far as V3.0.20204 so I can use Android Auto.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 1.0.15139

New SYNC Version: 3.0.20204

Do you have a error message, if so what is it?

Update Method: Official Ford

What’s with this new “people” that are new (less than 20 minutes from registration) and do not even say “hi” or “thanks”…

To be on the safe side, you should not go straight to that build.
You should install intermediate build 2.2.17011.

Check this thread for guidance: 2016 Mustang Sync3 1.0 updated to 3.0 and no Apple Carplay!

It looks you will have to get your hands dirty either way.

If you plan on staying on Sync 3.0, see this tutorial also for help with the Maps if necessary.
Tutorial: Sync 3.0.20204 with 2020 NA2.20 Map Installation - Ford / Guides - CyanLabs Official Community

I apologize for that, when I wrote this post I was frustrated from dealing with what I perceived as lack of help from the dealership and it hadn’t crossed my mind. Thank you and F150Chief both for the information, I’ll give it a shot.

The 2.2 Update was successful, getting ready to continue on to the 3.0 update here shortly. Thank you both very much, I really appreciate it!

Hi there!.
We are glad you were able to make some progress.
Does Android Auto work now for you?.

Just keep in mind that there’s a possibility that a new hub would be required for car play, but you should be able to get Android Auto working without any “USB hubs not supported” messages…
But even if that happens, it’s an easy and cheap fix (hub replacement).


Android auto was working with the 2.2 update, haven’t tried to plug in an iPhone to see what happens. I’ll probably end up doing the USB hub update in the next week or so just in case I ever end up with one.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.