Another MEM_ERR01 issue

I start off with an apology as I’m sure this has been covered umpteen times elsewhere, but I am seemingly going round in circles and concerned that I’m going to end up bricking the unit.

I have a 2020 (UK 69 plate) Fiesta which throws up a MEM_ERR01 when using the official Ford website download.

I believe the problem started when I used a cheap eBay USB drive which now seems completely dead, leading me to believe it stopped working mid-upgrade.

I have used the Gracenotes removal, Small Voice package and Downgrade options on the Syn3 utility but nothing has worked. In fact after downgrading I struggled to upgrade it back to the version it was on previously.

Looking at the interrogator log, it says Free Space 14G from a 64GB size.

Another issue I now have is since doing the downgrade I now have the US voice instead of the UK voice. How can I restore the UK voice?

I have owned the car for just a few months so I’m not completely familiar with the update side of things.


SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Unknown

Install Type: Unknown

Old SYNC Version: 3.4.22200

New SYNC Version: 3.4.22200

Do you have a error message, if so what is it?
MEM_ERR01

Update Method: Official Ford

ford

Send these:

  • the full interrogator log
  • the autoinstall file Ford pushed your way

Should I snip out the VIN?

I would, but that’s up to you.
We need to see the other stuff, VIN is irrelevant.

Attached. Thank you.
autoinstall.lst (610 Bytes)
Sync_NYBK012G.xml (11.3 KB)

Thanks, I will review then later once I have access to my computer.

EDIT
I’ve reviewed the files and nothing screams an error.
That log seems ok, unless the unit is not giving us all the information due to a previous unfinished install. Have you master reset the unit?.

Also, the files Ford pushed your way are only NAV_VOICEs files, not maps.
Once a MR is done, you can try installing them again.
You should not have to do this since your unit has plenty of room (apparently), and MEM_ERR01 is the lack of space.

If that fails, you can also try installing them one by one by editing the autoinstall.lst file.
The first one would be:

; SYNC3 Consumer Application Upgrade - Release 3.4.22200 - Only for Nav/EU assemblies.

[SYNCGen3.0_3.4.22200]
Item1 = 4U5T-14G422-BAH
Open1 = SyncMyRide\4U5T-14G422-BAH.tar.gz
Options = Delay,Include,Transaction

The second…

; SYNC3 Consumer Application Upgrade - Release 3.4.22200 - Only for Nav/EU assemblies.

[SYNCGen3.0_3.4.22200]
Item1 = 4U5T-14G422-BBH
Open1 = SyncMyRide\4U5T-14G422-BBH.tar.gz
Options = Delay,Include,Transaction

And so on until the first section completes.

Now, you mentioned you removed Gracenotes, but it’s installed… So I’m not sure what’s happening there…

Hi just seen this as it’s been a busy week.

Master Reset (and PWR+ right seek) hasn’t done anything.

Will try installing individually.

Update
Manually installing each ZIP file has succeeded and the 5th one has produced an XML file.

I have noticed that I have the American voice when adding bluetooth devices and no voice guidance at all. How can I restore this, specifically the British voice?

Should I now upload the XML file to the Ford website?

Glad it worked. If you have that file, please attach it to see what packages are currently installed on the unit.

This has to do with what you did before: :point_down:

What you need to do is reinstalling the corresponding voice file for your system.
You will need to install it, you can use the same syntax as reference as the other installs you previously did, but with this file → 5U5T-14G391-AT.
Once that’s installed, perform another Master Reset and re-run the interrogator log to see what’s installed on the system.

I do not see any harm in doing that, except your unit has not the proper voice file installed. Maybe you can save that log for later and try debugging the voice package thing, then you could upload a new log later.

Sync_NYBK012G.xml (11.1 KB)

Ok, install the voice package as previously described and then you should recreate and upload the log to ford.

1 Like

Sync_NYBK012G.xml (11.1 KB)

She’s back. Voice guidance working properly now.

Thank you for your help.

Does it look like all the available updates are installed?
What do I need to run to check?

Nothing, since you are on Ford’s path, just leave it as it is for now.
If Ford wants and decides to, it will push another update in the future for you.

What do I need to upload to Ford? The interrogator output?

Yes, the XML file for your current situation.

If your APIM is OTA capable, it reports the configuration to Ford on demand. You just need to have auto updates enabled connected to a WIFI network.

After connecting to wifi, the Ford website is now showing as up to date.

Thank you very much or your help.

On a slightly unrelated note. The Ford website has my vehicle down as a 2015 model.
I’ll assume this is a problem with the website and not something I’ve caused.
Screenshot 2023-10-02 135004