APIM 2020 Update

Hi Everyone,

I upgraded from sync 2 to sync 3. I’m currently at version 3.4.20136 with maps version of NA119. I would like to upgrade to the newest sync version and 2020 maps. I was wondering if this is possible yet with the 2020 apim’s? I havent found anything concrete saying you can without bricking.

Thanks!

Run the APIM Interrogator Utility and post the results. Why do you think you have a MY20+ APIM?

The APIM I installed has a build date of 10/22/2020. It also has a the letter L on the sticker which I believe is also another indicator of the latest generation APIM

1 Like

You can update it all (including maps) via AutoInstall which won’t reformat the unit. You can also force AutoInstall just for peace of mind but MY20 protection should be enabled by default if you upload an interrogator log.

Hello.

Check this thread → Tutorial: 2020 North America 2.20 Map Installation (Stand-Alone without Reformat) with Updated NAV_Voice 06/21/2021

Thanks everyone for your help. I will try this later today.

Sure, keep us informed on how it goes.

A maybe unnecessary clarification: the tutorial is for updating maps only, but you can use an AUTOINSTALL USB created by Syn3updater to update the other parts of Sync3 without reformat, just select “keep existing maps”, so installation method is AUTOINSTALL. Since you have a MY20/+ APIM, you can’t ever REFORMAT it.

I’m actually using the auto install utility right now. Just waiting for it to download the files. I did the integration utility which it confirmed I did have a 20 APIM. I’m currently at maps version of 2019 so I’m updating that to 20, as well as to the latest sync version. I should have the final update results in a few hours. Thanks again!

1 Like

Sorry didnt get a chance to update the other night. I tried updating tonight but I got the following error MEM_ERR03. Looks like this means no space to extract. Reading up this seems to be a common issue on non nav apims not as much on nav units. I was trying to update from 3.4.20136 to the latest as well as upgrade maps from 2019 to 2020. As I have a 2020 apim I’m apprehensive to try anything without some guidance first. Would there be any benefit to upgrade the sync version first then do the map update separate? Would that avoid the memory error?
20220216_174220

My 2020 Fusion is still getting updates and maps OTA so you may not need to do any of this.

Mine is a 2015 F350 with a sync 2 to 3 upgrade. Unfortunately OTA updates will not work for me

Please, run the interrogator log against the unit and post the file here.
Make sure to redact the VIN from the file’s title and content if you care about those things.

It will tell us which packages are installed, and most importantly how much free space the unit has.

Although you can install the Sync app, voice, maps, etc., all at one time I would advise you do not. Install the maps separately and follow the instructions in the tutorial. Use the autoinstall in the tutorial exactly as it is written. You can update your Sync app, voice, GN, using the Syn3 Updater.

Thanks everyone for the replies. Anytime I updated I always used the Auto install utility. I just tried running the Integrator utility and Im getting install failed and a PKG_ERR04 error. The last time I ran the Integrator utility before the update it worked fine. So something with the last update is causing this. I created the Integrator utility using 2 different computers and 2 different usb sticks to rule that out. However the same issue.

I updated my neighbors 2017 sync 3 f150 from 2.2 to 3.4 with Nav update no problem. It just appears the 20+apims are extra sensitive.

Thanks for the help!
20220218_181127
20220218_182725
20220218_182731

Did you use the -AD file? or -AC file?

Please, post the log for the Interrogator creation.

Im sorry I didnt get any email update that someone responded. I will get you that info this afternoon. Thanks!

Attached is the log. I re-ran the integrator utility on a fresh usb drive and tried it again but the same error. Im not sure what you mean did I use -AD or -AC file?
log

Oh dear lord… you are using -AA…

You have Syn3updater configured with the wrong values, most likely you didn’t update (nor allowed Syn3updater to do it itself) your current version after a previous upgrade, so it seems that for Syn3updater you are running 3.0.xxxx or below…

The Interrogator is version dependent, that’s why you are getting the error.
Syn3updater is smart enough to use the correct package for the correct version, as long as the user configure it right, of course.

So, easy fix:

  • configure syn3updater right with your current version and build
  • recreate the interrogator log USB again, the correct package should be used now
  • try again

@endlesssummer
That is for Sync 3 2.0.xxxxx. Use -AC.