Forcibly Closed Connection when downloading NA Maps 2.20

Have already downloaded 3.4.20351 and updated two vehicles. With release of 2.20 NA maps, making a new USB with 3.4.20351 version (waiting for a bit before using 21020). Multiple times Updater has stopped the download, and states:

“Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. An existing connection was forcibly closed by the remote host” (exactly as shown on screen)


FWIW, I got the same thing on a Windows 10 box with multiple tries. I thought maybe the antivirus so I disabled (as much as windows allows you to disable) but that didn’t seem to fix it. It was a work PC so it was loaded with all the windows safeguards and I wasn’t going to muck with it any more so I tried later in the day with an old virgin Win 7 box and it worked fine (with the same USB stick). It may be some protection software on your pc or possibly the time of day, I’ve read that the server was busy after the new maps release. Since I changed multiple variables I don’t know what the root cause was so maybe try later today or another PC.

1 Like

It’s actually the Microsoft Azure servers being hit with us downloading it.

1 Like

Yeah, this is an old box that I’m going to change out. Guess it’ll happen sooner rather than later. I have successfully downloaded about two weeks ago, and have tried different times of day. I’ll try the new box. Thanks!

OK, I’ll go with the time of day answer then :slight_smile:

1 Like

I have tried several times, over different days and times of day. I’ll keep trying! Thanks.

1 Like

They will soon migrate their stuff to Google servers. I don’t think it’ll happen until late of this year though.

1 Like

Says who?

1 Like

The Google deal, they have a 6 year contract

I worked finally. Thanks guys.

Doubt they will migrate sync 3 files though

Still getting the forcibly closed over multiple days. Luckily it makes it through a file or two before it happens, so at least it builds on itself… pain though. I have been at it for 3 days and restarting the download every couple hours when I look in on it…ugh…

same issue for me. been trying since Thursday.

I assume your 2013 F150 is a Sync 3 retrofit?

If you have doubts about the tool, you could manually download them…
And if you place then in the same directory Syn3Updater download them, it will just check then without re downloading

1 Like

Thanks, it went through last night. I was able to load the new build. Appreciate the suggestion though.

I’m still trying through cyanlabs and have yet to be able to download 3.4.21020

Glad to know it is not just me. See all these guys downloading on YouTube with no problem and I’m going on 2-3 days trying to download parts of it at a time before getting hit with that “Unable to read data from the transport connection…” error.

Thanks! Good luck to the rest of you guys!

But the thing is, what are you trying to do to work around the issue?.

If you are having issues with the tool and want to rule the app out, you can always try downloading the files manually to see how it goes:

  • If it also fails, then it’s Ford’s servers.
  • If it does not fail, then there’s something particular with your PC that’s interfering with Syn3updater.

But, if it’s your PC and you are able to download them, if you put the files in the Syn3updater folder, the tool won’t download them again, it will just check them for integrity and then create the USB.

So it’s worth trying that.

I’ve tried on a few different PCs and made sure to eliminate/deactivate all the antivirus/antimalware programs I could find. Based on that, I’m thinking the issue is with Ford servers (surprisingly?).

My best approach now is to continue using the same PC–as you said, so that it places all the files into the same folder and checks the integrity. Unfortunately, it’s just going to take a lot longer as it’s not readily easy to see when the error occurs as the error message is usually hidden behind my browser and there are no alert sounds.