Ford F150 2016 Sync 3 Build 19205

Hi! Looking for some help here. I have Sync3 in my 2016 F150. I’ve only done an update once or twice since I had my truck.

About 3-4 months ago, my Sync 3 started acting up and would have a lot of lag whenever I tried to utilize the touchscreen. This has been real annoying - as you can imagine. I tried to update the system when the problem first started - and I kept getting errors following the Ford process. This weekend, I figure I’d try to tackle this issue again. And since I started working on this yesterday afternoon my truck has literally been running in my drive way for hours.

Frustrated, I came across this tool. Again, I’ve tried updating using the tool to download the update and copy to a USB but it to seems to error out.

One thing I note in the process is, I don’t seem to have the ability to say I have navigation. Instead, the only option available to me is “Non NAV APIM”. I assuming I am missing something.

Any help would be greatly appreciated.

Thanks.

Click the gear icon in the bottom left of the app and make sure that your current configuration is 3.0.19205 and you have selected the navigation option. That should allow you to select maps when downloading the new version of SYNC.

1 Like

although you may have navigation, or not, there may be other reasons the update fails. First of all make sure your APIM is equipped for navigation. Run the APIM Interrogator Utility here and see if the APIM is indeed equipped with 32GB of storage.

Tutorial: APIM Interrogator Utility - Ford / Guides & Info - CyanLabs Official Community

This will also confirm your Sync version in the xml file. Just open it with IE.

Thanks! I figured it out. I had mistyped the current version of sync in the gun. Once I changed that…it installed with no hiccups!

1 Like