Ford Sync 3 update issue - no maps

Updated my Kuga 2017 Vignale sync 3 3.0 20204 to 3.4 23188, auto install, formatted drive, installed in car etc, colour changed from grey to blue after install so all good.
but after restart the screen said “Navigation Malfunction”, when i click on the navigation is says “Navigation is not functioning properly, please visit your dealer for service”. Satnav was working perfectly before the update. Tried master reset but still the same

I tried to reinstall an earlier version to see if that would help but now when i put the USB drive in the car i get the message “USB error, possible bad cable or device charge port”, both USB’s were working perfectly before update, my wireless USB Carplay dongle still works in the USB and on screen so USB’s are fine.
No ideas what to do next

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.20204

New SYNC Version: 3.4.23188

Do you have a error message, if so what is it?
as above

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Unable to create new log as USB gives error message

You cant autoinstall from 3.0, so I’m not sure what you mean.

We need to see the log for the USB you used for upgrading, it’s located on the USB itself and in the logs tab in Syn3Updater.

What do you mean by the USB giving an error when creating a log?

I have just uploaded the log here
log-2024-01-24-15-55-06.txt (5.1 KB)

Sorry misunderstood last question, i have taken pictures if that helps

Well, you told Syn3Updater the unit did not have nav, so no maps were installed… Configure Syn3Updater accordingly, WITH MAPS, and re do the process…

Also, do not post multiple messages, use the edit button instead to add information.

About the error message, I’m not sure about that.
Usually the hub may need to be replaced so that car play can work, but that does not seem to be your case… And the message displayed it’s different as well…

Thanks, tried to reinstall but got the following message
Installation Failed
Error Code :PKG_ERRO4
Download files again and retry to install
log.txt (14.7 KB)
I uploaded the new log

Since you upgraded it 3.0.20204 is not your previous version anymore.

Yes, it is now 3.4 23188 but tried to reinstall as above and now getting the error code Installation Failed
Error Code :PKG_ERRO4

so if i put previous version 3.4 23188 and try that ?

Yes, previous and current version 23188 and include latest maps after ensuring that you select nav on the updater.
Then do a master reset straight after the upload to the car.
Please advise result…


Well tried it, no joy, won’t even let me install as i am now getting the USB error as soon as i put the usb drive in “USB error, possible bad cable or device charge port”. my wireless carplay usb dongle still works though. tried it with two different USB’s (including a brand new sandisk 128gb) and still can’t get it to connect from USB to car, USB was working perfectly before install
Log.txt (16.1 KB)

It’s important to always have your “current version” correct, it changes how Syn3 Updater installs things.

No reason that shouldn’t work, try power cycling your APIM / Car

Did you unplug the wireless dongle while updating?

Yes dongle was unplugged, i have done the power cycling and currently installing on another USB on the PC

Still no joy, keep getting the USB error, then got a message saying ERRO5 this time. USB is still working fine with phone and carplay dongle after i put them in but not with either USB sticks
Log.txt (13.4 KB)
New log

Don’t you have a different brand USB to try with?
Also, clarify the full error you are getting, not only the suffix .

Sorry the message went off before i could see the entire error code.
Tried two usb’s (including a new sandisk one) i am currently in the car and when plugged in it now says “Updating System Software” at the top but it has been like that for around twenty minutes now, i take i need to wait as it will be installing Europe Maps as well, roughly how long does the update take?

Edit: OK so it installed then i got the message that car will update once engine restarts, screen went black and restarted but it went back updating system software as i did not remove USB as it didn’t tell me to, i take i should have removed USB and restarted the car as it looks like it’smjust updating it again

Edit2: IT WORKED , now have all maps, took over an hour to update but once the master rest was done the maps appeared, thank you guys for all your help with this, you are lifesavers

1 Like

Glad it worked. Just it’s odd that it took over an hour…
Generally speaking, it takes about 50-60 minutes… But it depends on the USB quality/performance…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.