Hotspot issue 20’ APIM install into a 17’ explorer

Hey all,

Hoping someone here may have the solution to the problem I am having.

I purchased and installed a Navi APIM from an early build 20’ Explorer into my 2017 XLT with Navi. Once installed I loaded my Asbuilt data from my old module into the new one. At the same time I finished my retrofit of a hot spot enabled TCU. I am using Ford PIFA’s for both connected car and hotspot they are connected using OEM cables. My issue is not being able to enable hot spot in settings. The FordPass tile is showing up, I can tap the hot spot menu under the FP tile but when I do I get a pop up that says “Vehicle Hotspot feature is not enabled in this vehicle” I’ve reviewed the APIM asbuilt data consulted with another DIY’er from the F-150 forums, we have made changes in hex for blocks 7D0-02-02 and 7D0-02-03 and we can’t seem to get the hotspot functionally to work.

Any suggestions? I’m sure I forgot to include some info y’ all may need, be happy to provide just let me know.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Retrofit

Old SYNC Version: 3.4.19200

New SYNC Version: 3.4.22110

Do you have a error message, if so what is it?
Vehicle hotspot feature is not enabled for this vehicle.

Update Method: Official Ford

You will not be able to enable and us the hotspot feature of the TCU, since your vehicle was not equipped as such from the factory. The VIN and TCU serial are a matched set registered with AT&T, who operates the service. If you are not in their database, it will not work.

You must have the donor VIN for the hotspot to get it to work FYI. I went through this when I activated my Hotspot on my retrofit for my 15 Explorer. I did it via their online registration. You might be able to get their customer service to correct it for you.

Also, the PFIA antenna is not for the hotspot. It actually uses the Roof Antena for this so you will need to replace that. That is how they get the 20’ range outside the vehicle. It’s a hybrid Sharkfin with a whip on it for the Explorer. In the Explorer it will talk directly to the TCU. I am gonna take a guess you might have an AB setting wrong in your TCU.

Here is a diagram that will show you and is specific to the Explorer…

I forgot to mention the donor VIN, thanks.
The hotspot antenna is internal to the TCU on the circuit board. The 2 each 4G ports are for receive (only) diversity. Only the purple transmits.

Hotspot service is active through ATT I used donor vin that the TCU came from

What setting are you using on 02-03 ?


Well that would be the one. Seems you got the APIM squared away. Are you sure the HS is turned on in the TCU?

Ran across this.

Manufacturer Communication Number: SSM 49541


Some 2018-2020 Ford and Lincoln vehicles equipped with TCU and WiFi Hotspot, May display Vehicle Hotspot feature not enabled on this vehicle when attempting to enter the Hotspot menu. When using the FordPass/Lincoln Way application, the customer may receive a message saying Wi-Fi has been disabled from this vehicle. Check the vehicle specifications or vehicle build information for the mfal code on the PTS website (Detailed Vehicle Specifications). If mfal = WAFAC or WAFAB do not replace the TCU, engineering is currently investigating this condition. Inform customers Ford is developing a software fix that is expected in early March. In the interim, let the customer know they can continue to drive the vehicle and schedule a follow-up appointment with the customer for early March. Monitor OASIS for updates.

What is the part number of the TCU you have put in the 17 Explorer? Did you downgrade the firmware? Since this is a 17 Explorer, what is the firmware version and software versions for the APIM? The older APIM’s will not support the hotspot in the menus.

TCU is the one that’s recommended for a retrofit: JB5T-14G229, I didn’t change firmware as the info in thread I was reviewing indicated the J series TCU Firmware didn’t need modified.

The APIM is out of an early build 2020 Explorer. PN: LB5T-14G371-MCG I don’t know what version the current firmware is. I know the software version 3.4.22251

Make sure HS4 is turned off in that APIM

I believe it is, but I will double check to be sure.

I only say that because an L series APIM would have an L series TCU on HS4. In your case you don’t have HS4 so I figure turn it off to eliminate that possibility. It may not matter but just in case.

On a side note make sure to have the VIN for that Explorer your APIM came out of. This will help later for official updates since you cannot reformat that APIM.

I have the donor vin info saved for the TCU and the APIM

HS4 is disabled. Just confirmed.

Make sure to take a screen shot of the Calibration values for @F150Chief so he can take a look at them and make sure you have the right ones.

Here is the TCU Info:

Here is the APIM Info:
Software Version: 3.4.22251

So this is the situation as I understand it:
You placed a 2020 APIM from a 2020 Explorer into the 2017 Explorer.
You placed a 2017 TCU (JL3T) from an F-series into the 2017 Explorer. JL3T-14G087-CF. This TCU will work fine, however it needs the firmware upgraded to -CT from -CF. This TCU does not use HS4, not even capable.
You are using the PIFA antennas for the purple and tan LTE connectors. This is fine, but you will likely only the need one on the purple connector.
The hot spot menu is under the FP tile but you get a pop up that says “Vehicle Hotspot feature is not enabled in this vehicle” You have the donor info for the TCU. Right now the TCU thinks it is in a 2017 Explorer that is not eligible for the hotspot function. Which is correct. Or the hotspot is turned off in the TCU…
The APIM firmware is fine.
The APIM settings are correct…?

APIM, Sync 3.2+:
Instruct the APIM there is a TCU.
7D0-02-02 xxxx *xxx xxxx, from 8 to 9.
Instruct the APIM that the TCU is hotspot capable, if so equipped.
7D0-02-03 *xxx, from 0 to 4.

Vehicle must be equipped with and programmed for factory remote start.
Enable Remote Start:
726-22-02: xxx1 xxxx xxxx
Remote Start: 0=disabled, 1=enabled

Tracking and Blocking Module (TBM)
726-49-01 x*xxx xxxx xxxx
TBM Avail Cfg: 0=absent, 1=present

Adds Remote Start menu to instrument cluster.
720-02-02: xxxx Axxx

The TCU settings are correct…?
Is the Wi-Fi Hotspot Feature (WHF) enabled in the TCU?

1 Like

TCU has hotspot enabled.

I followed the directions that are on the F-150 forum for programming the TCU and have been collaborating with another user on the forum TXFRDOwner to get the APIM programming correct for the MY17 since it came out of a MY20 and make sure the TCU setting I entered were correct. He also did this retrofit in his 150 and Fusion.

When I get back to my PC later this evening I will take a screen shot of the current APIM Asbuilt and post for you to review.

APIM and TCU asbuilts…

There is not much to change in the APIM between the two, mostly just feature sets for the two vehicles. Both are CGEA 1.3, so all those settings will remain the same.