Installation in progress some featutes will continue to be disabled untill this process is complete

Hello, I have a problem in my 2021 Ford Mustang with Sync 3.4 version 23188. Every time I start the engine, the message “Installation in progress some featutes will continue to be disabled untill this process is complete” appears, I tried to return to 3.3 version 19052, nothing. it didn’t work. I think the error occurred due to automatic updating via Wi-Fi. I am asking you for help because this message is very irritating.

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: MY20

Install Type: OEM

Old SYNC Version: 3.4.23088

New SYNC Version: 3.4.23188

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Branch: Beta
Operating System: Microsoft Windows 10 Home (2009)

Version: 3.3.19052
Region: EU
Navigation: True
Install Mode: Auto-Wykrywanie (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: WŁĄCZONE

Mode: Drive
Model: Kingston DataTraveler 3.0 USB Device
Size: 57,8GB
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater Beta - Autoinstall Mode - Sync 3.4.23188 EU

Item1 = RWDataCleaner TOOL - PU5T-14G386-BB_1690840002000.TAR.GZ
Open1= SyncMyRide\PU5T-14G386-BB_1690840002000.TAR.GZ
Item2 = VOICE - 5U5T-14G391-AT_1660763323000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G391-AT_1660763323000.TAR.GZ
Item3 = GRACENOTES - 4U5T-14G423-AC_1615425645000.TAR.GZ
Open3 = SyncMyRide\4U5T-14G423-AC_1615425645000.TAR.GZ
Item4 = ENH_DAB - 1U5T-14G658-AH_1644006443000.TAR.GZ
Open4 = SyncMyRide\1U5T-14G658-AH_1644006443000.TAR.GZ
Item5 = APPS - NU5T-14G381-AD_1689364279000.TAR.GZ
Open5 = SyncMyRide\NU5T-14G381-AD_1689364279000.TAR.GZ
Options = AutoInstall

PU5T-14G386-BB_1690840002000.TAR.GZ (3,2KB)
5U5T-14G391-AT_1660763323000.TAR.GZ (1,5GB)
4U5T-14G423-AC_1615425645000.TAR.GZ (689MB)
1U5T-14G658-AH_1644006443000.TAR.GZ (57,5MB)
NU5T-14G381-AD_1689364279000.TAR.GZ (869,8MB)

[10.05.2024 14:13:23] Selected Region: EU - Release: Sync 3.4.23188 - Map Version: ZACHOWAJ ISTNIEJĄCE MAPY 
[10.05.2024 14:13:23] Install Mode: Auto-Wykrywanie (autoinstall) Forced: False 
[10.05.2024 14:13:23] MY20 Protection: WŁĄCZONE 
[10.05.2024 14:13:23] Formatting USB drive
[10.05.2024 14:13:23] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[10.05.2024 14:13:34] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ 
[10.05.2024 14:13:34] Validated: PU5T-14G386-BB_1690840002000.TAR.GZ (Skipping Download) 
[10.05.2024 14:13:34] Checking Existing File: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[10.05.2024 14:13:50] Validated: 5U5T-14G391-AT_1660763323000.TAR.GZ (Skipping Download) 
[10.05.2024 14:13:50] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[10.05.2024 14:13:56] Validated: 4U5T-14G423-AC_1615425645000.TAR.GZ (Skipping Download) 
[10.05.2024 14:13:56] Checking Existing File: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[10.05.2024 14:13:57] Validated: 1U5T-14G658-AH_1644006443000.TAR.GZ (Skipping Download) 
[10.05.2024 14:13:57] Checking Existing File: NU5T-14G381-AD_1689364279000.TAR.GZ 
[10.05.2024 14:14:02] Validated: NU5T-14G381-AD_1689364279000.TAR.GZ (Skipping Download) 
[10.05.2024 14:14:02] Preparing USB drive
[10.05.2024 14:14:02] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ 
[10.05.2024 14:14:02] Copying: PU5T-14G386-BB_1690840002000.TAR.GZ 
[10.05.2024 14:14:02] Validating: PU5T-14G386-BB_1690840002000.TAR.GZ 
[10.05.2024 14:14:02] Copied: PU5T-14G386-BB_1690840002000.TAR.GZ 
[10.05.2024 14:14:02] Checking Existing File: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[10.05.2024 14:14:02] Copying: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[10.05.2024 14:16:07] Validating: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[10.05.2024 14:16:13] Copied: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[10.05.2024 14:16:13] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[10.05.2024 14:16:13] Copying: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[10.05.2024 14:17:09] Validating: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[10.05.2024 14:17:12] Copied: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[10.05.2024 14:17:12] Checking Existing File: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[10.05.2024 14:17:12] Copying: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[10.05.2024 14:17:18] Validating: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[10.05.2024 14:17:19] Copied: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[10.05.2024 14:17:19] Checking Existing File: NU5T-14G381-AD_1689364279000.TAR.GZ 
[10.05.2024 14:17:19] Copying: NU5T-14G381-AD_1689364279000.TAR.GZ 
[10.05.2024 14:18:29] Validating: NU5T-14G381-AD_1689364279000.TAR.GZ 
[10.05.2024 14:18:33] Copied: NU5T-14G381-AD_1689364279000.TAR.GZ 
[10.05.2024 14:18:33] Generating Autoinstall.lst


It’s not clear to me which version the unit is currently running. Can you clarify?.

The log you provided is not for going back to 3.3…

Have you tried with a master reset?

Usually appears when there is a unfinished autoinstall that was aborted or cancelled in someway, usually autoinstalling any other package over the top will resolve this.

I wonder whether disabling wifi auto updates and wifi altogether will help if not already done so. The system may be trying to finish the update from the Ford update site which could take several trips unless the car is left running near the wifi source as you know.

The OP talks of auto wifi updates and it is possible the original 3.4.23188 was not completely updated by wifi in the first place and now the system is confused since Cyanlabs was introduced.

I’m currently back to version 3.4.23188.

Yes, it didn’t help.

I tried to install the lower version 3.3.19052. After this procedure, this message still occurred. Both in version 3.3 and 3.4. However, I did this without updating the maps. Maybe that’s the reason? Need to do this with maps?

You have done the 3.4.23188 update through the Ford site and you have the latest maps supplied by Ford, not Cyanlabs…right?
On another forum you show a pic of your screen showing a message that the update is incomplete and to keep the engine running until it finishes the upload.
You are using wifi so you probably will have to do that unless you start the update again by USB as wifi can take a long time to complete and if you are driving around out of range of your wifi you will get this message til it finishes.
On the other hand if you are trying to fix the issue by uploading the software version through Cyanlabs you will need to turn auto wifi updates and wifi off.

Yes, on the Ford website it says that I have the current version of Sync 3.4.23188. I can download map updates which is very small, weighs only 92B and is called autoinstall. After inserting the pendrive, an error appears. When I try to update via Wi-Fi, it keeps looking for it and nothing changes.

Create and run an interrogator log, share the produced XML with us.

VIN: 1FA6P8CF4M5126767
Wersja 4U5T-14G381-AN
Model APIM: 5U5T-14G371-CPB
Typ APIM: Navigation
Rozmiar APIM: 32GB
Wolne miejsce APIM: 5.4G
02.01.2000 14:08:51 +00:00
Partition Type = Free / Total
/fs/sd/MAP/ = 12M / 1.6G
/fs/sd/MAP/ = 12M / 1.5G
/fs/sd/MAP/ = 12M / 1.5G
/fs/sd/MAP/ = 9.9M / 1.4G
/fs/sd/MAP/ = 2.9M / 951M
/fs/sd/MAP/ = 8.6M / 1.3G
/fs/sd/MAP/ = 14M / 1.8G
/fs/sd/MAP/ = 17M / 1.7G
/fs/sd/MAP/ = 7.6M / 1.5G
/fs/sd/MAP/ = 4.5M / 3.3G
/fs/sd/MAP/ = 6.2M / 1.3G
/fs/Nuance/ = 940K / 244M
/fs/rwdata/ = 668M / 1.2G
/fs/mp/ = 505M / 1.4G
/fs/mp/resources = 260K / 91M
/fs/images/ = 5.4G / 25G

Installed Packages
APIM AsBuilt
DE00: AA2A010A34021800008A
DE01: 504C0602C002009000004005
DE02: 0000010100
DE03: 01000900060001
DE04: 1856195A29D6
DE05: 80
DE06: 100033000000000B650000565675004C
If I did something wrong, please correct me.

Thank you for the information, that clears some things up.

This was wrong :point_down:

You are not on 3.4, you are on 3.3.19052.

Your APIM is not EU capable since it’s 32GB:

So using EU nav is out of the question at the moment, that requires a region change, which seems to be half way done since your country code seems correct.

You have a mixture of NA map versions:

All those should end with C_F, you have 3 with C_E. You can try manually installing them one at a time, since the APIM does not have a lot of free space.

Bottom line: if the car is imported from NA and used in EU, disable all automatic updates since Ford will push you NA stuff.

What I think you should look into if you care about NAV, is researching FMODS’ universal reformat tool (that can be ran against MY20 hardware) and complete your APIM’s conversion from NA to EU by installing a cutdown EU map version.

1 Like

I have just deleted all maps using Jailbreak and Navigation Data Remover, now I have 24Gb of free space on Apim, I am currently trying to install a reduced version of EU maps and switch to version 3.4.23188 downloaded from Cyanlabs. I will let you know what comes of it :see_no_evil:

1 Like

If the unit is JBken, the hard part is done… and the fastest and cleanest way for you to complete the process is by using FMODS’ universal reformat tool… that way you could leave the unit at its desired state in about 20 minutes…

I do not recall if latest EU maps are ESN locked or not, but while reformatting the unit that does not matter…

But while creating the USBs DO NOT USE CYANLABS’ reformat package for the reformat phase, be super sure about that.

Gentlemen, I think we succeeded. Unit updated to version 3.4.23188. The maps work and the sounds work too. No annoying message “Installation in progress some featutes will continue to be disabled untill this process is complete”, so this problem was related to the installed maps. Update via Wi-Fi disabled :grin: Now there is a problem when trying to check how much space Interrogator Removal USB has, the error PKG_ERR04 appears. If there was some space on the disk, maybe I would install another part of the EU maps :thinking:?

VIN: 1FA6P8CF4M5126767
Wersja NU5T-14G381-AD
Model APIM: 5U5T-14G371-CPB
Typ APIM: Navigation
Rozmiar APIM: 32GB
Wolne miejsce APIM: 7.0G
11.05.2024 17:58:12 +00:00
Partition Type = Free / Total
/fs/sd/MAP/ = 804K / 1.2G
/fs/sd/MAP/ = 17M / 2.3G
/fs/sd/MAP/ = 4.5M / 3.3G
/fs/sd/MAP/ = 26M / 3.2G
/fs/Nuance/ = 36M / 3.7G
/fs/Nuance/ = 8.4M / 1.9G
/fs/Nuance/grace = 21M / 1003M
/fs/rwdata/ = 660M / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 90M / 90M
/fs/mp/ = 17K / 496K
/fs/mp/ = 84M / 1.4G
/fs/mp/resources = 332K / 72M
/fs/images/ = 7.0G / 25G

Installed Packages
APIM AsBuilt
DE00: AA2A010A34021800008A
DE01: 504C0602C002009000004005
DE02: 0000010100
DE03: 01000900060001
DE04: 1856195A29D6
DE05: 80
DE06: 100033000000000B650000565675004C

Does everything look good in this journal now?

I didn’t double check each package against what it should be, but if you used Syn3updater as a guide for which packages to install, then your are ok. Plus, you said the unit is working correctly now right?, so i would call that a win.

Out of curiosity, did you reformat it?.

I used the autoinstallation method (there was no green bar that changes depending on the progress of work) from version 3.3 to 3.4 with a truncated map of Europe. The whole process was carried out in 3 stages, the first one was changing sync 3.3 to 3.4, next was the installation of EU maps and finally the installation of Gracenotes. After each API, it restarted and finally a message appeared that the installation was successful and that the USB can be removed :grin:.

Well done…you can now do further software updates through Cyanlabs.

Just remember to leave auto wifi disabled. :wink:

1 Like

Thank you all for your help, I have one more question. If I wanted to try to install more EU maps, would I just download them? During installation, will it not delete the maps that are already installed?