Interrogator Log shows 'APIM Model: Blank'


I was getting ready to update my Sync 3.0 to 3.4. Just to have the info on hand I ran the Interrogator tool and noticed the APIM Model entry says “Blank” Also, everything at the bottom of the log under APIM AsBuilt (Ford/UCDS) also show BLANK. That’s the actual word Blank, not that it’s empty.

My vehicle is a 2018 Mustang with Navigation, currently on Sync 3.0.19205. Factory hardware and software. I ran the interrogator tool on my parents’ vehicles, '16 Escape and '16 Focus, both Non-Navigation, and all those entries show proper numbers.

I’m using Syn3 Updater I currently do not have FORScan or an OBDLink adapter, though I’ll probably get them before trying the Sync update just in case. I just want to make sure all these things showing up as Blank won’t cause an issue with the Sync update, and if there’s anything I can do to fix it.

Thanks in advance.

Which file did you run, -AC or -AB?

Hmm, neither one. Looks like -AD? It’s what Syn3 Updater generated. Here’s the log:

Operating System: Microsoft Windows 10 Pro (2009)

Version: 3.0.19205
Region: NA
Navigation: True
Mode: autoinstall

Model: SanDisk U3 Cruzer Micro USB Device 1.9GB
FileSystem: FAT
Partition Type: MBR

; CyanLabs Syn3Updater 2.x - Autoinstall Mode - Interrogator Log Utility 

Item1 = TOOL - GB5T-14G386-AD_1606255780000.TAR.GZ
Open1 = SyncMyRide\GB5T-14G386-AD_1606255780000.TAR.GZ
Options = AutoInstall

GB5T-14G386-AD_1606255780000.TAR.GZ (46.1KB)

1/24/2021 5:01:51 PM GB5T-14G386-AD_1606255780000.TAR.GZ matches known good checksum
1/24/2021 5:01:51 PM GB5T-14G386-AD_1606255780000.TAR.GZ exists and successfully validated, skipping download
1/24/2021 5:01:51 PM Preparing USB drive
1/24/2021 5:01:51 PM Formatting USB drive
1/24/2021 5:01:51 PM Re-creating partition table as MBR and formatting as ExFat on selected USB drive
1/24/2021 5:01:59 PM Generating Autoinstall.lst
1/24/2021 5:01:59 PM GB5T-14G386-AD_1606255780000.TAR.GZ is missing or invalid, copying
1/24/2021 5:01:59 PM GB5T-14G386-AD_1606255780000.TAR.GZ matches known good checksum
1/24/2021 5:01:59 PM copied GB5T-14G386-AD_1606255780000.TAR.GZ and successfully validated
1/24/2021 5:01:59 PM All files downloaded and copied to USB successfully!

Use -AC and see if you get the same results. Tutorial here:

Tutorial: APIM Interrogator Utility - Ford / Guides & Info - CyanLabs Official Community

1 Like

That did it. Great!

Honestly, I had read your guide and totally missed the last part about trying a different file. My bad.

So seems like everything should be in order then.

Thanks very much for your help.

1 Like

I was able to replicate the issue you saw on my test APIM with 3.0 also…using the -AD version.

@CyanLabs, please note this issue.


So when does AD work?

I’ve changed it to AC in the app now.

I ran AD on my Fusion with 3.4.20282 and it generates the log properly. If it also worked on their Escape and Focus, then maybe its a Mustang issue? That’s the only other variable that’s changed.

AD does not work on Sync 3.0, need to use AB. AD works on 3.4, but I have not been able to test it on 3.2 or 3.3. AC works on 3.2 thru 3.4 that I have tested. The xml output file formatting is different for each version. Not in an file structure way, but how the information is interpreted.

What’s weird is that according to the original post AD seemed to work on 3.0 on the Escape and Focus?

When you run AD on 3.0, that is what you get. There might be a hardware factor to this also. I have a '16 APIM that I ran it on with 3.0.19205 and it says BLANK. AB and AC worked fine. There could have been an issue with a DTC?

AD parsing the file via /tmp/did8060-ica

/tmp/did8060-ica $logfile

Other than that and the fact that AC doesn’t have the did8060-ica file there is literally 0 differences, however obviously whatever that parsing does breaks certain configurations

These are the strings from that DID8060 file

file name: did8060-ica
mime type: 

000000f4: /usr/lib/
0000067a: __register_frame_info
00000690: xmlXPathFreeObject
000006a3: xmlXPathRegisterNs
000006b6: xmlNodeSetContent
000006c8: fwrite
000006cf: _Jv_RegisterClasses
000006e3: _fini
000006e9: xmlInitParser
000006f7: __cxa_finalize
00000706: strncmp
0000070e: strlen
00000715: snprintf
0000071e: xmlXPathNewContext
00000731: fclose
00000738: strncpy
00000740: xmlDocDump
0000074b: _Stderr
00000753: memset
0000075a: xmlXPathFreeContext
0000076e: xmlXPathEvalExpression
00000785: fprintf
0000078d: xmlFreeDoc
00000798: xmlParseFile
000007a5: xmlNodeGetContent
000007b7: xmlCleanupParser
000007cd: strchr
000007d9: xmlFree
000007e1: _init
000007e7: __deregister_frame_info
00000813: _init_array
0000081f: errno
00000825: _preinit_array
00000834: readdir
0000083c: strstr
00000843: strdup
0000084a: _init_libc
00000855: fopen
00000860: opendir
00000868: _fini_array
00000874: atexit
0000087b: access
00000882: __assert
0000088b: closedir
00000894: _btext
0000089b: __exidx_start
000008a9: __exidx_end
000008b5: __data_start
000008c2: _edata
000008c9: __bss_start
000008d5: __bss_start__
000008e3: __bss_end__
000008ef: __end__
000008f7: _stack
000014e0: replace_xpath_element
000014f8: update_xpath_nodes
0000150c: //d2p1:DID[@didValue="%d"]/d2p1:Response
00001538: xpathExpr
00001544: src/did8060_ica.c
00001558: value
00001560: Error: unable to create new XPath context
00001594: urn:ford/Vehicle/Module/Information/v3.0
000015c0: Error: unable to evaluate xpath expression "%s"
000015f4: nodes->nodeTab[i]
00001608: Error: unable to parse file "%s"
0000162c: DID8060 check fails, examining /fs/rwdata/.Version for part numbers to write to XML file.
00001694: INFO: Rewrote XML file due to missing DID8060 part numbers.
000016d0: ERROR: Could not rewrite XML file.
000016f4: DID8060 check passes, XML file will not be rewritten.
0000172c: /fs/rwdata/.Version
00001744: 14G381
0000174c: _Version.inf
0000190d: GCC: (GNU) 4.4.2
0000191f: GCC: (GNU) 4.4.2
00001931: GCC: (GNU) 4.4.2
00001947: aeabi
0000196e: .shstrtab
00001978: .interp
00001980: .note
00001986: .hash
0000198c: .dynsym
00001994: .dynstr
0000199c: .rel.dyn
000019a5: .rel.plt
000019ae: .init
000019b4: .text
000019ba: .fini
000019c0: .rodata
000019c8: .eh_frame
000019d2: .init_array
000019de: .fini_array
000019ef: .dynamic
000019fd: .data
00001a08: .comment
00001a11: .ARM.attributes

The most important appear to be

0000162c: DID8060 check fails, examining /fs/rwdata/.Version for part numbers to write to XML file.
00001694: INFO: Rewrote XML file due to missing DID8060 part numbers.
000016d0: ERROR: Could not rewrite XML file.
000016f4: DID8060 check passes, XML file will not be rewritten.

Yep. Admittedly I wasn’t paying attention to what file I had at that time, but assuming Syn3Updater was always grabbing AD then yes, AD definitely worked on the Focus and Escape. Both are Sync 3.0.18093.

APIM Models as reported by the AD file:
Focus: GJ5T-14G371-BFC
Escape: GB5T-14G371-BFC

Mustang APIM Model, reported by the AC file:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

This has been added to the upcoming release :slight_smile: