Need help, update 3.4.20021 to newer build

I upgraded my original 3.0 from my 2016 Focus RS to 3.4.20021 using the downgrade, then upgrade tool. Since then I’ve had a few bugs. Bluetooth disconnects repeatedly, Audio off when I start car until I change stations, USB port not compatible…

I’ve been trying to update to any of the newest builds to see if that helps. I constantly get the memerr_003 error. After reading the forum over and over I was thinking I ran out of storage space. I’ve even tried to install just the software, no apps or gracenotes. Still nothing.

I tried to use the APIM interrogator file and get a file_004 error on that one.

Any ideas on what I have to do to update to newest build?

Which error?

If you have an iPhone and want to use CP, you will need to replace the usb hub.

This is a NAV or NON-NAV APIM (Sync unit)?

Non Nav unit.
I use Android Auto.

I think it was INSTL_ERR04 that got, I would have to try and rerun the tool.

Is there a way to upgrade from build 20021?


There is an error in your autoinstall.lst file or it is missing.

Have you read thru this thread:

I did exactly as the tutorial says and I got an error both times. What I mean by both times is I tried the 2 different files it listed since I was on 3.0 and went to 3.4.

Here is my autoinstall.lst

Item1 = GB5T-14G386-AB_134244.tar.GZ
Open1 = SyncMyRide\GB5T-14G386-AB_134244.tar.GZ
Options = Delay,Include,Transaction

And this is the file in my SyncMyRide folder:


The other setup was the same, just using the file:

Item1 = GB5T-14G386-AC_1587495565000.TAR.GZ
Open1 = SyncMyRide\GB5T-14G386-AC_1587495565000.TAR.GZ
Options = Delay,Include,Transaction


And I made the adjustment to autoinstall.lst with the correct file name.

Any other ideas?

On Sync 3.4 use the -AC file.

Item1 = GB5T-14G386-AC_1587495565000.TAR.GZ
Open1 = SyncMyRide\GB5T-14G386-AC_1587495565000.TAR.GZ
Options = Delay,Include,Transaction


There is an error in your Autoinstall.lst file.

My apologies, my reply was incorrect, I changed the post to reflect what I changed. I’ve tried both files and both give me the same error.

Sometimes SYNC caches the error, reboot the unit, either disconnect power to the battery, or press and hold POWER + FWD for ~10 seconds or leave the car alone for ~30 minutes

Other than that assuming you are creating this file manually you likely have the wrong line endings, or you have special line ending characters or you aren’t saving it as plaint text and instead are opening it with wordpad, textedit, word etc. it must be plain text, use only notepad on windows or textedit on mac (in raw format)

1 Like

I will try this later today. I am using notepad only when I do the edit to autoinstall.lst.

Make sure notepad is not saving the file as .txt…

Looks like using the Gracenotes removal tool worked. I’ve update to the newest build of 20282.

Thanks for everyone’s help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.