NEW FASTER SYN3 UPDATER - Alpha Version

Hey all,

I have recently finished the development of the multi download thread version of Syn3 Updater. from my testing this saturated a full 1gbit link and downloaded and copied everything in about 15-20 minutes.

If you would like to test it out jump over to the Alpha build

And then once you have swapped over to the Alpha build you will see this new option

By default it will use 8 connections, i would leave it at this value if i was you but you can change it if you want.

Then simply download and enjoy the faster download (assuming ofcourse you have a fast connection)

additional features added in the recent Alphas coming soon include

And many bug fixes, small ui tweaks etc.

4 Likes

Switched to the Alpha version, now Syn3 Updater will not launch…Is there a way to switch back without uninstall/reinstall…

Delete your configuration from

C:\programdata\CyanLabs\Syn3Updater

and maybe also

C:\Users\Scott\AppData\Local\CyanLabs\Syn3Updater

1 Like

Back to working with the “Stable” branch. It was the first path that you mentioned. Thanks!!!

I have just tested multiple times updating from the latest stable, 2.7.3 (2.7.4 as of a few seconds ago) to the latest Alpha without issue, what is your current stable version?

Whats your computer name it may have logged an error which i can lookup from your computer name.

Correct, before launching just now, I was at 2.7.3, now I am at 2.7.4

Computer name is E6410

I will try to attach the two event log errors (rename to take the .txt extension off)

CyanLabs_Alpha.evtx.txt (68 KB)

Hmm it’s the launcher that is crashing

Application: Launcher.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NotImplementedException

Thanks for the log, if you have time could you test this Launcher and provide a event viewer log again, this should give debug information.
Launcher Debug.zip (895.8 KB)

No errors with this one. I extracted the zip into a temp folder, ran Launcher.exe, it started fine and downloaded the current build (2.7.4). There was nothing that I could find in the event log. I then selected “Alpha” from the settings menu, it downloaded and restarted the app fine this time. Now running 2.7.4.2 (Alpha) with no errors. I have not tried to make a USB drive yet, but can try that if you need me to.

Interestingly enough, if I try to run my original install, the Launcher fails again.

Cyan_Debug.evtx.txt (68 KB)

Hmm, weird, it may have just not downloaded properly or something odd like that. thanks for the feedback.

To everyone else, if you experience similiar please let me know as i plan to release this in the next few days.

see edited initial reply above.

What version is your current Launcher.exe? it seems to be 1.1?

Simply replacing the Launcher.exe in my original install folder with the Launcher.exe that was in your “debug” ZIP has fixed my original install. Attached are both versions:

Launcher.exe.zip.txt (643.3 KB)

Edit: But after doing this, I am now “only” at Alpha 2.7.4.0

Thats not a alpha build, i’d change from alpha to stable restart the app and then back to alpha restart the app and see if that fixes it

That fixed it (switching to stable and back to alpha). So now I am running from my original install and running the current Alpha (2.7.4.2).

Maybe my Launcher.exe was wacked out or not getting updated (v1.1)???

Yeah the launcher should have been 2.7.4 to match the latest stable syn3updater, even if the code doesn’t change i keep it in sync.

Something went weird but all good now :slight_smile:

Thanks for your help, feel free to clean up this thread if you need/want to. Sorry if this was a distraction.

No worries, thanks for toubleshooting :slight_smile:

Had the same issue , removing files under “C:\programdata\CyanLabs\Syn3Updater” solved that as well. I was able to go back to Stable, but after trying to use the Alpha, app does not longer start.