No gps after 3.4 upgrade

I upgraded to 3.4 on 2019 ford ranger and lost gps signal. Downgraded back to 3.3. Still no gps. Any ideas?

Did you run a master reset ?

Yep many times but only gps with red circle thru it

Hola que tal? Pudiste solucionar tu problema con el GPS? Tengo el mismo problema, ayuda!

I have noticed this seems to be a common problem, as there are 3 or 4 mentions on the threads on this forum and several more on others.
I’ve been searching for an answer but have not found a definitive solution, other than mentions of reloading the complete as built for the APIM and performing a Master Reset after that. I have not seen this issue personally so have not had to deal with it. If I find something I will post it on the thread.

Muchísimas gracias por tomarte el tiempo y la molestia de escribirme. Saludos!

Most people just don’t wait long enough or master reset, or have been messing with their APIM, i haven’t had a single confirmed report from it not working for anyone who hasn’t previously messed with AsBuilt.

1 Like

Any updates on No GPS? I have '17 f150 upgrade from 3.3 to 3.4.20351, flashed APIM AS-BUILT data, Master Reset, Cycled Power, Waited 10 minutes, Drove around… no luck,

I was having the English (UK) settings and changed to 5553 for English (US) thinking that would help. It helped the language and Radio Freq. but not the GPS situation.

Kinda stuck now.

Also downgraded back to 3.3 and it had no GPS with it also. sent it back to 3.4.20351 and the rest of the APIM reflash. no luck. Please help.

Did you reflash the APIM using the original asbuilt settings for the vehicle from the factory? You can find them here:

Index - FordServiceInfo.Com (motorcraftservice.com)

How many satellites do you see in the diagnostics menu?

Yeah I forgot to mention this. 0 satellites. I fiddled with APIM programming a bit and tested the With Navigation Repeater format. Swapped between Motorola and Intel. I believe it’s supposed to be Motorola.

I didnt flash with original as built because I have an APIM from another vehicle that has been in for about a year or so without issues. I have the original saved but it does not have the nav in the original flash.

Should I flash stock and update for the navigation?

You have an antenna issue. Software? Maybe?

Your asbuilt should reflect:
7D0-01-02 x*xx xxxx xxxx
2=USB2 Disabled, Navigation Enabled (Telenav Common HMI), Rear EFP Disabled

7D0-01-02 xxxx x*xx xxxx
2=MMI Disabled, CCT Automatic, SSA Not Available, NRF Motorola format (for NOT start/stop)
0=MMI Disabled, CCT Automatic, SSA Available, NRF Motorola format (for s/s)

A 2017 F-150 should have had Sync 3 originally equipped. Did you upgrade to NAV, or why? Do you know what vehicle the unit was sourced from?

The GPS issue is rather common with upgraded Sync systems. We just need to get to the root of the issue.

1st option is correct. I had 6 in for the second selection for whatever reason. I will try 0. I started with 3.3 I upgraded the APIM to get NAV.
It was from a ‘19 Focus.

Is your climate system a single zone with manual controls? If so, 4 or 6 would be correct, depending on S/S. If automatic climate controls, with the AUTO button, then 0 or 2, depending on S/S.

Edit: After looking thru your asbuilt it looks like you have a Lariat or below model. This asbuilt looks fine if that is true. Does the original asbuilt match this one from 7D0-01-01 thru the 7D0-07-04? Except for the NAV enable.

You should see about 8 satellites at any one time, at least. What antenna is connected for GPS in the vehicle?

Ok yeah its an XLT. Ill have to go back through it to see if it matches up besides the NAV. It should though as theres not much Ive changed otherwise. Is there anything outside the APIM I should check? There’s nothing else thats changed other than the new APIM and it has worked for a year prior to the 3.4 update. I used it a day before updating. It even had my house listed as the gps location for a little while then it went to no gps and after the first master reset it shows I am in Dearborn, MI.

Look at the WiFi settings and see if it is on, also see if you can check for updates via WiFi connected to your home network. This is just checking the unit.

Have you driven the vehicle since the update?

It connects to wifi. Searching for updates just finished but it says it is up to date 01-01-2014 3:33:59 PM then I just noticed my clock says that time and wont stay when I change it. And of course it wont sync to gps. Says GPS data unavailable. Please try again later.

I have driven it last night for about an hour. Gps never updated.

Did you acquire satellites?

One thing we can check is the Clock Master setting. The setting in your asbuilt reflects the correct choice for the clock master setting for an F-150, that the BCM is the master. The BCM, IPC, and APIM all talk about time, and GPS, but if disrupted might need a kick to wake up again.

Try this:
In FORScan, connect to the APIM asbuilt and change 7D0-01-01 xx** xxxx xxxx from 2A to 20 and write the changes. Let the APIM reboot.
Now change the value back to 2A. Write the changes, and let the unit reboot. See if you can now set the clock and GPS is working.

What this does is to change the Clock Master from the BCM to the APIM, and then back to the BCM. This will cause the communications to reset between the BCM and APIM.

If this does not work, you can reset the BCM thru FORScan. When you do this, the vehicle will throw all kinds of codes and flash lights, etc. This is normal. You will need to clear all the DTC codes once you do this in FORScan.

Of course, before you do any of this, make backups of the asbuilts.

Thanks. I will try this in the morning. I have not acquired any satellites yet.

Did you install another GPS antenna or are you using the rooftop one?
Also, do you have a puck or shark fin on the roof?