No Navigation Direction on instrument cluster

Hi Cynalabs,

Here are my configuration .
Original Region : ROW (INDIA)
Nav/Non Nav : Non Nav
Old Version : SYNC 3.0
New Version : 3.4.19274
Method used : WIndows App V 2.0.0.0
Car : Ecosport 2018 Titanium

The update was super easy , Thanks to Cynalabs.

I have found 2 issues .

  1. The splash screen starts with the ST screen (Which i configured using forscan) And when turns off it goes to the ford splash screen .
  2. The navigation direction from android auto is not displaying in the instrument cluster . I have enabled the below features in the IPC module using forscan .

Navigation Screen Repeater : Enabled.
Navigation / Compass : Enabled.
Turn by Turn Navigation : Enabled.
Trip Navigation : Enabled.
Trip Navigation pop up : Enabled.

Each time i connect to the android auto the Navigation changes to "Android Auto " as in the image but not the actual direction .

I even thought this behavior is due to non navigation APIM . And i tried with enabling the navigation using forscan . But its still not working. Please let me know, Am i missing any settings. Please help :slight_smile: .

Thanks
Naveen

@F150chief i think we found a solution for this in another topic? maybe it was @Louage?

Change the format of the navigation repeater from Motorola to Intel mode, or vice versa is the first thing to try

1 Like

Think that was what i was thinking of, couldn’t remember, read so much stuff by browsing these forums haha

@Naveen_kumar

Motorola to Intel: If you have a ‘0’, set to ‘1’. If ‘2’ set to ‘3’, and so on.
Intel to Motorola: If you have a ‘1’, set to ‘0’. If ‘3’ set to ‘2’, and so on.

7D0-01-02 xxxx x*xx xxxx
Mode Man Icon [Climate] (MMI), Climate Control Type (CCT), Surround Sound Available in Occupancy Mode (SSA), Nav Repeater Format (NRF)

0=MMI Disabled, CCT Automatic, SSA Available, NRF Motorola format
1=MMI Disabled, CCT Automatic, SSA Available, NRF Intel format
2=MMI Disabled, CCT Automatic, SSA Not Available, NRF Motorola format
3=MMI Disabled, CCT Automatic, SSA Not Available, NRF Intel format
4=MMI Disabled, CCT Manual, SSA Available, NRF Motorola format
5=MMI Disabled, CCT Manual, SSA Available, NRF Intel format
6=MMI Disabled, CCT Manual, SSA Not Available, NRF Motorola format
7=MMI Disabled, CCT Manual, SSA Not Available, NRF Intel format

You can try using the “easy” method (NOT the asbuilt selection) in FORScan selecting the ST theme to make the shutdown screen ST also. This used to work before 3.4 version. Since you are on the ST theme, you might have to set the theme to something like Ford default then back to ST to get it to work. You are looking for Visual Design Variants toward the end of the list.

A lot of the “exit screens” are hard coded and cannot be changed. The ST theme used to be this way before Sync 3.4.

@Louage , I tried both the navigation repeater, but it’s not working :(.

@F150chief, I tried below 4 options but no luck :frowning:
4=MMI Disabled, CCT Manual, SSA Available, NRF Motorola format
5=MMI Disabled, CCT Manual, SSA Available, NRF Intel format
6=MMI Disabled, CCT Manual, SSA Not Available, NRF Motorola format
7=MMI Disabled, CCT Manual, SSA Not Available, NRF Intel format

I imagine it’ll be a config option in your ipc in that case as there isn’t anything else to configure in the apim other than this option

I agree…but…

What was the original value?
Did you perform a master reset between changes?

the original values was 001A460080BA and I did not perform a master reset.

You need to do a master reset of the Sync system after making these changes.

Your original data is:
7D0-01-02 xxxx x*xx xxxx
001A 4600 80BA

Input this data:
7D0-01-02 xxxx x*xx xxxx
001A 4700 80BB

Then do a master reset of the Sync system.

If this does not do it, then it will be another setting in the IPC…

I tried both the Intel and Motorola format. And did a master reset. It did not work. But what is found out is eachtime I update the IPC asbuilt the navigation shows up and the moment I turn off the ignition and turn on then the navigation goes back to “Andorid Auto” view.

Looks like the version sync 3.4.19274 has this bug and updating to sync 3.4.20282 fixed this issue . Now I’m getting the navigation in my cluster.

Thanks for helping me :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.