Screen size and APIM firmware or software

Are the APIM’s firmware locked into a specific screen size? I have a '20 F250 and I did the 4" to 8" conversion with a new APIM, but wondering if the screen size can be modified in the original APIM to make it work? From the various Ford forums it seems everyone is saying no, that you the APIM and screen size are tied together.

The APIM I purchased for this conversion I made sure was a more modern variant, but, it seems a tad sluggish. I did try and plug the new 8" screen into the original APIM and the splash screen filled the screen as expected, but once fully booted it defaulted to the 4" layout. The APIM software is the same on both of them, but wasn’t sure if there is a theme or another FORScan value that can be modified. Or potentially flashing new firmware onto the APIM?

I upgraded the SYNC version of the new-to-me APIM using the SYNC updater here, and I’m not sure if some of the issues I have might be related or just inherent to the SYNC platform in general (Android Auto crashes from time to time, and the device can be sluggish moving between settings at times, but nothing major beyond that).

The APIM are not necessarily ‘locked’ to a specific screen size, but some will not support all screen sizes. Example in point is the APIM’s used for the 4" screens. These may be only Sync 2.5 hardware and software, or may not be Sync hardware at all. Although you may get the original 4" APIM to work on an 8" screen, I doubt that the full software functionality would be realized due to the lack of memory and processing power available in the 4" models. This does not even account for NAV vs NON-NAV.

The firmware in some cases is not compatible between Sync 2.5 and 3.0, and in some cases neither is the software.

What version (part number) of APIM did you use as a replacement? The newer APIM’s (2019 and forward) are what you should have purchased for the replacement. This generation of hardware will be compatible with your vehicle and should perform properly. Earlier versions of APIM are not optimized for your '20 F250 and will not support certain vehicle features or perform properly.

The model number that came out of my truck is GR26A LC3T-14G370-BLL, I don’t have the picture anymore, or I can’t find it, but the “Software Version” info on the screen did display something about Sync3 version with 3.4 listed, and it was the exact same as the most current version Ford was offering for the Sync3 with 8" screen at the time.

The HW that came out of the truck is identical to the one I purchased, from a physical point of view. The new (to me) HW is GR26A KS7T-14G370-BBH, and has a 2019 build date. The place I purchased from did want my VIN from a programming point of view.

I haven’t lost any functionality, I still have Ford Pass and the remote start works as expected. The hotspot in the car works as expected. The WiFi to connect to my home works. I don’t have Nav, and didn’t want Nav, I just wanted the larger screen. The issues I do have, are hard to say if its due to some HW issue or just how it functions. Android Auto is the biggest pain, but, honestly Android Auto hasn’t been reliable on any vehicle I use it with. Other than that it just can get sluggish at times.

What I find odd is that the Sync3 software versions matched. I really want to see if perhaps changing the theme or some other FORScan setting can change the screen size. Watching videos of the companies that sell the conversion kits, the APIM that comes out is the much older variant. But what came out of my truck is identical to what I put it. Obviously, to your point, the guts could be different. I’m not sure if opening it up will necessarily help. But I am open to experimenting with FORScan settings.

The LC3T-14G370-BLL unit is MY20 F-Series.
The KS7T-14G370-BBH unit is MY19 Fusion/Focus.

These are compatible replacements as long as the KS7T-14G370-BBH unit is programmed properly. These are both NON-NAV, 8GB storage onboard. The NAV versions are 32GB. Since these units don’t have a lot of spare storage available, yes, they can get a bit sluggish at times. It seems like other than that, your functionality seems to be ok.

The following involves swapping out the Sync units in the truck, if you are up to it…

To be sure the KS7T-14G370-BBH is properly programmed, you can run the APIM Interrogator Tool, either from the Syn3 Updater or tutorial. In this case, run it from the tutorial to obtain the XML file. Run the file on each unit. Use the GB5T-14G386-AC file for both units. Once you have the XML files, you can post them here or PM.

Tutorial: APIM Interrogator Utility - Ford / Guides & Info - CyanLabs Official Community

Although the version numbers may match, the software may be different builds, 4" vs 8". This and the storage will be determined by the Interrogator Tool. Based on this information, it might be possible to modify the LC3T-14G370-BLL unit. (No guarantees here.)

Sync_WZ9NBRXT_1FT7W2BN3LEE77580.xml (10.1 KB)

Thank you! Here is the XML from the original APIM. Once I get the replacement put back in I will re-run the tool.

Thanks for all the help!

Here is the XML from the APIM that works with the 8" screen.
Sync_VXAV153D_1FT7W2BN3LEE77580.xml (10.2 KB)

The 2 APIM’s are configured differently, the versions do not match.
The original APIM part number is 5U5T-14G371-LMD.
WZ9NBRXT (Original APIM for 4" screen)
Software: 5U5T-14G381-FD 408Mb Sync3 v3.4.20136 15.05.2020 (Latest software is -FR.)
Firmware: 1U5T-14G374-EK/1U5T-14G375-CA

The replacement APIM part number is KU5T-14G371-BDE.
VXAV153D (Replacement APIM for 8" screen)
Software: 5U5T-14G381-ER 847Mb Sync3 v3.4.21020 20.01.2021 (Up to date.)
Firmware:1U5T-14G374-DA/1U5T-14G375-CA

There are discrepancies in the asbuilt for the replacement unit, VXAV153D, in 7D0-01-01. These lines should match between the units. Use the original stock values.
Both APIM’s are 16GB storage. with 7-8gb free.
Both have DTC’s set indicating outstanding issues. (Probably just from swapping them out or configurations.)

What is it you were looking to do with the original unit? In this case, it is possible to load the 8" version of the software onto the original unit, WZ9NBRXT, and use it with the 8" screen as long as the screen drivers work properly. It has older 4" software on it now. This is up to you if you like.

Thank you for all this!

My original intent in all of this was to see if I could even re-use the original APIM without having to purchase one. At this point, since I already have a replacement APIM, it’s just to experiment with what I could do with the original. I would like to see if I could get the original APIM loaded with the software for the 8" screen since it seems the firmware appears to be ok.

What is interesting about the original is playing around with the branding, splash screen, and VSD is I could see the splash screen re-sizing to it’s appropriate size based on the various settings (
7D0-01-02 as an example). So setting the splash screen to the 10" I would see the screen, but way too large for the 8", setting it to the others would re-size as needed).

So focusing on settings in 7D0-01-02, 7D0-02-01, 7D0-03-01 I could get at least the boot/splash screen to be the appropriate size, which made me think there was some combination that would work for the rest of the interface. But, if the software isn’t there, it won’t matter. But, odd that Ford would include all the boot screens for all the other models and makes but not the rest of the interface.

But, anyway, if I can get the software installed does that basically pull the APIM out of the Ford upgrade path? Meaning I will need to rely on the software from Cyanlabs and such? It won’t make a difference either way, since I don’t want to go back to the 4" screen. So with that said, would I just pull
SyncUpdate tool to push a package down and see how it works? OR is there something else I would need to do to install new software?

Thanks again!

Loading the original APIM with the -ER software should just make it work, no adjustments necessary for screen size. And yes, the Ford packaged updates will not be used on it again.

Software: 5U5T-14G381-ER 847Mb Sync3 v3.4.21020 20.01.2021 (Up to date.)

Great! Thank you for all the help!

A quick update, I was able to the original APIM and everything seemed to work ok. Except for FordPass. The vehicles hotspot works fine, I can connect a device, but the “Connectivity Settings” under the FordPass Menu just says “Please wait” and never does anything. Also, I cannot activate the remote features (remote start, etc). I get an immediate error message saying that I need to try again later. I’ve done multiple master resets, I’ve removed the truck from the Ford Owners portal, removed the app from my phone (android), disconnected the battery. And still nothing. No DTC on the TCU (checking the status on the TCU shows the correct waiting for authorization).

I’m thinking that putting the other APIM back in place and then issuing a Master Reset SHOULD clear the association of the older ESN (or the Sync SN, or whatever ID they use to associate the Truck to the backend servers) so that when I do try and re-authorize it should get refreshed device info. But, I don’t actually know how Ford is associating the truck to the backend servers.

I’m actually having some weird APIM issues, though. Beyond that one menu item (Fordpass Connect - Connection Settings), there was some odd menu items coming up. I rolled back to my backup settings from Feb when I put the replacement APIM in, and it helped somewhat. I then went back to the Ford Asbuilt and it put all the menu options back that weren’t there before. I thought I read someplace that your vehicle will sync the settings back to Ford after a while and overwrite those. But, it honestly feels as if Forscan wasn’t taking the updates. Luckily when I purchased this truck I had the VIN from another truck I didn’t purchase but was almost the same except it came with the 8" screen versus the 4". Comparing the asbuilt between the two has helped.

Anyway, before I start taking my console apart again, any ideas? The Fordpass menu item I think is an artifact of the issue. Contacting Ford, they said they could see the TCU in a “waiting for auth” state and that at Master Reset would clear this up. They then said take it to a dealer.

This is common and is not an issue with your setup, but the Ford servers.

Make sure that automatic updates and sending info to Ford is turned on.

This is a good idea. The ESN is associated with the VIN and the TCU on the Ford system.

This is not how that happens. This is thru IDS at the dealer, not via wifi. (For Sync 3.)

Put the other APIM back in place and then a Master Reset. Take the vehicle out of Fordpass. Reset app on the phone.
Put the new APIM in place, Master Reset and clear all DTC’s. Add vehicle to Fordpass. This should now associate the APIM ESN with the TCU and VIN.
Activate thru phone.

If this does not work, try this…with the new APIM in place. The pics below are old, disregard the FORScan version. You don’t need 2.4.x…

SAVE the TCU ASBUILT!

TCU:
While monitoring the TCU PIDs in real time, there’s a PID which tells you the current authorization status of the module. If you’re having issues with the authentication, change this in ForScan, wait a few minutes, and then set it back to whatever was there before.

754-01-01: xx00 xxxx xxxx (Make sure you know what this value was to return.)

When monitoring the Authorization Status PID, it’ll go through several stages. If cell signal shows 255 it means the TCU is still rebooting. Setting up the TCU in ForScan for the authentication process requires your patience.


Everything will then work as long as the other data listed below is also configured correctly:
APIM (Sync 3):
Instruct the APIM there’s a TCU:
7D0-02-02: xxxx 9xxx xxxx
Instruct the APIM that the TCU is hotspot capable:
7D0-02-03: 4xxx

You should be able to authorize as above.

1 Like

Man, I am beating my head against the wall here. I’ve done all the steps multiple times and it’s still just not connecting. Interestingly enough, yesterday I did a “Check for updates” on the unit and it said there was an update waiting, and it pushed down a new file. I was hoping that would somehow help, but it hasn’t. It’s so weird…the modem is working because I can use it as a hotspot. The TCU says “Wait for Authorize” (I’ve done the steps listed above, so I can see it move through the states, but it never gets beyond that "wait for’ state). Since I received an OTA update from Ford, they can at least see the system.

What is interesting is that when I do the Bezel Test (holding down the media forward button on the steering wheel and the FCIM) there is an APIM Configuration Status option, and going through all of that there is a line about the TCU, which says “Not Connected” or something similar. So I verified 7D0-02-02: xxxx 9xxx xxxx and 7D0-02-03: 4xxx and they are configured correctly. In fact I changed them to other states just to see (changed them, completely shut down, and then re-started). And sure enough removing those configs the hotspot and the Ford Connect options went away. And then I re-configured, and they came back. So at some level the APIM see’s the TCU. But, I’m not sure if the Bezel Config is necessarily reporting accurate info. It did seem odd, though. So I am wondering what others see in that setting.

At this point, I am planning on just doing a complete master reset and then giving it a week or so to settle in. Its certainly seems as if there is a mis-match someplace on the backend of the Ford environment. I might try taking it into the dealer, but based on what I’ve read about this issue Ford doesn’t seem to know how to fix it. At the end of the day its just some basic remote features, so I’m not missing out on a lot, but it was nice to unlock the truck with my phone when I didn’t have my keys handy.

1 Like

This might be the best bet at this point. The above procedure usually works well, although the authorization can take a day or two.

Well…I’ve gotten a little bit closer, but still no dice. I realized when I restored the APIM from asbuilt it wasn’t writing all the blocks in, and leaving a couple of settings as they were. At some point I enabled customer connectivity (or whatever it’s called), and disabling that and then doing a master reset gave me some new prompts to accept on the screen. I no longer have the “connectivity settings” menu, obviously, but now when I do a master reset I get an immediate notification on my Ford Pass app that that I will need to re-issue an authorization. But, I still do not get the authorization request to go through. It no longer times out after 2 minutes with an error, it will sit in a requesting authorization state for several days until I do a master reset. At least I know the modem is working and communicating back to Ford.

I can’t for the life of me get the authorization request to complete, though. It just will not prompt me on the screen. I’m debating rolling back a sync minor version and seeing if that might work, or a newer version if there is one. It’s so frustrating for something that I will rarely use!

I was having the issue with the FordPass app not showing all the buttons and controls, but the authorization always worked. I could control the commands via Siri shortcuts for FordPass. I tried all the stuff above and still would not get the app to work.

So to fix the app issue I did the following in this order:

I removed the vehicle from the app.
Deleted the app from the phone.
I deleted the vehicle from my account at Ford Owner site.
Performed a master reset on the APIM.
With FORScan:
Under the tools menu, select reset modules and reset the APIM and TCU.

Now this is critical, wait 24 hours! Do nothing.

Now it’s the next day…

Go thru the procedure above again, make sure the TCU goes thru all the steps of Factory mode, etc. and comes back with Waiting for Authorization.

Load app on phone, add vehicle, answer prompts.

For me, everything worked just like it’s supposed to after a short time processing the authorization request. I had the log out of the app on the phone and log back in for it to refresh. But now it works flawlessly. All buttons and functions are there, even scheduled starts, etc., which I never had before. This is on a 2015 F-150 Platinum that never came with a modem.

One thing I noticed, that if you don’t get the emails saying that you have deleted or added a vehicle or activation almost immediately, then the Ford servers are busy and it probably will not work. When everything answered right away, it all worked. I think the processing time in the servers goes long and the requests are dropped, so authentications keep failing.

Try this when you have time and see if it works for you. Good luck.

FINALLY got this working…after screwing around with a million different settings and losing the ability to change stations, the TCU working, and then not working, and then working again, etc etc etc, finally figured it out. I went online to see if I could find a 250 that was as close as possible and then pulled the asbuilt from Motorcraft and used the asbuilt explorer to do a line-by-line comparison. The APIM sections has some differences, but I decided against fiddling with that too much, the ACM had one slight difference, but again, didn’t seem that important, so left it as is. Ended up on the TCU and found one address near the bottom that was different and Googled it, and in the Ford Transit forums I found a discussion about people doing what I did, but in their vans (going from 4" to 8") and one user changing that address and it making FordPass work. So I tried it, and sure enough, that was enough to make things work.

My factory setting:

754-18-01 : 0204

The comparison truck:

754-18-01 : 0304

Made the change, shut the ignition and let it sit for a minute, restarted, and after system finished booting the Connectivity Menu didn’t just spin, but gave me the menu choices, and then the connection approval prompt appeared (I had forgotten that I even had a request pending).

Anyway, thanks again for helping me out through all of this, definitely was a frustrating experience. I’m sure others will have the same experience, so not quite sure where to post the fix.

1 Like

That setting is new for 2020+ vehicles apparently. The previous settings only go thru 754-13-xx.

Glad that worked.

All that for a feature that I will use rarely, but was driving me crazy. What’s really weird is that FordPass was working fine until I did a Master Reset. So I’m really curious what it does.

1 Like

Could you send me the link for the Ford Transit forum discussion about the TCU data change? I would like to capture this info and compare it to the 2021 model since that is nearly flushed out by Livinitup who I work with occasionally on this stuff.