Syn3Updater error Invalid Class

Two weeks ago I updated my Sync3 from 3.3.18351 to 3.4.22200 and all went OK. Today having seen that a newer relase was out I thought I would update to 3.4.22251, however when I open the Syn3Updater App I receive an RED warning box with Error Invalid Class.
I am running the latest version of Syn3Updater and have tried it both in Stable and Beta but I still get the same error.

I cant even select a USB drive. The USB drive I am using is the same one that worked 2 weeks ago and I have even reformatted it in Windows Explorer so my systme can see the drive and write to it but the App can’t.

I have also removed the App from the PC and reinstalled it but it still has the same error.

Any ideas?

This is an error with your computer, there was a fix to manually load the class but i can’t find the topic that included this currently.

EDIT: just found it

Please provide your OS Information also
Windows + R > “winver”

Hi Scott,

Windows 11


So this should be fine, please do as the link i shared said, this should fix the issue.

I ran the command which completed succesfully but I still get the same error when I try to run Syn3Updater app

provide C:\Users%USERNAME%\AppData\Local\CyanLabs\Syn3Updater\applog.txt

(make sure to close the application after getting the error so the log file is updated)

applog.txt (3.0 KB)

Something of note is that the applog file is complaning about the there being no info log file or something. What I have noticed is that I did after installing the 3.4.22200 update try to create the interigator log on a USB. I created the USB for this placed in car and let it run. I then brought the USB in to the PC to upload it but the Syn3Updater is stuck at step 3 Open interigator log as it was unable to open the XML file for some reason and its still stuck at this step today in the program. Could this have any bearing on the issue?

  "Log":"ERROR: Invalid class ",

Some USB device seems to be messing with my software.

Strange how it worked two weeks ago and yet today it will not open at all though. Even with no USB device in the PC it still errors.

I have tried 3 different USB stick as well.

Post this Invalid Namespace Error - #10 by CyanLabs

Computer Management > Servicves and Applications > WMI Control

That version of windows 11 has been superseded, try updating, it may fix your errors. Current version is 22H2.

Thanks I will check for update but I have fixed it anyway it was due to the windows WMI.

I will update what I did after the weekend as I am away at the moment.


Presumably WMI was disabled, well that would ofcourse break it as it uses WMI to get disk information

My problem was with MOF registration errors.

Using this page Microsoft WMI – Invalid Class Error [0x80041010] - Virtually Boring
I was able to check if WMI was functioning properly by doing the following: -

Launch the WMI MMC snapin holding the Windows Start key +R then enter WMIMGMT.MSC and hit OK

This showed that I had WMI :Invalid Class errors as listed on the website.

I ignored the bit about downloading the WMIDiag Tool as googling told me that this was now outdated so I just went to the fix to resolve MOF Registration errors:

I tried to run the command as show below but this errored for me in a PowerShell window

CD C:\Windows\System32\WBEM dir /b *.mof *.mfl | findstr /v /i uninstall > moflist.txt & for /F %s in (moflist.txt) do mofcomp %s

So I spit the command into two and ran CD C:\Windows\System32\WBEM and then ran dir /b *.mof *.mfl | findstr /v /i uninstall > moflist.txt & for /F %s in (moflist.txt) do mofcomp %s which seemed to work and updated all the MOF files.

I then re-ran WMIMGMT.MSC which now showed the WMI Control was OK

Hey presto Syn3Updater now loads without the class error and I can select a USB drive which I have now done to configure the 3.4.22251 udate.

hope this helps someone else if they get stuck like I did.

Glad this worked, but this is essentially the same thing i said to do in the quoted post, adding the mof file.

Just this added all the mof files in the directory (hence the for loop)

The combination command didn’t work because you were in powershell not CMD, type CMD in the powershell window and you will enter CMD

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.