Sync 3.4.23088 & F12 EU / 2.22 NA / 2.22 ANZ Maps - Feedback & Issues

Same for me. I used Ford site and/or syn3updater in the past without problems, uploading logs worked. Ford sync3 update page worked fine. After updating to 23088 build and F12 maps last week and uploading log to Ford, only this error message is shown and nothing else. It doesn’t even show my current version or car model. Found some people on other forums with the same problem. Maybe something wrong with the log (?).

If your Mondeo is a 2020 model well that is different and of course you could update with Ford or Cyanlabs but you said before it was a 2019 model and it is also listed on your profile as being 2019.
As mentioned before the 3.4 update for a 2019 Ford could only be done through Cyanlabs, but the 2020 + models are different.

No idea why you led us to believe your Mondeo was a 2019 model before which obviously confused the issue. :thinking:

It was build in 09-2019, of course it´s a little bit misleading.

Build 09-2019
Model 2020

1 Like

Ok…but regardless of that the point is that once you go down the Cyanlabs track for updates you cannot revert back to updates through the Ford site.

I doubt that you can also advise your Ford account/profile of your latest update via Cyanlabs either as you have now dropped out of the Ford site update system.

This is wrong, please be sure the information you are providing is correct to not cause further confusion to the community, people already get way more confused than they need to.

My 2019 car is officially on 3.2+

I’ve deleted this post once already, post a new topic this has nothing to do with this topic

Your exact question is clearly documented

Worked perfectly for me and fixed several issue from my previous version,
Speak and Spell - fixed
Traffic Info - fixed
Radio EPG - fixed

After the master reset all my radio logo are present

Thanks again cyanlabs for another excellent update job.

I am sorry…probably my wording was misleading.

I know you can get the 3.4 sync version from Ford for 2019 and earlier models but from research I was under the impression that you could only download it through Cyanlabs for these earlier models and not through the Ford updating site and that is what I was trying to point out.

That is the case with my 2017 Gen3 Escape as I could only update to 3.4 with Cyanlabs but if it doesn’t apply to 2019 model Fords then I apologize.

As you are aware 2020 + models already came with the 3.4 version and can be updated through the Ford site updating system or Cyanlabs.

1 Like

No worries, the wording is not misleading though, it’s just wrong Information, a 2019 car can officially get 3.4

1 Like

Upgraded two days ago in my 2016 Ford Fusion… No issues and took about 35 minutes. Performed master reset as always instructed and everything is working as expected with new maps! A couple Sirius logos are missing but this happened last update and after a week or so they all updated.

Updating today finally. Will post back with feedback or any issues. Going to master reset before and after the update from 22251 → 23088. :slight_smile:

1 Like

new voice map revision K available:


[Mod Edit: Direct links to ford’s server are not allowed, link removed]

1 Like

Syn3Updater updated with the updated F12 Nav Voices for EU!

@CyanLabs I think there is some problem. When I try, Sync return MEM_ERR01 even though the fsimage dir has 10G of free space

… going to need way more information…

Create a separate sync3 issue, complete all the information the template requires. On top of that, create and run an interrogator log against the unit and post it when creating the thread. Also, if you have a picture of the error, it would be good to send it as well.


ok, thanks.

Ran the update yesterday on the way home from work. Master reset before and after. Took about 35-40 total minutes. 25min for the second phase after downgrade.

No issues. Seems to run a bit snappier too.

Same with me. 3.4.23088 + F12 EU installed. When trying to install new nav voices (autoinstall, original Ford update package offered by Ford update site), immediately after inserting usb into the sync, MEM_ERR01 pops up. I also have 10G free space on images partition.

correct, the problem is the same. I think that with the default autoinstall.lst configuration, this update cannot be done if 23088 + F12 has already been installed