Sync 3.4.23088 & F12 EU / 2.22 NA / 2.22 ANZ Maps - Feedback & Issues


Sync 3.4.23088 has been found online and added to Syn3 Updater!
New 2022 Maps for EU, NA and ANZ have been found online and added to Syn3 Updater!

For each new release a specific thread will be created, please use this thread to post any feedback or issues you have noticed for the corresponding release.

Important Notes

This release only updates the APP package and optionally the MAPS


  • Do not reply to this thread with general issues that are not specific to 3.4.23088
  • If you notice a bug or change specific to this feature report it below

Failure to follow the above rules will result in your post either being moved (if moderators or myself are feeling generous) or deleted without prompt

To clarify, MEM_ERR’s, Missing Logos, LST_ERRS etc should not be posted here, make a new thread using this Support Link

Install Methods

Syn3 Updater

You can update using Syn3 Updater

Quick Links

China : syn3updater://Region=CN;Release=3.4.23088
Europe: syn3updater://Region=EU;Release=3.4.23088
North America: syn3updater://Region=NA;Release=3.4.23088
Australia: syn3updater://Region=ANZ;Release=3.4.23088
ROW: syn3updater://Region=ROW;Release=3.4.23088

Manual Method

It’s also added to the manual method available at the below link

App Package URL

SYNC 3 Common Issues and FAQ’s

Official Issues


Community Spotted Issues

Clock resetting (only some cars?)

Issues that may still exist in 23088

It’s not yet clear if this issue from 3.4.22251 remains in this build or not

Community Spotted Changes


Technical Information from FMods

Package Name: NU5T-14G381-AC
Epoch: 1682460957000
Major Version: 3.4
Build: 23088
Build Date: 2023-03-29
Package Date: 2023-04-25
Release Date: 2023-05-08
List of Changed files: List of changes (based on DIFF) in Sync 3 Build 3.4.23088 compared to previous v -
Changes (based on diff):

  • Updated some ifs, some bins and some libs

Most important thing:
Does JB works? YES


Maybe related to the fact it’s so new, but creating a USB drive fails with a validation error…see image below…Ford issue, Syn3 issue? Or should I wait a bit to be sure all is ok on the various backends? Tried several thumb drives, all name brands that worked fine before, also lowered my # of connections…same issue…

1 Like

NA, EU and ANZ Maps added to Syn3 Updater!

I am getting the same error

1 Like

It’s fixed as of like 1 minute ago, for that specific file, his error was another issue

Still not working for me. I even went and deleted the downloaded files.

Confirm the filesize (not size on disk) of the downloaded file please

Here is what I show…

I too experienced the same error.

1 Like

I looks like it downloads it twice and than fails on the second one. :man_shrugging:

1 Like

The issue should now be fixed, small typo, the cause was found together on our Discord.

Can confirm all files downloaded and verified successfully. Thank you!

1 Like

Deleted all files from download directory then tried again…drive created successfully…will update tomorrow and report…


ANZ here, just installed and so far so good.

Although I didn’t experience the out of storage bug from 22251 (821MB free), I did have a similar bug in Navigation, where a specific setting kept reactivating itself after disabling it. Perhaps that’s fixed in 23088.

Will keep an eye on it and report later.

1 Like

At first I had problems downloading the Sync3 updater ver. beta by itself interrupted the download only after the 4th time it was possible to download the files and rip them to a pendrive. After making a flash drive, the Sync3 updater application always asked if it should change the sync versions in the settings, this time it was not and I have to enter it manually.

The update took over an hour. After the update I had to do a SYNC reset because the station logos disappeared.

1 Like

I updated from 22251 to 23088. I haven’t had time to review it yet, but the radio logos don’t appear, and the calm screen switch has also disappeared from the main screen.

Can you get back the station logo after reset?

Yes, after the reset, the station logos returned.


Thx. I will try that, i have no more time to wait. :slight_smile: It was more than one hour… :slight_smile:

This always happens during “new build” days, servers are rate limited and fail a lot