Sync 3 stuck at "Updating system software"

Have sync 3.4.19274 Non-nav unit trying to upgrade to 3.4.20196.

Whenever I insert the usb, system just stays as “Updating system software” for over an hour with the car on.

Tried different usb’s and master resets before updates but can’t get it to go.

Any suggestions?

Can you post the log.txt file on the USB drive here?

Did you read this tutorial?

At this point you are still at 3.4.19274. Run the Tutorial: APIM Interrogator Utility and attach the xml.

Hello F150Cheif,

Thanks for the reply. Swear I searched everywhere and didn’t see this tutorial.
Will post XML shortly.

RAM=“1491484672” vmcuVersion=“Vector_VMCU_02.02.20”>
<d2p1:PartitionHealth type="/fs/Nuance/" total=“480M” available=“12M”/>
<d2p1:PartitionHealth type="/fs/Nuance/grace" total=“1.0G” available=“57M”/>
<d2p1:PartitionHealth type="/fs/rwdata/" total=“1.2G” available=“996M”/>
<d2p1:PartitionHealth type="/fs/rwdata/quip/" total=“35M” available=“35M”/>
<d2p1:PartitionHealth type="/fs/rwdata/quip/" total=“90M” available=“90M”/>
<d2p1:PartitionHealth type="/fs/mp/" total=“1.4G” available=“146M”/>
<d2p1:PartitionHealth type="/fs/images/" total=“3.0G” available=“1.3G”/>
d2p1:InstallationLog/

Just delete Gracenotes then run the update.

Thanks F150Chief! Got Gracenotes deleted and update worked without a hitch this time.

Now trying to see if I can get gracenotes back. Might not have enough room since I got an error trying to install only that afterwards, but that’s minimal.

Thanks again!

Run the APIM Utility and post the storage.

APIM log after doing a factory reset:

  <d2p1:PartitionHealth type="/fs/Nuance/" total="465M" available="3.1M"/>
  <d2p1:PartitionHealth type="/fs/rwdata/" total="1.2G" available="995M"/>
  <d2p1:PartitionHealth type="/fs/rwdata/quip/" total="35M" available="24M"/>
  <d2p1:PartitionHealth type="/fs/rwdata/quip/" total="90M" available="90M"/>
  <d2p1:PartitionHealth type="/fs/mp/" total="1.4G" available="128M"/>
  <d2p1:PartitionHealth type="/fs/images/" total="3.0G" available="2.4G"/>
  <d2p1:InstallationLog/>

When running an install of just a gracenotes install from Syn3Updater, get a LST_ERR07 error.

Install it manually. You have plenty of storage. Follow the instructions:

That worked! I’m completely updated! Thank you, you’re awesome!

1 Like

Thanks. Enjoy!..,

Can you post the autoinstall, please? I’d like to see why it didn’t work.

Manually created install:
[SYNCGen3.0_ALL]
Item1 = 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Options = Autoinstall

Created using Syn3Updater with only Gracenotes selected.
[SYNCGen3.0_ALL_PRODUCT]
Options = AutoInstall
[SYNCGen3.0_ALL]
Item1 = GRACENOTES - 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Options = Delay,Include,Transaction

Yep. The autoinstall is not right. I’ll have Cyanlabs look into it.

@CyanLabs

Known issue already fixed in the beta version of Syn3 Updater when i get time to finalize the other things it will be released.

1 Like