Sync 3 upgrade from Sync 2 - Nav Stuck in Cologne or no GPS based on the asbuilt I use

Hi all. I have a 2016 C-MAX which I have upgraded from Sync 2 to 3. I also upgraded to Sync 3.4.

I saved the asbuilt from Sync2 prior to installing Sync3 and also saved the Sync3 asbuilt as soon as I installed it. I cannot get the nav to work correctly.

If I use the Sync2 asbuilt the nav stays in one place in Cologne.

If I use the Sync3 asbuilt the nav seems to track my location but I get a “Navigation malfunction” error when the car starts although sometimes it will display the map and show my location but it seems sporadic. I also get a “no gps” signal.

I have tried 2 different GPS antennas and both had the same issue so I am thinking it’s an asbuilt configuration issue.

Is there anything else I can try?

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Retrofit

Old SYNC Version: 2

New SYNC Version: 3.4

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: -

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File



Post your complete as-built values for others to review.

Also, have you looked into these?:

Here are the asbuilts. I am wondering if I should just start again with a similar asbuilt?

Sync2.abt (196 Bytes)

Sync3.abt (401 Bytes)

A) do not post multiple consecutive messages, post a single one with all the information (or use the edit button to add information to a message)
B) have you even looked at what I said before?.

Thanks for your help. I could only add one image per post and didn’t see your comment before I posted the next one.

I’ll review your suggestion and see if that resolves the issue. I appreciate your help.

Ok I checked 7D0-02-01 and that was set to 554B for the UK which is correct.

For the rest of the suggested changes in the ACM asbuilt I only have 727-01-01 and not any of the other ones.

Anything else I can try or a working asbuilt I can apply? I did the GPS strength check and have no signal whatsoever. The no gps icon is on the map.

WF0VXXGCEVJS79814.ab (10.9 KB)

Ok I managed to download an asbuilt from a UK 2019 CMAX using the VIN number. I applied it via forscan (APIM asbuilt) and did a master reset. Still no GPS.

I notice that I can enter the address of a location in the nav and it will plot a route but then the location does not update. Even when I am driving the location will stay on my driveway where I entered the route. To test it I drove around for a mile hoping that maybe it will pick up a signal but it will not. I don’t understand how it can plot a route as I did a master reset and have no connectivity via my phone or wifi.

I’m running Sync 3.4 build 23188 via cyanlabs. The GPS test shows no satellite signal and no history either.

Edit: I’m preparing a USB drive to downgrade to Sync 3.3 based on the comments here, albeit from 2021 (GPS not working after SYNC3 update - Page 6 - Ford Focus Club - Ford Owners Club - Ford Forums)

Downgraded to 3.3 and still cannot get a GPS signal. I left the GPS signal open and briefly saw a signal but it went away before I could get a picture of it. My wife drove the car for 20+ miles today and it didn’t have a GPS signal the entire time so that rules out my driveway being a blackspot.

Anything else I can try please? I’m running out of ideas.

I made some progress on this today, the issue wasn’t down to the APIM. Infact, I believe the GPS antenna to be the issue. When I uncoiled it and ran it out of the car on to the roof using the magnet I got a really healthy signal. As soon as the antenna was placed in the car the signal completely died. Obviously it’s not feasible to run the antenna out of the car so I’ll need to figure something out but at least it proves the APIM isn’t faulty.

One thing I also tried was to disconnect the GPS module which sync 2 uses from behind the rear mirror cover. I’m not sure if this helped or not.

For some reason when I downgraded to 3.3 from 3.4 I don’t have the maps installed anymore. I am going to try 3.4 again and hope the maps are installed as they were before.

One strange thing I did notice however is even with the satellite signal being strong, if I try and set the clock based on the GPS it says “GPS data unavailable”.

First off, the aftermarket antenna’s suck for the most part. Do you by chance have the heated windscreen?

Yes I do have a heated windscreen. I have ordered another (3rd!) GPS antenna just to be sure.

The best way is to find the signal splitter and use an OEM antenna. If you have the heated Windscreen than you may want to let the APIM know that if you haven’t already…

Thank you this certainly helped along with removing the GPSM and relocating the new fakra C GPS antenna in it’s place.

It would have saved me hours if I had just move the aerial outside the car in the first place. Lesson learnt!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.