Sync 3 very laggy but fine with USB stick inserted. Sync 3.0.20204 with EU2.21 maps failing installation

FAO SanD-82 UA (@SaNdMaN) (RE: Discord conversation)

This is the latest Interrogator log
Sync_LW3D00F8_WF0RXXWPGRHM78267.xml (10.3 KB)

Short version: Fords website showed I needed to update my Sync from 2.2 to 3.0 which eventually completed OK, after the installation the Sync was very laggy (10 seconds to register a buttom push) even after a Master Reset so I upload the log file to their website which then said I needed to update my maps which it wasn’t saying originally so I figure this is why my sync is laggy, because the software is up to date but the maps now are not. No matter what I did I couldn’t get the maps to install as it would start the installation then prompt me for a key cycle and every time I cycled it or left it overnight or whatever it would always start the installation again and again prompt me to key cycle so I left the USB stick in the vehicle permenantly for 2 weeks or so so it would keep trying to update itself and hopefully eventually work. This is when I noticed that with the USB inserted (trying to update) the Sync was not at all laggy, it was fine, but when the USB was removed it would instantly lag again to the point it was unuseable.

Now I did say on Discord that the map update did eventually get past the key cycle and did complete but I may have been wrong, i’m sure it said installation complete but now it’s asking me to key cycle again. Can you tell from the log file if the maps have indeed updated?

This is what I see on my screen right now:

Sync 3 software version: 3.0
Gracenote version: (EU-0010)
Navigation maps version: EU 4 15
Sync serial number: LW3D00F8

So as it is my Sync is so laggy it is completely unuseable unless I leave the USB stick in the vehicle with either the Interrogator on it or the Map update on it so its constantly trying to install something in the background, the second I take the USB stick out its laggy again.

For simplicity’s sake I just leave the interrogator on the USB stick in the vehicle to prevent the lag because it throws up less prompts and is quicker than having the map update on the stick constantly trying to install. It’s so odd that I have to have that on the stick and in the vehicle in order to prevent the really bad lag.

SYNC Region: Europe

Navigation Variant: Yes

Install Type: Stock (Original Unit)

Old SYNC Version: 2.2.16280

New SYNC Version: 3.0.20204

Do you have a error message, if so what is it?

Update Method: Official Ford

Syn3 Updater Version:

Syn3 Updater Documentation Read:

Syn3 Updater Log File

1 Like

Hello there, thank you for the information.

So, your unit currently has Sync3 3.0.20204, which is from 2020.
Question: which upgrade method did you use to get up to that build?.
Maps are from 2016 so it seems.

Do you have the upgrade USB you used?, specifically the autoinstall.lst file that’s on the USB’s root.

1 Like

All I’ve done so far is use the offical Ford website by typing my VIN in and insalling the file they give me.

autoinstall.lst (455 Bytes)

The sole reason for updating from 2.2 to 3.0 was because i bought the vehicle used recently and the sync kept forgetting its settings overnight and the place I bought it from said that an update would fix that, and to be fair when updated to 3.0 that issue did actually go away, but as I said after updating to 3.0 it went suoer laggy and Ford then said I needed to update the maps, which is what where I seem to be stuck in a never ending key cycle loop.

I did see a thread on a Kuga forum where someone else had the exact same issue, ie: lag after update to v3 but not laggy if he kept the USB inserted, the thread fizzled out so I’m going to register there and PM him to see what he did in the end.

The autoinstall.lst file you sent before was only to update Gracenotes and Voice_Nav.
So it’s not a full upgrade with maps, which makes sense now.
Both Gracenotes and Voice_Nav packages are correctly installed, so autoinstall.lst was correctly processed and your unit is where Ford wanted it to be with the upgrade.

Just to rule some overhead work going on, perform another master reset WITHOUT ANY DEVICE connected to any USB port. If the lag is due to re-work based on an update USB found again, this should solve it.

And of course, since the update went ok, do not plug the USB again (there’s no need)

But, there’s always a but…

This is never a good sign, ever.
We had cases of failing APIMs presenting these kind of issues, since the issue is hardware based (bad memory sectors, for instance), random stuff would happen. Has a master reset not working, or maybe not erasing user data from the unit (bluetooth information).

1 Like

I have done a master reset this afternoon with no devices attached via usb or bluetooth and the lag was still there. I did just come across another forum post where someone had the same issue, and they were told by Ford that the Sync v3 software didn’t like working well with the old maps so they needed to update their maps, but like me the map update just wouldn’t apply so Ford had to fit a new module. That sound like the direction I’m heading?

Since I did the Sync update I’ve not had a single memory error from what I can see, all settings have stuck.

That depends, is the unit under warranty?.

That’s good to know, but consider that installing new sw on the unit may have changed the physical location of where the data resides.

Based on experience, when there’s something wrong with the eMMC storage, it’s kind of luck if you have issues or not. Maybe you have issues and after a reinstall with reformat those issues will be gone, since unaffected memory is now being used.

Sadly, if multiple master resets were performed and lag is still there, there’s nothing really much to do to the unit. The unit has what the autoinstall.lst file wanted to do, it’s not like it’s missing files.

As long as no component is MY20, the other thing you could try is upgrading to newer builds to see how it behaves. But there’s no turning back once you do, you cannot go back to 3.0.

1 Like

Issue with not having it plugged in is that my system is completely unuseable with it unplugged.

So are we saying my update went OK in the eyes of Ford but technically not OK as the maps are outdated? And that’s what is causing the lag? If so, how on earth am i going to fix that?

Have you tried having a non-úpgrade usb connected?.

The autoinstall.lst file you sent before, does not mention any map, only Voice_NAV and Gracenotes.

; SYNC3 Consumer Application Upgrade - Release 3.0.25 - Only for Nav/EU assemblies.

Item1 = HB5T-14G386-TJB
Open1 = SyncMyRide\HB5T-14G386-TJB.tar.gz
Item2 = JR3T-14G422-BF
Open2 = SyncMyRide\JR3T-14G422-BF.tar.gz
Item3 = JR3T-14G423-AB
Open3 = SyncMyRide\JR3T-14G423-AB.tar.gz
Options = Delay,Include,Transaction
Item1 = GB5T-14G386-AC
Open1 = SyncMyRide\GB5T-14G386-AC.tar.gz
Options = Delay,Include,Transaction

These are the installed packages the unit currently has:

Installed Packages

You can ignore the first and fourth files on the autoinstall.lst file, since they are tools.
But JR3T-14G422-BF and JR3T-14G423-AB are correctly installed.
As you can see, none of them are maps, they are VOICE_NAV and GRACENOTES.

For what’s causing the LAG, I’m not sure. A failing APIM could be the case as stated before, since you mentioned it not remembering some Sync settings.

If you ask me, that incompatibility issue you found online does not seem so solid, but I’m not a Ford expert.

About your old version not remembering some settings, you never lost saved radio stations, right?.

If the unit is not under warranty and you want to try some stuff up, you may consider using Syn3Updater to update everything to newer builds, both Sync and Maps.
But once you do, you “are on your own” regarding Ford, since your car was not meant to have versions past 3.0.

1 Like

I have not tried a non update USB, I’ll go try that shortly.

Weird how no maps were on the install list becasue that whole .rar file came from Ford where they specifically said my maps need updating and to download the file.

The settings it was forgetting were Nav Home and Work locations, Nav Favourites and mobile phone pairing.

It’s not under warranty with Ford no but the used car place I bought it from has given me a 3 month warranty and when I first told them about the memory issue straight away they said it’ll be one of two things, the Sync needs updating or the module needs replacing, well I’ve updated the Sync and the memory is foxed but now it lags real bad. Are my maps actually up to date, like is 2016 the latest maps for me? If not how can I get ahold of the map files to try to update them? If they are up to date should I go back to the dealer and see if they’ll do the module for me?

Just to confirm non update USBs do not get rid of the lag.

Since your unit is under some kind of warranty, I would not mess with it yet then.
Talk to the dealer, mention that now the unit is extremely laggy after the upgrade, which did not happen before, and that you have issues using it like that, since it’s not responsive.

Also, let the unit run for a few days to see if something changes, maybe there’s some kind of background processing that’s still going on (unlikely, but who knows).

Yep, that resides on the APIM. I asked about saved radio stations, since they reside on a different module.

1 Like

I can’t be 100% sure about radio stations but I ‘think’ they were not getting reset. I’'ll call the used car place tomorrow then and see what they say. So would a new module already have the latest versions of everything on or am i going to have to go into update hell again if and when a new module is fitted?

So, sourcing map update files and installing them won’t help you don’t think?

Depends on the unit, really. If it’s an “old” module like yours, it will be on 3.0.
But you can update that (and yours) module to 3.4 with Syn3updater.
And updating is not complex, really.

It’s the first time I’ve read that maps and sync version may be incompatible, so I do not think it would help.

Sorry to come back to the “my unit was not saving settings”, I think that’s the root cause.

Lets wait some days to see if someone else has something to say here, or maybe you will get a response from the other case you mentioned before.

1 Like

They aren’t stored on the APIM ,they are stored on the ACM

1 Like

No no it’s fine, if we’re homing in on the likely cause then it’s all good and . happens we’re actually getting somewhere.

Cool so again this points to a module issue right?

Please ignore